X
Tap here to go to the mobile version of the site.

Support Forum

Changed menu bar colors via options. does not work. stays white on black. hard to read

Posted

I went to options general language and colors then picked new colors. Colors remained the same. white text on black background on menu bar on top. However, in the options it started by saying that I have black text on white background. Which is opposite of what is actually happening. The white text on black background is very difficult to read. The version I use is 64.0.4 for win10 I read related topics did not quite understand the instructions.I need step by step instructions. Could you please help me. Thanks George

I went to options general language and colors then picked new colors. Colors remained the same. white text on black background on menu bar on top. However, in the options it started by saying that I have black text on white background. Which is opposite of what is actually happening. The white text on black background is very difficult to read. The version I use is 64.0.4 for win10 I read related topics did not quite understand the instructions.I need step by step instructions. Could you please help me. Thanks George

Chosen solution

Hi George, your Firefox is saying version 54, not 64. It also sends this weird part I bolded:

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 ds0bXiki-1 Firefox/54.0

Either way, as you know, that's not the current version. To clean up that user agent string, please see the steps in this article: How to reset the default user agent on Firefox.

User Interface Colors

The settings on the Options page are for web pages, not for the toolbar area.

If the problem is with the menu bar at the top of the screen above the tabs, this usually follows your Windows theme. To change that, you can use a different theme. Now, the method is different between Firefox 54 and Firefox 64, but in general, you could try going to the Themes or Appearance section of the Add-ons page as a starting point. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Appearance or Themes, depending on what yours says.

You can try built-in themes listed there (Firefox 57+) or seek out an add-on theme on the Add-ons site:

https://addons.mozilla.org/firefox/themes/

The theme sets both the text color add the background color. Solid themes generally are not too distracting, while highly artistic ones might make text hard to read.

Can you find one that works for you?

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 ds0bXiki-1 Firefox/54.0

More Information

jscher2000
  • Top 10 Contributor
8637 solutions 70661 answers

Chosen Solution

Hi George, your Firefox is saying version 54, not 64. It also sends this weird part I bolded:

Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 ds0bXiki-1 Firefox/54.0

Either way, as you know, that's not the current version. To clean up that user agent string, please see the steps in this article: How to reset the default user agent on Firefox.

User Interface Colors

The settings on the Options page are for web pages, not for the toolbar area.

If the problem is with the menu bar at the top of the screen above the tabs, this usually follows your Windows theme. To change that, you can use a different theme. Now, the method is different between Firefox 54 and Firefox 64, but in general, you could try going to the Themes or Appearance section of the Add-ons page as a starting point. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Appearance or Themes, depending on what yours says.

You can try built-in themes listed there (Firefox 57+) or seek out an add-on theme on the Add-ons site:

https://addons.mozilla.org/firefox/themes/

The theme sets both the text color add the background color. Solid themes generally are not too distracting, while highly artistic ones might make text hard to read.

Can you find one that works for you?

Hi George, your Firefox is saying version 54, not 64. It also sends this weird part I bolded: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 '''ds0bXiki-1''' Firefox/54.0 Either way, as you know, that's not the current version. To clean up that user agent string, please see the steps in this article: [[How to reset the default user agent on Firefox]]. '''User Interface Colors''' The settings on the Options page are for web pages, not for the toolbar area. If the problem is with the menu bar at the top of the screen above the tabs, this usually follows your Windows theme. To change that, you can use a different theme. Now, the method is different between Firefox 54 and Firefox 64, but in general, you could try going to the Themes or Appearance section of the Add-ons page as a starting point. Either: * Ctrl+Shift+a (Mac: Command+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Appearance or Themes, depending on what yours says. You can try built-in themes listed there (Firefox 57+) or seek out an add-on theme on the Add-ons site: https://addons.mozilla.org/firefox/themes/ The theme sets both the text color add the background color. Solid themes generally are not too distracting, while highly artistic ones might make text hard to read. Can you find one that works for you?
Was this helpful to you? 1
Quote

Question owner

This is what helped. Went to menu, add-ons, themes Changed to LIGHT. Worked great. PS the computer I ams itting at says version 66.0.5

Thanks for the help George

This is what helped. Went to menu, add-ons, themes Changed to LIGHT. Worked great. PS the computer I ams itting at says version 66.0.5 Thanks for the help George
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8637 solutions 70661 answers

Sounds good, thanks.

Sounds good, thanks.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157372 answers

Helpful Reply

Did you reset the user agent pref on the about:config page via the right-click context menu to the default value?

  • general.useragent.override

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Did you reset the user agent pref on the <b>about:config</b> page via the right-click context menu to the default value? *general.useragent.override You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
Was this helpful to you? 1
Quote

Question owner

See my reply above. It now works. Thanks everyone. George

See my reply above. It now works. Thanks everyone. George
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.