X
Tap here to go to the mobile version of the site.

Support Forum

All addons disabled for being unsupported

Posted

Suddenly while browsing, I got a bar notification saying that some of my addons had been disabled because they were unsupported. Clicking the button took me to a page that showed no addons, but linked to a page for Legacy Addons in which I found 25 of my addons (That's literally all but 2) have been marked as "not verified for use in Firefox" and disabled, despite literally all of them working mere seconds again and a large majority of them being obtained directly from Mozilla's official addon website! Firefox didn't even receive an update or anything, they just all randomly got flagged out of nowhere for no reason. Why are all of my addons suddenly marked as unverified and disabled, and how can I enable them all again?

(The uploaded image doesn't seem to be showing in the support thread, so here's a direct link https://puu.sh/Dnxlm/b471b782d7.PNG )

Suddenly while browsing, I got a bar notification saying that some of my addons had been disabled because they were unsupported. Clicking the button took me to a page that showed no addons, but linked to a page for Legacy Addons in which I found 25 of my addons (That's literally all but 2) have been marked as "not verified for use in Firefox" and disabled, despite literally all of them working mere seconds again and a large majority of them being obtained directly from Mozilla's official addon website! Firefox didn't even receive an update or anything, they just all randomly got flagged out of nowhere for no reason. Why are all of my addons suddenly marked as unverified and disabled, and how can I enable them all again? (The uploaded image doesn't seem to be showing in the support thread, so here's a direct link https://puu.sh/Dnxlm/b471b782d7.PNG )
Attached screenshots

Modified by EasternSanarise

Chosen solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • Firefox 66.0.3
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0
  • Support URL: https://support.mozilla.org/1/firefox/66.0.3/WINNT/en-US/

Extensions

  • View Image in New Tab 0.2.3 (new-tab-image@exe-boss)
  • Bandcamp Volume 1.3.1 (@bandcamp-volume) (Inactive)
  • Bitwarden - Free Password Manager 1.39.3 ({446900e4-71c2-419f-a6a7-df9c091e268b}) (Inactive)
  • Block Site 4.0.8.2 ({dd3d7613-0246-469d-bc65-2a3cc1668adc}) (Inactive)
  • Don't touch my tabs! (rel=noopener) 2.1 ({6b938c0c-fc53-4f27-805f-619778631082}) (Inactive)
  • Enhanced Steam 10.0 (jid1-YdiFiTEkQgInxA@jetpack) (Inactive)
  • Facebook Container 1.6.5 (@contain-facebook) (Inactive)
  • Image Search Options 3.0.9 ({4a313247-8330-4a81-948e-b79936516f78}) (Inactive)
  • Iridium for YouTube 0.2.5 (iridium@particlecore.github.io) (Inactive)
  • LastPass: Free Password Manager 4.27.2.10 (support@lastpass.com) (Inactive)
  • Mate Translate – translator, dictionary 7.0.6 (jid1-TMndP6cdKgxLcQ@jetpack) (Inactive)
  • MEGA 3.57.9 (firefox@mega.co.nz) (Inactive)
  • minerBlock 1.2.16 (xd4rker@gmail.com) (Inactive)
  • New Tab Override 14.2.0 (newtaboverride@agenedia.com) (Inactive)
  • New XKit 7.8.2 (@new-xkit) (Inactive)
  • PahaelHelper 3.5.0 ({d35f4f8d-6e25-444a-a51e-5091bb776179}) (Inactive)
  • Privacy Badger 2019.2.19 (jid1-MnnxcxisBPnSXQ@jetpack) (Inactive)
  • Px Downloader 3.4.1 ({a3650a89-273e-474b-9e32-46ba5397cf46}) (Inactive)
  • Reddit Enhancement Suite 5.14.5 (jid1-xUfzOsOFlzSOXg@jetpack) (Inactive)
  • Redirector 3.2.1 (redirector@einaregilsson.com) (Inactive)
  • Steam Database 2.1.2 (firefox-extension@steamdb.info) (Inactive)
  • Stylus 1.5.3 ({7a7a4a92-a2a0-41d1-9fd7-1e92480d612d}) (Inactive)
  • Tab Session Manager 4.5.2 (Tab-Session-Manager@sienori) (Inactive)
  • Tab Unloader 2018.8.24 (tab-unloader-we@afnankhan) (Inactive)
  • Tampermonkey 4.9.5921 (firefox@tampermonkey.net) (Inactive)
  • uBlock Origin 1.18.16 (uBlock0@raymondhill.net) (Inactive)
  • View Image for Google Images 0.1.1 ({e3a09cf7-751b-4739-9449-70e7ea23b800}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 1080
  • adapterDescription2:
  • adapterDeviceID: 0x1b80
  • adapterDeviceID2:
  • adapterDrivers: C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumdx.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumdx.dll C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumd.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumd.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumd.dll,C:\Windows\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_37ec54c19854e219\nvldumd.dll
  • adapterDrivers2:
  • adapterRAM: 8192
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • contentUsesTiling: False
  • crashGuards: [{u'prefName': u'gfx.crash-guard.status.wmfvpxvideo', u'type': u'wmfvpxvideo'}]
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.17763.168
  • driverDate: 4-9-2019
  • driverDate2:
  • driverVersion: 25.21.14.2531
  • driverVersion2:
  • failures: [u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.', u'CP+[GFX1-]: WMF VPX video decoding is disabled due to a previous crash.']
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Compositing', u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct2D', u'name': u'DIRECT2D'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'GPU Process', u'name': u'GPU_PROCESS'}, {u'status': u'opt-in', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'description': u'WebRender', u'name': u'WEBRENDER'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'WebRender qualified', u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Off Main Thread Painting', u'name': u'OMTP'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Advanced Layers', u'name': u'ADVANCED_LAYERS'}]}
  • indices: [0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15]
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • lowEndMachine: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • targetFrameRate: 60
  • usesTiling: False
  • webgl1DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_explicit_context GL_ANGLE_explicit_context_gles1 GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_KHR_parallel_shader_compile GL_KHR_robust_buffer_access_behavior GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object OES_compressed_EAC_R11_signed_texture OES_compressed_EAC_R11_unsigned_texture OES_compressed_EAC_RG11_signed_texture OES_compressed_EAC_RG11_unsigned_texture OES_compressed_ETC2_RGB8_texture OES_compressed_ETC2_RGBA8_texture OES_compressed_ETC2_punchthroughA_RGBA8_texture OES_compressed_ETC2_punchthroughA_sRGB8_alpha_texture OES_compressed_ETC2_sRGB8_alpha8_texture OES_compressed_ETC2_sRGB8_texture
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 1080 Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.eff6bfdb1db9)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000013cab) EGL_VERSION: 1.4 (ANGLE 2.1.0.eff6bfdb1db9) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_ANGLE_create_context_extensions_enabled EGL_MOZ_create_context_provoking_vertex_dont_care EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_KHR_debug EGL_ANGLE_explicit_context
  • webgl2DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_explicit_context GL_ANGLE_explicit_context_gles1 GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_multiview GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_KHR_parallel_shader_compile GL_KHR_robust_buffer_access_behavior GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object OES_compressed_EAC_R11_signed_texture OES_compressed_EAC_R11_unsigned_texture OES_compressed_EAC_RG11_signed_texture OES_compressed_EAC_RG11_unsigned_texture OES_compressed_ETC2_RGB8_texture OES_compressed_ETC2_RGBA8_texture OES_compressed_ETC2_punchthroughA_RGBA8_texture OES_compressed_ETC2_punchthroughA_sRGB8_alpha_texture OES_compressed_ETC2_sRGB8_alpha8_texture OES_compressed_ETC2_sRGB8_texture
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 1080 Direct3D11 vs_5_0 ps_5_0)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.eff6bfdb1db9)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 0000000000013cab) EGL_VERSION: 1.4 (ANGLE 2.1.0.eff6bfdb1db9) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_ANGLE_create_context_extensions_enabled EGL_MOZ_create_context_provoking_vertex_dont_care EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses EGL_KHR_debug EGL_ANGLE_explicit_context
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11
  • windowUsingAdvancedLayers: True

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
jscher2000
  • Top 10 Contributor
8637 solutions 70662 answers

The Add-ons team is working on a fix for this. I don't know whether that will involve running an add-on update or something else. We're all hoping to learn soon.

The Add-ons team is working on a fix for this. I don't know whether that will involve running an add-on update or something else. We're all hoping to learn soon.
rosawood 4 solutions 42 answers

I am so pissed about this that I'd like to spit nails. I hope Firefox gets this fixed soon, because I have to open my password keeper in a separate tab to use it. What in the heck happened? Nice to know you're working on it, but I'd like to know how it happened to begin with.

I am so pissed about this that I'd like to spit nails. I hope Firefox gets this fixed soon, because I have to open my password keeper in a separate tab to use it. What in the heck happened? Nice to know you're working on it, but I'd like to know how it happened to begin with.

Question owner

jscher2000 said

The Add-ons team is working on a fix for this. I don't know whether that will involve running an add-on update or something else. We're all hoping to learn soon.

Thank you for the response I sincerely hope they come up with a solution for this soon, because it seems to have affected a LOT of users. I'm also curious as to how a mistake of this magnitude even happens in this first place. As much as Firefox is a good browser, it's nothing without working addons, and having to go without until this is solved is a major inconvenience.

''jscher2000 [[#answer-1217934|said]]'' <blockquote> The Add-ons team is working on a fix for this. I don't know whether that will involve running an add-on update or something else. We're all hoping to learn soon. </blockquote> Thank you for the response I sincerely hope they come up with a solution for this soon, because it seems to have affected a LOT of users. I'm also curious as to how a mistake of this magnitude even happens in this first place. As much as Firefox is a good browser, it's nothing without working addons, and having to go without until this is solved is a major inconvenience.
jscher2000
  • Top 10 Contributor
8637 solutions 70662 answers

Helpful Reply

It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.)

I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.

It looks like a certificate used to sign many popular extensions expired. (The verification process checks that certificate.) I don't know how soon re-signed versions of those extensions will become available, or whether another workaround will be discovered. We are all hoping to learn more soon.
Chesshur 0 solutions 27 answers

After going through what I would describe as troubleshooting hell, I will no longer be using FF after all these years.

Long story short, I was using FF56 Portable due to most of my addons being "legacy" ones (not to mention the now defunct Personas -- which I must have!) and it had gotten so bad that FF's UI mysteriously changed to that of FF60+ and no amount of refreshing, reinstalling, using Mozbackup, or even restarting my PC would fix the situation! I was willing to forgive Mozilla for killing Personas as long as my copy of FF could still use the addon, but not now. Not after what I went through!

I have switched over to Waterfox which is not having any issues whatsoever with FF's addons. So long Firefox!

After going through what I would describe as troubleshooting hell, I will no longer be using FF after all these years. Long story short, I was using FF56 Portable due to most of my addons being "legacy" ones (not to mention the now defunct Personas -- which I must have!) and it had gotten so bad that FF's UI mysteriously changed to that of FF60+ and no amount of refreshing, reinstalling, using Mozbackup, or even restarting my PC would fix the situation! I was willing to forgive Mozilla for killing Personas as long as my copy of FF could still use the addon, but not now. Not after what I went through! I have switched over to Waterfox which is not having any issues whatsoever with FF's addons. So long Firefox!
jscher2000
  • Top 10 Contributor
8637 solutions 70662 answers

Just a note that official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so this option isn't ideal.

Just a note that official updates are expected to be posted here: https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047 Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so this option isn't ideal.
Chesshur 0 solutions 27 answers

I already tried changing the date. That was the first thing I did and it would not work! In my case, I was able to restore FF56 briefly with all addons working but as soon as I starting doing anything in FF, it froze up again and my addons got disabled and the UI changed to FF60+ version again. This time no amount of messing with FF would allow me to use it with ANY addons.

As I said earlier, I will be using Waterfox from now on since it appears to be more stable with addons. I am officially done with FF!

I already tried changing the date. That was the first thing I did and it would not work! In my case, I was able to restore FF56 briefly with all addons working but as soon as I starting doing anything in FF, it froze up again and my addons got disabled and the UI changed to FF60+ version again. This time no amount of messing with FF would allow me to use it with '''ANY''' addons. As I said earlier, I will be using Waterfox from now on since it appears to be more stable with addons. I am officially done with FF!
Chris Ilias
  • Moderator
353 solutions 1941 answers

Chosen Solution

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.
WoodyAutumn 0 solutions 3 answers

Chris Ilias said

... In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked. ...
At first, I could not find Allow Firefox to install and run studies under Privacy and Security. This is located under Privacy & Security => Firefox Data Collection and Use => Allow Firefox to install and run studies.
''Chris Ilias [[#answer-1218435|said]]'' <blockquote> ... In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. ...</blockquote> At first, I could not find '''Allow Firefox to install and run studies''' under Privacy and Security. This is located under Privacy & Security =>''' Firefox Data Collection and Use''' => Allow Firefox to install and run studies.

Modified by WoodyAutumn

McCoy
  • Top 10 Contributor
520 solutions 4894 answers

WoodyAutumn said

I do not see Allow Firefox to install and run studies under Privacy and Security.

When you scroll down to 'Data Collection and Use' you should see that option .....

''WoodyAutumn [[#answer-1218486|said]]'' <blockquote> I do not see '''Allow Firefox to install and run studies''' under Privacy and Security. </blockquote> When you scroll down to 'Data Collection and Use' you should see that option .....
WoodyAutumn 0 solutions 3 answers

McCoy said

WoodyAutumn said
I do not see Allow Firefox to install and run studies under Privacy and Security.

When you scroll down to 'Data Collection and Use' you should see that option .....

This worked! My addons have been re-enabled. I did have to restart Firefox.

Thank you!

''McCoy [[#answer-1218491|said]]'' <blockquote> ''WoodyAutumn [[#answer-1218486|said]]'' <blockquote> I do not see '''Allow Firefox to install and run studies''' under Privacy and Security. </blockquote> When you scroll down to 'Data Collection and Use' you should see that option ..... </blockquote> This worked! My addons have been re-enabled. I did have to restart Firefox. Thank you!
McCoy
  • Top 10 Contributor
520 solutions 4894 answers

WoodyAutumn said

This worked! My addons have been re-enabled. I did have to restart Firefox.

That must be a huge relief  ! (well done, by the way)

''WoodyAutumn [[#answer-1218499|said]]'' <blockquote> This worked! My addons have been re-enabled. I did have to restart Firefox. </blockquote> That must be a huge relief ! (well done, by the way)
Chesshur 0 solutions 27 answers

I have FF56 Portable. Your fix does not work for me. My addons still got disabled. And yes I do have that checked.

I have FF56 Portable. Your fix does not work for me. My addons still got disabled. And yes I do have that checked.
jscher2000
  • Top 10 Contributor
8637 solutions 70662 answers

Chesshur said

I have FF56 Portable. Your fix does not work for me. My addons still got disabled. And yes I do have that checked.

Does Firefox 56 Portable have the "Studies' feature? Possibly that is one of the differences between "Portable" and standard builds.

Ref. About Studies

''Chesshur [[#answer-1218751|said]]'' <blockquote> I have FF56 Portable. Your fix does not work for me. My addons still got disabled. And yes I do have that checked. </blockquote> Does Firefox 56 Portable have the "Studies' feature? Possibly that is one of the differences between "Portable" and standard builds. Ref. [[About Studies]]
Chesshur 0 solutions 27 answers

Yes it does. I have that checked and FF still froze and disabled my addons.

Yes it does. I have that checked and FF still froze and disabled my addons.
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157373 answers

You can run this code (copied from the hotfix) in the Browser Console to install the intermediate certificate.

You can verify success in the Certificate Manager (Authorities tab) under Mozilla Corporation: signingca1.addons.mozilla.org


try {
  let intermediate = "MIIHLTCCBRWgAwIBAgIDEAAIMA0GCSqGSIb3DQEBDAUAMH0xCzAJBgNVBAYTAlVTMRwwGgYDVQQKExNNb3ppbGxhIENvcnBvcmF0aW9uMS8wLQYDVQQLEyZNb3ppbGxhIEFNTyBQcm9kdWN0aW9uIFNpZ25pbmcgU2VydmljZTEfMB0GA1UEAxMWcm9vdC1jYS1wcm9kdWN0aW9uLWFtbzAeFw0xNTA0MDQwMDAwMDBaFw0yNTA0MDQwMDAwMDBaMIGnMQswCQYDVQQGEwJVUzEcMBoGA1UEChMTTW96aWxsYSBDb3Jwb3JhdGlvbjEvMC0GA1UECxMmTW96aWxsYSBBTU8gUHJvZHVjdGlvbiBTaWduaW5nIFNlcnZpY2UxJjAkBgNVBAMTHXNpZ25pbmdjYTEuYWRkb25zLm1vemlsbGEub3JnMSEwHwYJKoZIhvcNAQkBFhJmb3hzZWNAbW96aWxsYS5jb20wggIiMA0GCSqGSIb3DQEBAQUAA4ICDwAwggIKAoICAQC/qluiiI+wO6qGA4vH7cHvWvXpdju9JnvbwnrbYmxhtUpfS68LbdjGGtv7RP6F1XhHT4MU3v4GuMulH0E4Wfalm8evsb3tBJRMJPICJX5UCLi6VJ6J2vipXSWBf8xbcOB+PY5Kk6L+EZiWaepiM23CdaZjNOJCAB6wFHlGe+zUk87whpLa7GrtrHjTb8u9TSS+mwjhvgfP8ILZrWhzb5H/ybgmD7jYaJGIDY/WDmq1gVe03fShxD09Ml1P7H38o5kbFLnbbqpqC6n8SfUI31MiJAXAN2e6rAOM8EmocAY0EC5KUooXKRsYvHzhwwHkwIbbe6QpTUlIqvw1MPlQPs7Zu/MBnVmyGTSqJxtYoklr0MaEXnJNY3g3FDf1R0Opp2/BEY9Vh3Fc9Pq6qWIhGoMyWdueoSYa+GURqDbsuYnk7ZkysxK+yRoFJu4x3TUBmMKM14jQKLgxvuIzWVn6qg6cw7ye/DYNufc+DSPSTSakSsWJ9IPxiAU7xJ+GCMzaZ10Y3VGOybGLuPxDlSd6KALAoMcl9ghB2mvfB0N3wv6uWnbKuxihq/qDps+FjliNvr7C66mIVH+9rkyHIy6GgIUlwr7E88Qqw+SQeNeph6NIY85PL4p0Y8KivKP4J928tpp18wLuHNbIG+YaUk5WUDZ6/2621pi19UZQ8iiHxN/XKQIDAQABo4IBiTCCAYUwDAYDVR0TBAUwAwEB/zAOBgNVHQ8BAf8EBAMCAQYwFgYDVR0lAQH/BAwwCgYIKwYBBQUHAwMwHQYDVR0OBBYEFBY++xz/DCuT+JsV1y2jwuZ4YdztMIGoBgNVHSMEgaAwgZ2AFLO86lh0q+FueCqyq5wjHqhjLJe3oYGBpH8wfTELMAkGA1UEBhMCVVMxHDAaBgNVBAoTE01vemlsbGEgQ29ycG9yYXRpb24xLzAtBgNVBAsTJk1vemlsbGEgQU1PIFByb2R1Y3Rpb24gU2lnbmluZyBTZXJ2aWNlMR8wHQYDVQQDExZyb290LWNhLXByb2R1Y3Rpb24tYW1vggEBMDMGCWCGSAGG+EIBBAQmFiRodHRwOi8vYWRkb25zLm1vemlsbGEub3JnL2NhL2NybC5wZW0wTgYDVR0eBEcwRaFDMCCCHi5jb250ZW50LXNpZ25hdHVyZS5tb3ppbGxhLm9yZzAfgh1jb250ZW50LXNpZ25hdHVyZS5tb3ppbGxhLm9yZzANBgkqhkiG9w0BAQwFAAOCAgEAX1PNli/zErw3tK3S9Bv803RV4tHkrMa5xztxzlWja0VAUJKEQx7f1yM8vmcQJ9g5RE8WFc43IePwzbAoum5F4BTM7tqM//+e476F1YUgB7SnkDTVpBOnV5vRLz1Si4iJ/U0HUvMUvNJEweXvKg/DNbXuCreSvTEAawmRIxqNYoaigQD8x4hCzGcVtIi5Xk2aMCJW2K/6JqkN50pnLBNkPx6FeiYMJCP8z0FIz3fv53FHgu3oeDhi2u3VdONjK3aaFWTlKNiGeDU0/lr0suWfQLsNyphTMbYKyTqQYHxXYJno9PuNi7e1903PvM47fKB5bFmSLyzB1hB1YIVLj0/YqD4nz3lADDB91gMBB7vR2h5bRjFqLOxuOutNNcNRnv7UPqtVCtLF2jVb4/AmdJU78jpfDs+BgY/t2bnGBVFBuwqS2Kult/2kth4YMrL5DrURIM8oXWVQRBKxzr843yDmHo8+2rqxLnZcmWoe8yQ41srZ4IB+V3w2TIAd4gxZAB0Xa6KfnR4D8RgE5sgmgQoK7Y/hdvd9Ahu0WEZI8Eg+mDeCeojWcyjF+dt6c2oERiTmFTIFUoojEjJwLyIqHKt+eApEYpF7imaWcumFN1jR+iUjE4ZSUoVxGtZ/Jdnkf8VVQMhiBA+i7r5PsfrHq+lqTTGOg+GzYx7OmoeJAT0zo4c=";
  let certDB = Cc["@mozilla.org/security/x509certdb;1"].getService(Ci.nsIX509CertDB);
  certDB.addCertFromBase64(intermediate, "", "");
  console.log("new intermediate certificate added");
} catch (e) {
  console.error("failed to add new intermediate certificate:", e);
}
You can run this code (copied from the hotfix) in the Browser Console to install the intermediate certificate. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Browser_Console You can verify success in the Certificate Manager (Authorities tab) under Mozilla Corporation: signingca1.addons.mozilla.org <hr> <pre><nowiki>try { let intermediate = "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"; let certDB = Cc["@mozilla.org/security/x509certdb;1"].getService(Ci.nsIX509CertDB); certDB.addCertFromBase64(intermediate, "", ""); console.log("new intermediate certificate added"); } catch (e) { console.error("failed to add new intermediate certificate:", e); }</nowiki></pre>
rosawood 4 solutions 42 answers

Chris Ilias said

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled
  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.
I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated.

I made sure that studies is check marked but so far (2 hours) nothing has happened. I'm not sure if I[m supposed to leave my computer running all night, but that's not going to happen, as I turn off the modem at night.

''Chris Ilias [[#answer-1218435|said]]'' <blockquote> Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps. In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled # Go to '''[=] > Options > Privacy & Security'''. # Make sure '''Allow Firefox to install and run studies''' is check marked. I you had it disabled, you can disable studies again after your add-ons have been re-enabled. They are working on a general fix that doesn't need to rely on this and will keep you updated. </blockquote> I made sure that studies is check marked but so far (2 hours) nothing has happened. I'm not sure if I[m supposed to leave my computer running all night, but that's not going to happen, as I turn off the modem at night.
cor-el
  • Top 10 Contributor
  • Moderator
17418 solutions 157373 answers

Note that you should reset the time to the correct time to prevent all kind of issues like with OCSP responses.

Note that you should reset the time to the correct time to prevent all kind of issues like with OCSP responses.
Chesshur 0 solutions 27 answers

cor-el said

You can run this code (copied from the hotfix) in the Browser Console to install the intermediate certificate. You can verify success in the Certificate Manager (Authorities tab) under Mozilla Corporation: signingca1.addons.mozilla.org
try {
  let intermediate = "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";
  let certDB = Cc["@mozilla.org/security/x509certdb;1"].getService(Ci.nsIX509CertDB);
  certDB.addCertFromBase64(intermediate, "", "");
  console.log("new intermediate certificate added");
} catch (e) {
  console.error("failed to add new intermediate certificate:", e);
}

I added the certificate, however half of my addons are still disabled. I definitely will be sticking with Waterfox from now on.

''cor-el [[#answer-1219001|said]]'' <blockquote> You can run this code (copied from the hotfix) in the Browser Console to install the intermediate certificate. *"3-bar" menu button or Tools -> Web Developer *https://developer.mozilla.org/en-US/Tools/Browser_Console You can verify success in the Certificate Manager (Authorities tab) under Mozilla Corporation: signingca1.addons.mozilla.org <hr> <pre><nowiki>try { let intermediate = "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"; let certDB = Cc["@mozilla.org/security/x509certdb;1"].getService(Ci.nsIX509CertDB); certDB.addCertFromBase64(intermediate, "", ""); console.log("new intermediate certificate added"); } catch (e) { console.error("failed to add new intermediate certificate:", e); }</nowiki></pre> </blockquote> I added the certificate, however half of my addons are still disabled. I definitely will be sticking with Waterfox from now on.
Chesshur 0 solutions 27 answers

Uninstalled FF56 Portable and did a clean install of the regular version of FF56. Then added your code and this addon Hotfix-update-xpi-intermediate 1.0.2. Half my addons were still disabled, but I attempted to re-download them and now they are back to normal!

[Edit] That didn't work with FF56 Portable, but the odd thing is that when I copied the profile of the regular FF56 into the profile folder for FF56 Portable, everything was back to normal on FF56 Portable. So far, so good. No freezing or disabling of addons as of this typing.

Uninstalled FF56 Portable and did a clean install of the regular version of FF56. Then added your code and this addon [https://storage.googleapis.com/moz-fx-normandy-prod-addons/extensions/hotfix-update-xpi-intermediate%40mozilla.com-1.0.2-signed.xpi Hotfix-update-xpi-intermediate 1.0.2]. Half my addons were still disabled, but I attempted to re-download them and now they are back to normal! [Edit] That didn't work with FF56 Portable, but the odd thing is that when I copied the profile of the regular FF56 into the profile folder for FF56 Portable, everything was back to normal on FF56 Portable. So far, so good. No freezing or disabling of addons as of this typing.

Modified by Chesshur