Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox displays checkered gray grid and won't show certain content from webpage

  • 2 replies
  • 1 has this problem
  • Last reply by cor-el

more options

I need help determining what is causing Firefox to not display certain content in webpages and is putting a checkered grid in place of external content.

See screenshot of image below. What is causing the checkered grid to show. I see the image for the briefest of time when loading the webpage, then the checkered grid appears in the place of the image. This is not the only online site for which this occurs. If I disable all my plugins, I get a similar issue. If I turn off content blocking, I still get this issue.

I am using ublock origin, and umatrix.

If I load the page in a private view, then the checkered grid disappears. If I create a new tab and load the page, the check grid is now gone too, but if I reload the page with the checkered gray grid pattern, the checkered grid pattern is still there. The inconsistency is baffling me.

Attached screenshots

Modified by TCx00

All Replies (2)

more options


Modified by TCx00

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window