X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Support Forum

Tabs not showing

Posted

My tab bar shows no tab whatsover, I tried pressing cntrl t or opening a link and nothing happens. Happens after updating to 66.0

My tab bar shows no tab whatsover, I tried pressing cntrl t or opening a link and nothing happens. Happens after updating to 66.0

Chosen solution

What about userChrome.css?

If you are using a userChrome.css file, with Firefox 66 that is the most likely culprit. The code for "tabs" was changed for 66 and the user would need to fix that code for compatibility going forward from Fx65.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

the-edmeister
  • Top 25 Contributor
  • Moderator
5386 solutions 39975 answers

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.


Another thing to look at is the optional userChrome.css file if you are using one. The code for the Tab Bar was changes a bit in Firefox 66 and has caused an issue for a few users who posted here in the last week.

'''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Another thing to look at is the optional userChrome.css file if you are using one. The code for the Tab Bar was changes a bit in Firefox 66 and has caused an issue for a few users who posted here in the last week.
Was this helpful to you? 0
Quote

Question owner

the-edmeister said

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:
  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.
If Firefox is not running, you can start Firefox in Safe Mode as follows:
  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
When the Firefox Safe Mode window appears, select "Start in Safe Mode".
SafeMode-Fx35
If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause. To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again. When you figure out what's causing your issues, please let us know. It might help others with the same problem. Another thing to look at is the optional userChrome.css file if you are using one. The code for the Tab Bar was changes a bit in Firefox 66 and has caused an issue for a few users who posted here in the last week.

Hi, thanks for the answer.

Starting in safe mode the bar works. I tried to disable all extensions and disable hardware acceleration as said in the troubleshoot, and started again with the same problem

''the-edmeister [[#answer-1207082|said]]'' <blockquote> '''Try Firefox Safe Mode''' to see if the problem goes away. [[Troubleshoot Firefox issues using Safe Mode|Firefox Safe Mode]] is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). '''If Firefox is open,''' you can restart in Firefox Safe Mode from the Help menu: * Click the menu button [[Image:New Fx Menu]], click Help [[Image:Help-29]] and select ''Restart with Add-ons Disabled''. '''If Firefox is not running,''' you can start Firefox in Safe Mode as follows: * On Windows: Hold the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac: Hold the '''option''' key while starting Firefox. * On Linux: Quit Firefox, go to your Terminal and run ''firefox -safe-mode'' <br>(you may need to specify the Firefox installation path e.g. /usr/lib/firefox) When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] article to find the cause. ''To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' When you figure out what's causing your issues, please let us know. It might help others with the same problem. Another thing to look at is the optional userChrome.css file if you are using one. The code for the Tab Bar was changes a bit in Firefox 66 and has caused an issue for a few users who posted here in the last week. </blockquote> Hi, thanks for the answer. Starting in safe mode the bar works. I tried to disable all extensions and disable hardware acceleration as said in the troubleshoot, and started again with the same problem
Was this helpful to you? 1
Quote
the-edmeister
  • Top 25 Contributor
  • Moderator
5386 solutions 39975 answers

Chosen Solution

What about userChrome.css?

If you are using a userChrome.css file, with Firefox 66 that is the most likely culprit. The code for "tabs" was changed for 66 and the user would need to fix that code for compatibility going forward from Fx65.

What about '''userChrome.css'''? If you are using a userChrome.css file, with Firefox 66 that is the most likely culprit. The code for "tabs" was changed for 66 and the user would need to fix that code for compatibility going forward from Fx65.
Was this helpful to you? 1
Quote

Question owner

the-edmeister said

What about userChrome.css? If you are using a userChrome.css file, with Firefox 66 that is the most likely culprit. The code for "tabs" was changed for 66 and the user would need to fix that code for compatibility going forward from Fx65.

Worked. Thanks a lot. I didn't created that file (that's why I didn't even checked if it was the problem), don't know how it was there

''the-edmeister [[#answer-1207173|said]]'' <blockquote> What about '''userChrome.css'''? If you are using a userChrome.css file, with Firefox 66 that is the most likely culprit. The code for "tabs" was changed for 66 and the user would need to fix that code for compatibility going forward from Fx65. </blockquote> Worked. Thanks a lot. I didn't created that file (that's why I didn't even checked if it was the problem), don't know how it was there
Was this helpful to you?
Quote
lompos 0 solutions 1 answers

How can i do that?

How can i do that?
Was this helpful to you?
Quote

Question owner

lompos said

How can i do that?

Go to your profile folder and find a chrome folder, the file will be there. http://kb.mozillazine.org/Profile_folder

''lompos [[#answer-1219330|said]]'' <blockquote> How can i do that? </blockquote> Go to your profile folder and find a chrome folder, the file will be there. http://kb.mozillazine.org/Profile_folder
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.