Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

JavaScript is Enabled in Config Settings, but some sites load as blanks. As I View Source, I notice the script reading how JS is not supported etc.

  • 7 replies
  • 1 has this problem
  • 23 views
  • Last reply by jscher2000

more options

Please help.

All Replies (7)

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !


Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

@ Fred - Disabling Add-ons worked in Safe Mode. I was able to view the sites blocked before etc. Now I just have to figure out which one of them is the culprit. Any idea how?

more options

@ Fred – Actually I think I discovered what it is:

This add-on (screenshot attached) is causing issues with JS. It is so critical for me to use though. How do I get around this?

more options

That was very good work. Well done. I called for more help.

more options

It is not very likely the multi-container tabs are causing issues with JavaScript not working properly. This extension only supports container that make it possible to isolate websites that open in another group.

If there are issues with JavaScript not working then this is more likely caused by an extension that blocks content like Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin.

Can you list your extensions?

more options

cor-el said

It is not very likely the multi-container tabs are causing issues with JavaScript not working properly. This extension only supports container that make it possible to isolate websites that open in another group. If there are issues with JavaScript not working then this is more likely caused by an extension that blocks content like Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin. Can you list your extensions?


Yes here they are, attached

more options

Hi FirefoxWhodi, I imagine containers might cause an issue if you restrict Site A from using scripts from Site B (or cookies from Site B) by forcing them into separate containers. I haven't experimented with it myself.