X
Tap here to go to the mobile version of the site.

Support Forum

Allow Cookies for TwoFactAuth (2FA)

Posted

Hallo, I want to use 2FA with amazon.de. When I close firefox I will all cookies be deleted. I always must enter the twofactauth, amazon doen't remember my PC, I think because I delete the cookies.

Now my questions: 1.) Is it right, that a 2FA company remeber the PC in a cookie? 2.) How can I prevent only these cookies from being deleted? I do not want to allow all cookies.

Hallo, I want to use 2FA with amazon.de. When I close firefox I will all cookies be deleted. I always must enter the twofactauth, amazon doen't remember my PC, I think because I delete the cookies. Now my questions: 1.) Is it right, that a 2FA company remeber the PC in a cookie? 2.) How can I prevent only these cookies from being deleted? I do not want to allow all cookies.

Chosen solution

Hi Rolmei, turn off the feature to delete history when you close Firefox. Or if you want to use this feature for some kinds of history, go into the settings for the feature and make sure you are not removing either Cookies or Site Preferences. I don't know what they are called in your language, but here's an English screenshot.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

WestEnd 60 solutions 5387 answers

Did you check your Privacy and history setting to make sure they aren't deleting cookies and history and tracking? I use Amazon on both Chrome and Firefox and don't have problem signing out and back with saved logins.

Did you check your Privacy and history setting to make sure they aren't deleting cookies and history and tracking? I use Amazon on both Chrome and Firefox and don't have problem signing out and back with saved logins.

Question owner

Hallo, thank you for your answer. But I want to delete all other cookies when closing the browser except amazon

Hallo, thank you for your answer. But I want to delete all other cookies when closing the browser except amazon
TippyToe 0 solutions 6 answers

Select 'Delete cookies and site data when Firefox is closed' then under 'manage permissions' copy and paste the amazon url and select 'allow'

Select 'Delete cookies and site data when Firefox is closed' then under 'manage permissions' copy and paste the amazon url and select 'allow'

Question owner

When I enter and save cookie authority, these permissions have disappeared after firefox rebooted. How can this be?

When I enter and save cookie authority, these permissions have disappeared after firefox rebooted. How can this be?

Modified by Rolmei

christ1
  • Top 25 Contributor
2198 solutions 16064 answers
You can specify which websites are always or never allowed to use cookies and site data. Type the exact address of the site you want to manage and then click Block, Allow for Session, or Allow.

Note the term exact above. To my knowledge Amazon sites use https URLs, not http.

You may also want to take a look at this extension. https://addons.mozilla.org/en-US/firefox/addon/cookie-autodelete/

<blockquote> You can specify which websites are always or never allowed to use cookies and site data. Type the exact address of the site you want to manage and then click Block, Allow for Session, or Allow. </blockquote> Note the term '''exact''' above. To my knowledge Amazon sites use https URLs, not http. You may also want to take a look at this extension. https://addons.mozilla.org/en-US/firefox/addon/cookie-autodelete/

Modified by christ1

Question owner

the problem is, that firefox loses the exceptions after a reboot of firefox. 1.picture save exception 2.picture after reboot firefox

the problem is, that firefox loses the exceptions after a reboot of firefox. 1.picture save exception 2.picture after reboot firefox

Modified by Rolmei

McCoy
  • Top 10 Contributor
578 solutions 5391 answers

Hello Rolmei,

Would you give this a try please (if you haven't already) :

When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Does that work  ?

Hello Rolmei, Would you give this a try please (if you haven't already) : When you're on that site, click on the 'i' in a circle, next to the padlock at the left side of the address bar. Then click on the little black arrow on the dropdown and then on "More Information", which will take you to "Page Info". Click on the 'Permissions" tab and scroll down to "Set Cookies". Uncheck "Use Default" and check "Allow". Then close and restart Firefox. Does that work ?
jscher2000
  • Top 10 Contributor
8838 solutions 72234 answers

Chosen Solution

Hi Rolmei, turn off the feature to delete history when you close Firefox. Or if you want to use this feature for some kinds of history, go into the settings for the feature and make sure you are not removing either Cookies or Site Preferences. I don't know what they are called in your language, but here's an English screenshot.

Hi Rolmei, turn off the feature to delete history when you close Firefox. Or if you want to use this feature for some kinds of history, go into the settings for the feature and make sure you are not removing either Cookies or Site Preferences. I don't know what they are called in your language, but here's an English screenshot.
TippyToe 0 solutions 6 answers

According to the screenshots you posted you have 'Content Blocking' set to 'Custom' and you are automatically blocking Trackers and Cookies. It is better to keep the settings to 'Standard' and instead select 'Delete cookies and site data when Firefox is closed', then under 'Manage Permissions' copy and paste the url into the address bar and select 'Allow'.

According to the screenshots you posted you have 'Content Blocking' set to 'Custom' and you are automatically blocking Trackers and Cookies. It is better to keep the settings to 'Standard' and instead select 'Delete cookies and site data when Firefox is closed', then under 'Manage Permissions' copy and paste the url into the address bar and select 'Allow'.
cor-el
  • Top 10 Contributor
  • Moderator
17690 solutions 160039 answers

The screenshot you posted above shows you created the exception for http: domains and not for https: domains like you should.

Second screenshot:

The screenshot you posted above shows you created the exception for http: domains and not for https: domains like you should. Second screenshot: *https://support.mozilla.org/en-US/questions/1251671#answer-1201597