X
Tap here to go to the mobile version of the site.

Support Forum

My Firefox 65.0.1 will not link to Costco signin screen https://www.costco.com/LogonForm ...(my alternate browsers will; Costco says Firefox is the problem)

Posted

Costco sign-in stopped working a few weeks ago (not sure, but I suspect it was a change in Firefox release). If I click the sign-in link on the costco.com website, nothing happens. Same if I try to go directly to that sign-in url (https://www.costco.com/LogonForm). I called Costco and was told the problem is known to them and is a Firefox browser issue. I have other browsers installed and they do not have the problem (Cyberfox, Opera, Avast, Chrome)

Costco sign-in stopped working a few weeks ago (not sure, but I suspect it was a change in Firefox release). If I click the sign-in link on the costco.com website, nothing happens. Same if I try to go directly to that sign-in url (https://www.costco.com/LogonForm). I called Costco and was told the problem is known to them and is a Firefox browser issue. I have other browsers installed and they do not have the problem (Cyberfox, Opera, Avast, Chrome)
Attached screenshots

Chosen solution

Hello car-nuts,

You may have a point about the cookies .....

Would you try this please :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")

You may also want to check the settings of your security software (if you have any). And the same goes for Options => Privacy & Security => Content Blocking.

Then there is your uBlock Origin - maybe you could check its settings as well .....

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

WestEnd
  • Top 25 Contributor
60 solutions 5377 answers

I have no issue with firefox, IE12, chrome, edge. I suspect they do that to not find out where the problem is. But firefox 65.0.1 has no issue when I try it. Also if that was the case we also hear more users commenting on the problem login as well.

I have no issue with firefox, IE12, chrome, edge. I suspect they do that to not find out where the problem is. But firefox 65.0.1 has no issue when I try it. Also if that was the case we also hear more users commenting on the problem login as well.
FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

Please explain the problem in detail. What happens? What is the exact error messages?

Please explain the problem in detail. What happens? What is the exact error messages?

Question owner

WestEnd: Thanks for letting me know your Firefox 65.0.1 has no issue; that means my Firefox has a problem, but what is that problem? I did try clearing cookies in Options/Privacy&Security, but I will try again.

FredMcD: my issue is that if I go to costco.com (3rd screenshot above, which is Firefox, the first 2 are other browsers) and click the sign-on link on that page (to the right of the search field), nothing happens... I remain on that page (when I expect to go to costco.com/LogonForm, 1st & 2nd screenshots above, which were taken from from other browsers). If I start with a fresh startup of Firefox and type in the url "costco.com/LogonForm" and press enter, I again get the "costco.com" page instead (so again I cannot log into my Costco account using Firefox). My other browsers act normally.

I am posting another image of my Firefox, which is showing url of "Costco.com/LogonForm" (I typed that url address in and hit enter) but it goes instead to the "Costco.com" page. Clicking on the "Sign In / Register" icon takes me to this same screen, not to the Costco login screen.

I'm thinking now it must be a cookies issue (I thought I'd eliminated that possibility by clearing cookies), so I'll revisit that.

WestEnd: Thanks for letting me know ''your'' Firefox 65.0.1 has no issue; that means ''my'' Firefox has a problem, but what is that problem? I did try clearing cookies in Options/Privacy&Security, but I will try again. FredMcD: my issue is that if I go to costco.com (3rd screenshot above, which is Firefox, the first 2 are other browsers) and click the sign-on link on that page (to the right of the search field), nothing happens... I remain on that page (when I expect to go to costco.com/LogonForm, 1st & 2nd screenshots above, which were taken from from other browsers). If I start with a fresh startup of Firefox and type in the url "costco.com/LogonForm" and press enter, I again get the "costco.com" page instead (so again I cannot log into my Costco account using Firefox). My other browsers act normally. I am posting another image of my Firefox, which is showing url of "Costco.com/LogonForm" (I typed that url address in and hit enter) but it goes instead to the "Costco.com" page. Clicking on the "Sign In / Register" icon takes me to this same screen, not to the Costco login screen. I'm thinking now it must be a cookies issue (I thought I'd eliminated that possibility by clearing cookies), so I'll revisit that.
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

Chosen Solution

Hello car-nuts,

You may have a point about the cookies .....

Would you try this please :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")

You may also want to check the settings of your security software (if you have any). And the same goes for Options => Privacy & Security => Content Blocking.

Then there is your uBlock Origin - maybe you could check its settings as well .....

Hello car-nuts, You may have a point about the cookies ..... Would you try this please : Clear the Firefox cache : https://support.mozilla.org/en-US/kb/how-clear-firefox-cache "Remove the cookies" from websites that cause problems : https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site") You may also want to check the settings of your security software (if you have any). And the same goes for Options => Privacy & Security => Content Blocking. Then there is your uBlock Origin - maybe you could check its settings as well .....
FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

If the above does not help, Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

If the above does not help, [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

McCoy's solution appears to have worked. Thanks!

McCoy's solution appears to have worked. Thanks!
McCoy
  • Top 10 Contributor
525 solutions 4913 answers

car-nuts said

McCoy's solution appears to have worked. Thanks!

My pleasure, car-nuts - that sure puts a smile on my face  !

''car-nuts [[#answer-1199926|said]]'' <blockquote> McCoy's solution appears to have worked. Thanks! </blockquote> My pleasure, car-nuts - that sure puts a smile on my face !

Question owner

Well, I spoke too soon. McCoy's solution did work that one time, but now I'm back to where I started:

Costco.com/LogonForm takes me to Costco.com, and clicking the Sign-on/Register field on that page does nothing.

I found this link that seemed to hold some promise without deleting all my cookies, but it did not work, either:

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox?redirectlocale=en-US&redirectslug=delete-cookies-remove-info-websites-stored#w_clear-cookies-for-the-current-website (Clear cookies for any website section)

I also tried clearing recent history cache, also unsuccessful...

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache#w_automatically-clear-the-cache

I cannot be erasing all my cookies every time I want to sign on to Costco, there has to be a better solution.

This was not an issue for me until something changed, either one of the more recent upgrades by Firefox (as Costco indicates), or a change by Costco that only affects Firefox (unlikely).

It is a serious annoyance, Is there a way I can go back to a prior (2018) release of Firefox and prevent it from upgrading itself to the latest release?

Well, I spoke too soon. McCoy's solution did work that one time, but now I'm back to where I started: Costco.com/LogonForm takes me to Costco.com, and clicking the Sign-on/Register field on that page does nothing. I found this link that seemed to hold some promise without deleting ''all'' my cookies, but it did not work, either: https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox?redirectlocale=en-US&redirectslug=delete-cookies-remove-info-websites-stored#w_clear-cookies-for-the-current-website (''Clear cookies for any website'' section) I also tried clearing recent history cache, also unsuccessful... https://support.mozilla.org/en-US/kb/how-clear-firefox-cache#w_automatically-clear-the-cache I cannot be erasing ''all ''my cookies every time I want to sign on to Costco, there has to be a better solution. This was not an issue for me until something changed, either one of the more recent upgrades by Firefox (as Costco indicates), or a change by Costco that only affects Firefox (unlikely). It is a serious annoyance, Is there a way I can go back to a prior (2018) release of Firefox and prevent it from upgrading itself to the latest release?

Modified by car-nuts

FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

Clear the cache and cookies as directed. Does the issue return?

Clear the cache and cookies as directed. Does the issue return?
jscher2000
  • Top 10 Contributor
8643 solutions 70721 answers

Are you able to fill and submit the form on this page:

https://www.costco.com/LogonForm

It is normal to be redirected from there back to the main page, but then it should say "My Account" instead of sign in on the top bar. At least, that's what I see in Firefox 65.

To bypass cache and cookies for a site, you can try accessing it in a private window. You can call that up using Ctrl+Shift+p.

Are you able to fill and submit the form on this page: https://www.costco.com/LogonForm It is normal to be redirected from there back to the main page, but then it should say "My Account" instead of sign in on the top bar. At least, that's what I see in Firefox 65. To bypass cache and cookies for a site, you can try accessing it in a private window. You can call that up using Ctrl+Shift+p.

Question owner

Reply to Fred McD:

Yes, see my reply (3rd above) to McCoy when I thought the issue was resolved. It's back.

If I erase all cookies and history, it will take me to the Costco login screen once (go to Costco.com and click the Sign-in/Register link field, or type in url Costco.com/LogonForm in the Firefox url field); after that one time, it only goes to the Costco.com webpage and so I am back into the same problem.

Deleting just the Costco cookies and my recent history does not then allow me to get to the Costco.com/LogonForm screen. I cannot live with deleting ALL cookies every time I want to get to the Costco login screen, because once I successfully log in to Costco, every time thereafter I have to remember every userid and password for every website I've signed in to before.

Again, I DO NOT have this problem with any other browser I've tried.

Reply to Jscher2000:

I have 65.0.2 Once I have the problem, going to that Https://www.costco.com/LogonForm url (even in a private window) only takes me to the Costco.com page, not the logon page.

Reply to Fred McD: Yes, see my reply (3rd above) to McCoy when I thought the issue was resolved. It's back. If I erase all cookies and history, it will take me to the Costco login screen once (go to Costco.com and click the Sign-in/Register link field, ''or'' type in url Costco.com/LogonForm in the Firefox url field); after that one time, it only goes to the Costco.com webpage and so I am back into the same problem. Deleting just the Costco cookies and my recent history does not then allow me to get to the Costco.com/LogonForm screen. I cannot live with deleting ALL cookies every time I want to get to the Costco login screen, because once I successfully log in to Costco, every time thereafter I have to remember every userid and password for every website I've signed in to before. Again, I DO NOT have this problem with any other browser I've tried. ***** Reply to Jscher2000: I have 65.0.2 Once I have the problem, going to that Https://www.costco.com/LogonForm url (even in a private window) only takes me to the Costco.com page, not the logon page.

Modified by car-nuts

jscher2000
  • Top 10 Contributor
8643 solutions 70721 answers

Hi car-nuts, did you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Hi car-nuts, did you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?

Question owner

Reply to jscher2000

It DID work in safe mode. So, I guess I need to restart Firefox in normal mode and start disabling/re-enabling add-ons one by one (I have 11 add-ons), looking for a culprit?

Reply to jscher2000 It DID work in safe mode. So, I guess I need to restart Firefox in normal mode and start disabling/re-enabling add-ons one by one (I have 11 add-ons), looking for a culprit?
jscher2000
  • Top 10 Contributor
8643 solutions 70721 answers

Helpful Reply

Checking extensions is the most logical thing to do. I think privacy-related ones would be worth checking first, but you might be able to tell from their toolbar buttons whether they dislike any of the third-party scripts used on Costco's site.

Checking extensions is the most logical thing to do. I think privacy-related ones would be worth checking first, but you might be able to tell from their toolbar buttons whether they dislike any of the third-party scripts used on Costco's site.

Question owner

It appears that an add-on named "AdsBlocker for Firefox" is the culprit. I've turned it off.

Thank you for that suggestion!

It appears that an add-on named "AdsBlocker for Firefox" is the culprit. I've turned it off. Thank you for that suggestion!