X
Tap here to go to the mobile version of the site.

Support Forum

I want to download java from this

Posted

Hi,

I want to download java from this "https://java.com/en/download/windows-64bit.jsp but I am getting this alert message before download We have detected you are using the 64-bit version of Firefox which will not run the Java plugin from this browser. More info

I have downloaded this firefox version 65.0.1 (64-bit)

Can you please help me in resolving this error??

Thank you in anticipation.

Hi, I want to download java from this "https://java.com/en/download/windows-64bit.jsp but I am getting this alert message before download We have detected you are using the 64-bit version of Firefox which will not run the Java plugin from this browser. More info I have downloaded this firefox version 65.0.1 (64-bit) Can you please help me in resolving this error?? Thank you in anticipation.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:65.0) Gecko/20100101 Firefox/65.0

More Information

FredMcD
  • Top 10 Contributor
4313 solutions 60582 answers

All Firefox v52+ Releases disables all plugins except for Flash Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? {web link}

All Firefox v52+ Releases disables all plugins except for Flash [https://support.mozilla.org/en-US/kb/npapi-plugins Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work?] {web link}
James
  • Top 25 Contributor
  • Moderator
1603 solutions 11348 answers

A correction to above comment about "All Firefox v52+" as the exception was the now EOL Firefox 52 ESR (52.9.0esr was the last).

Also for Windows users you needed to use the 32-bit Firefox back then as the Win64 Firefox only allowed the Flash and Silverlight NPA. Plugins to run then.

Now as mentioned the only NPAPI allowed to run in Firefox now is the Flash Player Plugin from Adobe will run regardless if you are using a 32-bit or 64-bit version.

Is there a reason why you think you need the Java Plugin form Oracle to run in Firefox?. Note it has nothing to with JavaScript built in Firefox.

There is the Java Web Start option but I have not used it.

A correction to above comment about "All Firefox v52+" as the exception was the now EOL Firefox 52 ESR (52.9.0esr was the last). Also for Windows users you needed to use the 32-bit Firefox back then as the Win64 Firefox only allowed the Flash and Silverlight NPA. Plugins to run then. Now as mentioned the only NPAPI allowed to run in Firefox now is the Flash Player Plugin from Adobe will run regardless if you are using a 32-bit or 64-bit version. Is there a reason why you think you need the Java Plugin form Oracle to run in Firefox?. Note it has nothing to with JavaScript built in Firefox. There is the Java Web Start option but I have not used it.

Modified by James

Pj 42 solutions 869 answers

meenakshisal said

I want to download Java...

Java is not the 'cool' thing anymore. Security issues with it. Any website still running it should've dumped it long ago. I haven't used Java for years now. Don't miss it, as other platforms are out there.

As the other post stated, Java will not run with 64-Bit FireFox. The error message is correct in that Java won't work with 64-Bit FireFox.


~Pj

''meenakshisal [[#question-1250179|said]]'' <blockquote> I want to download Java... </blockquote> '''Java''' is not the 'cool' thing anymore. Security issues with it. Any website still running it should've dumped it long ago. I haven't used Java for years now. Don't miss it, as other platforms are out there. As the other post stated, Java will not run with 64-Bit FireFox. The error message is correct in that Java won't work with 64-Bit FireFox. ~Pj
James
  • Top 25 Contributor
  • Moderator
1603 solutions 11348 answers

Pj said

As the other post stated, Java will not run with 64-Bit FireFox. The error message is correct in that Java won't work with 64-Bit FireFox.

It will not run on any 64-bit or 32-bit version of Firefox for Windows, Mac OSX and Linux since the Firefox 52.0 Release.

''Pj [[#answer-1197492|said]]'' <blockquote> As the other post stated, Java will not run with 64-Bit FireFox. The error message is correct in that Java won't work with 64-Bit FireFox. </blockquote> It will not run on any 64-bit or 32-bit version of Firefox for Windows, Mac OSX and Linux since the Firefox 52.0 Release.