Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After most recent Firefox update, can't sign into TD Ameritrade website, can't display full content on various United Healthcare web pages, Yahoo Finance not di

  • 6 replies
  • 1 has this problem
  • 8 views
  • Last reply by bashwk

more options

After the last few updates of Firefox I am having increasing trouble using some websites, TD Ameritrade, United Healthcare, and Yahoo Finance. I have the latest update on High Sierra 10.13.6 and Firefox 65.0. United healthcare problem started about 5 months ago when some of the pages would partially load or not load at all. Clearing cache and cookies, etc. used to solve that problem, but not any more. Problem still persists. Then after another update about a month ago, Yahoo Finance pages showed truncated column shown and inability to scroll to bottom of editing windows to save changes. That seem to resolve after about 2 week and full screens reappeared. But the Yahoo Finance problems came back after Firefox most recent update. Also, about a month ago my TD Ameritrade website started to load very slowly about the time the Yahaoo problem became worse. Now, after the latest update, I get the the login page, but after inputting the id and password, website never connects---justs gives me a blank page that never loads. In summary, I have 3 important websites that I cannot access or navigate using Firefox, BUT CAN ACCESS AND NAVIGATE USING SAFARI. I prefer, and been a loyal user/promoter of Mozilla products for decades especially for their versatility, and superior security. I hope that something can be done, so that these important sites will again fully function using Firefox.

All Replies (6)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

Turned on Firefox in Safe Mode and tried to open the TD Ameritrade site. As always I get to the "sign on" page but when I click "log in", Page goes blank like it is trying to load, but never loads. Same in Normal Mode. There is a "lock" icon at left of URL highlights as "Certified by "DigiCert.Ins" and lower left "Transferring data from static.inq.com...", but no data ever transferred. The the same in Normal mode and Safe Mode. A "shield" does NOT appear at the left of the address, so I assume that Content Blocking is NOT "on" for the TD Ameritrade site. The only recent Add Ons, i.e. added in the last 6 months, were Eno Virtual Credit Card (enabled), Facebook Container (enabled). The only other Add On's are Theme and Fonts (enabled), Webroot Filtering (disabled) and eBooks (disabled). So only 5 total Add Ons, 3 enabled, 2 disabled. Also, no "Allow" popups along the top ever appear during the "transferring data" time. Did not try the other 2 sites at this time. Thanks again for any other ideas.

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Per your suggestions, again deleted cookies and cache and disabled the Hardware Accelerator, Quit and Restarted Firefox. Still cannot get TD Ameritrade website to load. Furthermore, still cannot properly navigate United Healthcare or Yahoo Finance websites or get pages to fully load.

more options

Please provide a public link (no password) that we can check out. No Personal Information Please !

more options

Unfortunately, all my issues involve logging onto a site or navigating the sites, or pages not loading properly AFTER logging on. I tried to create a fictitious account for you, but it was linked to my other accounts, so that would not work. Thanks for you help though.