X
Tap here to go to the mobile version of the site.

Support Forum

Is there a way to remove the unmute icon button that appeares in tabs when muted?

Posted

So to elaborate, when a tab is muted, the "unmute" button icon is situated right next to the "close tab" button. I always keep everything muted unless i specifically want to hear sounds from for example youtube, occasionally facebook and the like. These buttons are way too close to each other and i keep clicking either one i don't want to click at the time by accident again and again. I want the unmute button to go away forever, i can just rightclick and use that menu for unmuting. Every time i try to bring my issue onto the "almighty" google, it's always unrelated, and no, the setting of browser.tabs.showAudioPlayingIcon to false in about:config does not do anything since it's not the audio playing icon, but the unmute icon that's the problem.

Any related wisdom is appreciated.

So to elaborate, when a tab is muted, the "unmute" button icon is situated right next to the "close tab" button. I always keep everything muted unless i specifically want to hear sounds from for example youtube, occasionally facebook and the like. These buttons are way too close to each other and i keep clicking either one i don't want to click at the time by accident again and again. I want the unmute button to go away forever, i can just rightclick and use that menu for unmuting. Every time i try to bring my issue onto the "almighty" google, it's always unrelated, and no, the setting of browser.tabs.showAudioPlayingIcon to false in about:config does not do anything since it's not the audio playing icon, but the unmute icon that's the problem. Any related wisdom is appreciated.

Modified by Bontain

Chosen solution

Ahh, so that add-on is the culprit  !

I don't blame you for not wanting to try that CSS - should you want to try (maybe later) :

https://www.howtogeek.com/334716/how-to-customize-firefoxs-user-interface-with-userchrome.css/

In the mean time :

You could try to contact the developer of the add-on : see under 'More information' => Support Email

https://addons.mozilla.org/en-US/firefox/addon/auto-mute/

But you say that you uninstalled it - problem solved then  ?

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:64.0) Gecko/20100101 Firefox/64.0

More Information

McCoy
  • Top 10 Contributor
490 solutions 4513 answers

Hello Bontain,

After you changed the pref's value, did you then close and restart Firefox in order for the change to take effect  ?

The audio playing icon = the mute/unmute icon, see :

https://techdows.com/2016/08/disable-firefox-tab-audio-indicator.html

To make sure I just tested it, and setting the value to "false" worked ......

Hello Bontain, After you changed the pref's value, did you then close and restart Firefox in order for the change to take effect ? The audio playing icon = the mute/unmute icon, see : https://techdows.com/2016/08/disable-firefox-tab-audio-indicator.html To make sure I just tested it, and setting the value to "false" worked ......

Question owner

Heyo. I did close and restart, in fact i've had the mentioned pref set to false for days, yet the unmute thing still persists.

Attached an image of the button in question as it seems it refused to upload earlier.

Heyo. I did close and restart, in fact i've had the mentioned pref set to false for days, yet the unmute thing still persists. Attached an image of the button in question as it seems it refused to upload earlier.

Modified by Bontain

McCoy
  • Top 10 Contributor
490 solutions 4513 answers

Hello again,

Thank you for that screenshot  ! It shows the mute/unmute icon where I have never seen it
before .....

Stab in the dark, but did you by any chance install this
extension :

https://addons.mozilla.org/en-US/firefox/addon/auto-mute/  ?

If so, would you please take a look at this thread :

https://support.mozilla.org/en-US/questions/1229236

Hello again, Thank you for that screenshot ! It shows the mute/unmute icon where I have never seen it <BR>before ..... Stab in the dark, but did you by any chance install this <BR>extension : https://addons.mozilla.org/en-US/firefox/addon/auto-mute/ ? If so, would you please take a look at this thread : https://support.mozilla.org/en-US/questions/1229236

Question owner

Heya.

I did install the extension when i found that thread yesterday, yet all this talk of editing css or whatever is kinda beyond my braining so i uninstalled it again...

Thanks for trying so far. :)

Heya. I did install the extension when i found that thread yesterday, yet all this talk of editing css or whatever is kinda beyond my braining so i uninstalled it again... Thanks for trying so far. :)
McCoy
  • Top 10 Contributor
490 solutions 4513 answers

Chosen Solution

Ahh, so that add-on is the culprit  !

I don't blame you for not wanting to try that CSS - should you want to try (maybe later) :

https://www.howtogeek.com/334716/how-to-customize-firefoxs-user-interface-with-userchrome.css/

In the mean time :

You could try to contact the developer of the add-on : see under 'More information' => Support Email

https://addons.mozilla.org/en-US/firefox/addon/auto-mute/

But you say that you uninstalled it - problem solved then  ?

Ahh, so that add-on ''is'' the culprit ! I don't blame you for not wanting to try that CSS - should you want to try (maybe later) : https://www.howtogeek.com/334716/how-to-customize-firefoxs-user-interface-with-userchrome.css/ In the mean time : You could try to contact the developer of the add-on : see under 'More information' => Support Email https://addons.mozilla.org/en-US/firefox/addon/auto-mute/ But you say that you uninstalled it - problem solved then ?

Question owner

Well, no, the problem persists.

I installed the extension to try and solve my problem with the button, but never got any further than that. As in, i don't have the auto mute thingie and the unmute icon is staring at me nefariously in the tab right now...

But i'll look into the link and try to educate myself on css, thank you for that!

Well, no, the problem persists. I installed the extension to try and solve my problem with the button, but never got any further than that. As in, i don't have the auto mute thingie and the unmute icon is staring at me nefariously in the tab right now... But i'll look into the link and try to educate myself on css, thank you for that!

Question owner

Latest update: The CSS trick worked wonders and the instructions in your link was really easier to follow than most other places i've been. And better yet, the icon i wanted gone, is now gone!

Thank you so much for your time and help McCoy, you're a lifesaver!

Latest update: The CSS trick worked wonders and the instructions in your link was really easier to follow than most other places i've been. And better yet, the icon i wanted gone, is now gone! Thank you so much for your time and help McCoy, you're a lifesaver!
McCoy
  • Top 10 Contributor
490 solutions 4513 answers

Helpful Reply

Bontain said

Thank you so much for your time and help McCoy, you're a lifesaver!

My pleasure, Bontain  !

But I'm impressed with the way you handled the 'CSS trick' - well done  !

''Bontain [[#answer-1193095|said]]'' <blockquote> Thank you so much for your time and help McCoy, you're a lifesaver! </blockquote> My pleasure, Bontain ! But I'm impressed with the way you handled the 'CSS trick' - well done !