X
Tap here to go to the mobile version of the site.

Support Forum

Previous fix to eliminate unwanted question marks no longer works.

Posted

The solution below no longer works. My current version of Firefox is 64.0.2

When did this problem start for you?

On Mac, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. The developers are aware of this and some fixes were made in Firefox 57, but they might have missed some font types or unexpected font file locations.

To see whether this is the problem, and as a temporary workaround, you can reduce the sandbox security level back to what it was in Firefox 52-55 as follows:

(1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste sand and pause while the list is filtered

(3) Double-click the security.sandbox.content.level preference and change the value from 3 to 1 and click OK

That change won't take effect until the next time you quit and restart Firefox

The solution below no longer works. My current version of Firefox is 64.0.2 When did this problem start for you? On Mac, Firefox 56 ratcheted up the security sandbox, limiting which files pages can use on your system. This apparently prevents Firefox from using font files in a "suitcase" or "Adobe Type 1" format. The developers are aware of this and some fixes were made in Firefox 57, but they might have missed some font types or unexpected font file locations. To see whether this is the problem, and as a temporary workaround, you can reduce the sandbox security level back to what it was in Firefox 52-55 as follows: (1) In a new tab, type or paste about:config in the address bar and press Return. Click the button accepting the risk. (2) In the search box above the list, type or paste sand and pause while the list is filtered (3) Double-click the security.sandbox.content.level preference and change the value from 3 to 1 and click OK That change won't take effect until the next time you quit and restart Firefox

Additional System Details

Installed Plug-ins

?

Application

  • Firefox 64.0.2
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:64.0) Gecko/20100101 Firefox/64.0
  • Support URL: https://support.mozilla.org/1/firefox/64.0.2/Darwin/en-US/

Extensions

  • Adobe Acrobat 18.0.9 (web2pdfextension.17@acrobat.adobe.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x67df
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • contentUsesTiling: True
  • crashGuards: []
  • driverDate:
  • driverVersion:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'OpenGL Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}, {u'status': u'opt-in', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}], u'name': u'WEBRENDER'}, {u'status': u'blocked', u'description': u'WebRender qualified', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'No qualified hardware', u'type': u'env'}], u'name': u'WEBRENDER_QUALIFIED'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • info: {u'TileHeight': 1024, u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'none', u'TileWidth': 1024, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 4
  • numTotalWindows: 4
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 3
  • usesTiling: True
  • webgl1DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: ATI Technologies Inc. -- AMD Radeon Pro 580 OpenGL Engine
  • webgl1Version: 4.1 ATI-1.68.21
  • webgl1WSIInfo: CGL
  • webgl2DriverExtensions: GL_ARB_blend_func_extended GL_ARB_draw_buffers_blend GL_ARB_draw_indirect GL_ARB_ES2_compatibility GL_ARB_explicit_attrib_location GL_ARB_gpu_shader_fp64 GL_ARB_gpu_shader5 GL_ARB_instanced_arrays GL_ARB_internalformat_query GL_ARB_occlusion_query2 GL_ARB_sample_shading GL_ARB_sampler_objects GL_ARB_separate_shader_objects GL_ARB_shader_bit_encoding GL_ARB_shader_subroutine GL_ARB_shading_language_include GL_ARB_tessellation_shader GL_ARB_texture_buffer_object_rgb32 GL_ARB_texture_cube_map_array GL_ARB_texture_gather GL_ARB_texture_query_lod GL_ARB_texture_rgb10_a2ui GL_ARB_texture_storage GL_ARB_texture_swizzle GL_ARB_timer_query GL_ARB_transform_feedback2 GL_ARB_transform_feedback3 GL_ARB_vertex_attrib_64bit GL_ARB_vertex_type_2_10_10_10_rev GL_ARB_viewport_array GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_texture_compression_s3tc GL_EXT_texture_filter_anisotropic GL_EXT_texture_mirror_clamp GL_EXT_texture_sRGB_decode GL_APPLE_client_storage GL_APPLE_container_object_shareable GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_texture_range GL_ATI_texture_mirror_once GL_NV_texture_barrier
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context
  • webgl2Renderer: ATI Technologies Inc. -- AMD Radeon Pro 580 OpenGL Engine
  • webgl2Version: 4.1 ATI-1.68.21
  • webgl2WSIInfo: CGL
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17344 solutions 156782 answers

Helpful Reply

Did you try to disable the sandbox altogether?

  • security.sandbox.content.level = 0

What font is this about that Firefox changes to a last resort font and where is it stored?

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-faily CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

Did you try to disable the sandbox altogether? *security.sandbox.content.level = 0 What font is this about that Firefox changes to a last resort font and where is it stored? You can check the font used for selected text in the Font tab in the right pane of the Inspector. *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts Note that this is not about the font-faily CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

Question owner

Thanks for the "zero" suggestion. I will have to wait a few hours to give it a try, but I will let you know the result either way. As for the other, I am not a developer and I really don't want to spend a lot of time experimenting - especially in places I'm not familiar with. Whatever the fonts, they are undoubtedly common ones - and I am not even sure that any given font is always being relpaced. I do have a few screen captures. If I feel ambitious - and if the "zero" idea doesn't work out, maybe I will try to check the fonts. Thanks again! (And stay tuned later.)

Thanks for the "zero" suggestion. I will have to wait a few hours to give it a try, but I will let you know the result either way. As for the other, I am not a developer and I really don't want to spend a lot of time experimenting - especially in places I'm not familiar with. Whatever the fonts, they are undoubtedly common ones - and I am not even sure that any given font is always being relpaced. I do have a few screen captures. If I feel ambitious - and if the "zero" idea doesn't work out, maybe I will try to check the fonts. Thanks again! (And stay tuned later.)

Question owner

This appears to have worked, so thanks, again.

I suppose if he question marks creep back into view, I will just have to change the setting to ............. "11" ................. ; - )

That's a little nonDeveloper humor.

Thx.

Well, I may have spoken too soon. This morning, I downloaded Firefox 65.0. When I opened it, nothing displayed below the Bookmarks Toolbar -- and no button or icon worked. The text in the tab for the empty window said "Private Browsing." It seems like I could access my Preferences and I took a quick look but didn't see anything to change. I used the "about:config"/"sand" steps to resotre the number to 1. I shut down, reopened and got content again - but with the same display error of question marks in several places (I didn't surf around much). I decided to change it to zero again to see if content would display -- since I wouldn't be opening it for the first time in a new version -- but once again got no content displaying. This time, I didn't seem able to open my preferences. I have restored the setting to 3, rather than 1, just to see what that gets me - but I know for sure it gets me some question marks. You would think that Firefox would have solved this problem themselves by now - rather than keep squabbling with Adobe, if that's what it amounts to. I am really close to moving all my boomakrs to Chrome and getting used to that for a browser - whether I like it or not. Any ideas? Thanks in advance ... Rob

This appears to have worked, so thanks, again. I suppose if he question marks creep back into view, I will just have to change the setting to ............. "11" ................. ; - ) That's a little nonDeveloper humor. Thx. ***** Well, I may have spoken too soon. This morning, I downloaded Firefox 65.0. When I opened it, nothing displayed below the Bookmarks Toolbar -- and no button or icon worked. The text in the tab for the empty window said "Private Browsing." It seems like I could access my Preferences and I took a quick look but didn't see anything to change. I used the "about:config"/"sand" steps to resotre the number to 1. I shut down, reopened and got content again - but with the same display error of question marks in several places (I didn't surf around much). I decided to change it to zero again to see if content would display -- since I wouldn't be opening it for the first time in a new version -- but once again got no content displaying. This time, I didn't seem able to open my preferences. I have restored the setting to 3, rather than 1, just to see what that gets me - but I know for sure it gets me some question marks. You would think that Firefox would have solved this problem themselves by now - rather than keep squabbling with Adobe, if that's what it amounts to. I am really close to moving all my boomakrs to Chrome and getting used to that for a browser - whether I like it or not. Any ideas? Thanks in advance ... Rob

Modified by robkuhnjr

arnokenis 0 solutions 3 answers

Helpful Reply

I too have this issue. Changing it to 0 does not help.

Changing it to 1 did the trick before. Now since I upgraded to version 65.0.1 it doesn't work anymore.

I just implemented Firefox policies for enterprise and firefox is the default browser in our company. I guess I'll see how I can pimp chrome to become the standard. I can't have 1000+ users calling helpdesk because they can't use their browser anymore.

I too have this issue. Changing it to 0 does not help. Changing it to 1 did the trick before. Now since I upgraded to version 65.0.1 it doesn't work anymore. I just implemented Firefox policies for enterprise and firefox is the default browser in our company. I guess I'll see how I can pimp chrome to become the standard. I can't have 1000+ users calling helpdesk because they can't use their browser anymore.

Question owner

I don't think it occurred to me to circle back to "1" ... or maybe I did.

I have migrated the bookmarks that seem to have the biggest problems with this to Chrome. But I do not like the intrusiveness of Chrome. I am not into having my work and personal files "synced"

I understand that many people find this helpful - and it unarguably is helpful. I just find the balance with invasion of privacy (increasingly hard to avoid, I also realize) to be extremely annoying.

I hope there is a way for you to avoid such intrusion if you wind up making Chrome the default.

I dont know what Mozilla is thinking -- apparently not much. I just selected "Very dissatisfied" in the survey they pushed me. Apparently that short-circuited two minutes to two seconds.

I don't think it occurred to me to circle back to "1" ... or maybe I did. I have migrated the bookmarks that seem to have the biggest problems with this to Chrome. But I do not like the intrusiveness of Chrome. I am not into having my work and personal files "synced" I understand that many people find this helpful - and it unarguably is helpful. I just find the balance with invasion of privacy (increasingly hard to avoid, I also realize) to be extremely annoying. I hope there is a way for you to avoid such intrusion if you wind up making Chrome the default. I dont know what Mozilla is thinking -- apparently not much. I just selected "Very dissatisfied" in the survey they pushed me. Apparently that short-circuited two minutes to two seconds.
cor-el
  • Top 10 Contributor
  • Moderator
17344 solutions 156782 answers

@ arnokenis

You can check in the Font tab in the Inspector to see what font Firefox would want to use and where this font it stored.

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check the font used for selected text in the Font tab in the right pane of the Inspector.

Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab.

@ arnokenis You can check in the Font tab in the Inspector to see what font Firefox would want to use and where this font it stored. You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected. You can check the font used for selected text in the Font tab in the right pane of the Inspector. Note that this is not about the font-family CSS rule, but about the font that Firefox actually uses as shown in the Font tab. *https://developer.mozilla.org/en-US/Tools/Page_Inspector *https://developer.mozilla.org/en-US/Tools/Page_Inspector/How_to/View_fonts *https://developer.mozilla.org/en-US/Tools/Page_Inspector/UI_Tour

Question owner

Thanks arnokenis ... sincerely ... but that is a bridge too far for me. I am not a developer; I don't want to mess around in developer pages.

I had to check to see if I had changed their primary default for Font -- and I did not.

As far as I am concerned, this is a problem with Mozilla's code and it's their responsibility to get it under control. I have no interest in taking on any additional admin tasks related to all this convenient, time-saving technology.

I don't like moving bookmarks to Chrome (I think I already said that), but if that is the path of least resistance, I will take it [ at least until it pisses me off more than this ].

But thanks again, sincerely, for your advice!

Rob

Thanks arnokenis ... sincerely ... but that is a bridge too far for me. I am not a developer; I don't want to mess around in developer pages. I had to check to see if I had changed their primary default for Font -- and I did not. As far as I am concerned, this is a problem with Mozilla's code and it's their responsibility to get it under control. I have no interest in taking on any additional admin tasks related to all this convenient, time-saving technology. I don't like moving bookmarks to Chrome (I think I already said that), but if that is the path of least resistance, I will take it [ at least until it pisses me off more than this ]. But thanks again, sincerely, for your advice! Rob
arnokenis 0 solutions 3 answers

Hey Rob.

I understand, it was not me asking you to do the developer things.

I have done the same as you. I created a settings profile for chrome (where you can enable the transfer of bookmarks from firefox and disable all the intrusive features too). And I'm rolling out new latest chrome as we speak.

Too bad, but I have no choice. A lot of my users are impacted and I can't afford any downtime.

Good Luck! Arno

Hey Rob. I understand, it was not me asking you to do the developer things. I have done the same as you. I created a settings profile for chrome (where you can enable the transfer of bookmarks from firefox and disable all the intrusive features too). And I'm rolling out new latest chrome as we speak. Too bad, but I have no choice. A lot of my users are impacted and I can't afford any downtime. Good Luck! Arno

Question owner

Thanks, Arno

Thanks, Arno
jscher2000
  • Top 10 Contributor
8578 solutions 70134 answers

The sandbox problem shouldn't affect Macs where Firefox simply uses the built-in fonts. What third party font managers do you guys use on your Macs?

The sandbox problem shouldn't affect Macs where Firefox simply uses the built-in fonts. What third party font managers do you guys use on your Macs?

Question owner

Well, that makes sense. I don't experience this issue on my Mac at home. In the office, we use Universal Type Client -- in conjunction with Adobe Creative Cloud apps.

The company seems to have enough trouble wrangling the fonts - and preventing Designers from using variations we don't have to pay for. This has been a problem for a long time. "Recently," following the rollout of Woodwing, there has been an effort to get the font usage under control.

Probably the best I can do is raise this as a general issue with the helpdesk and see if they want to explore it. Some folks have experienced the same issue in their MS Office Outlook app. So maybe the helpdesk will research it.

Thanks!

Well, that makes sense. I don't experience this issue on my Mac at home. In the office, we use Universal Type Client -- in conjunction with Adobe Creative Cloud apps. The company seems to have enough trouble wrangling the fonts - and preventing Designers from using variations we don't have to pay for. This has been a problem for a long time. "Recently," following the rollout of Woodwing, there has been an effort to get the font usage under control. Probably the best I can do is raise this as a general issue with the helpdesk and see if they want to explore it. Some folks have experienced the same issue in their MS Office Outlook app. So maybe the helpdesk will research it. Thanks!
jscher2000
  • Top 10 Contributor
8578 solutions 70134 answers

Hi Rob, if there is a standard path for Universal Type Client that should be whitelisted to avoid sandbox problems, you can submit it through Bugzilla. However, it could take a couple versions before that is released.

https://bugzilla.mozilla.org/

Possibly Adobe has a note on it somewhere?

Hi Rob, if there is a standard path for Universal Type Client that should be whitelisted to avoid sandbox problems, you can submit it through Bugzilla. However, it could take a couple versions before that is released. https://bugzilla.mozilla.org/ Possibly Adobe has a note on it somewhere?

Question owner

Hi ... Thanks, very much, but that's getting beyond the level of effort I want to expend just to have a font display properly. A few particular barriers include: I don't know how to determine a "standard path" for Universal Type Client. A search for "Adobe - Firefox - Universal Type Client" brought up a handful of problems, but not mine. I don't know what "whitelisting" is. I'm afraid I could do all you suggest but then find out the problem is too local to my setup for Firefox to fix universally - or provide some specific fix for me. My feeling is that since you have been able to figure this out from my series of comments, Mozilla should already be aware that there are issues with these interactions - and be attempting to correct them. I'm just not sure -- repeating myself now -- that they can offer some universal solution. But thanks again! for shedding more light on why I've been seeing this problem. Rob

Hi ... Thanks, very much, but that's getting beyond the level of effort I want to expend just to have a font display properly. A few particular barriers include: I don't know how to determine a "standard path" for Universal Type Client. A search for "Adobe - Firefox - Universal Type Client" brought up a handful of problems, but not mine. I don't know what "whitelisting" is. I'm afraid I could do all you suggest but then find out the problem is too local to my setup for Firefox to fix universally - or provide some specific fix for me. My feeling is that since you have been able to figure this out from my series of comments, Mozilla should already be aware that there are issues with these interactions - and be attempting to correct them. I'm just not sure -- repeating myself now -- that they can offer some universal solution. But thanks again! for shedding more light on why I've been seeing this problem. Rob
arnokenis 0 solutions 3 answers

We also use universal type client, so our issues seem to be identical.

@jscher2000 How can I determine the standard path of Universal Type Client?

We also use universal type client, so our issues seem to be identical. @jscher2000 How can I determine the standard path of Universal Type Client?

Question owner

FYI, everyone ... my desktop iMac had a minor stroke this morning ... or at least the MS Office suite did. I saw the question marks in a couple of Excel files. But when another Excel file that I open every day earned me an error dialog, I decided to shut down, pause a minute, and start up again. That cured the Excel issues - but the font display problem is definitely not restricted to Firefox. I got a couple of screen shots of the Excel errors and so I can start a helpdesk ticket. Might as well, and see what their motivation is to troubleshoot and maybe correct this. Thanks, all ... and keep talking. Rob

FYI, everyone ... my desktop iMac had a minor stroke this morning ... or at least the MS Office suite did. I saw the question marks in a couple of Excel files. But when another Excel file that I open every day earned me an error dialog, I decided to shut down, pause a minute, and start up again. That cured the Excel issues - but the font display problem is definitely not restricted to Firefox. I got a couple of screen shots of the Excel errors and so I can start a helpdesk ticket. Might as well, and see what their motivation is to troubleshoot and maybe correct this. Thanks, all ... and keep talking. Rob
cor-el
  • Top 10 Contributor
  • Moderator
17344 solutions 156782 answers
See also: *https://wiki.mozilla.org/Security/Sandbox#Content_Levels
Franknca 0 solutions 3 answers

I have tried to follow this but I am using a PC not a Mac and people are now telling me that my replies have ??? added after sentences. I can not figure out how to fix this as I don't know if it's a bug from a recent update or what. I can go into tools and such but don't see anything that I can change. Is there a simple solution?

I have tried to follow this but I am using a PC not a Mac and people are now telling me that my replies have ??? added after sentences. I can not figure out how to fix this as I don't know if it's a bug from a recent update or what. I can go into tools and such but don't see anything that I can change. Is there a simple solution?
jscher2000
  • Top 10 Contributor
8578 solutions 70134 answers

Franknca said

I have tried to follow this but I am using a PC not a Mac and people are now telling me that my replies have ??? added after sentences. I can not figure out how to fix this as I don't know if it's a bug from a recent update or what. I can go into tools and such but don't see anything that I can change. Is there a simple solution?

Hi Franknca, are you composing those messages on a website in Firefox, or in the Thunderbird email program? Since your situation is different from the issue in this thread, I suggest starting a new question using the most applicable link:

On either page, scroll down past article links to continue with the form.

''Franknca [[#answer-1212794|said]]'' <blockquote> I have tried to follow this but I am using a PC not a Mac and people are now telling me that my replies have ??? added after sentences. I can not figure out how to fix this as I don't know if it's a bug from a recent update or what. I can go into tools and such but don't see anything that I can change. Is there a simple solution? </blockquote> Hi Franknca, are you composing those messages on a website in Firefox, or in the Thunderbird email program? Since your situation is different from the issue in this thread, I suggest starting a new question using the most applicable link: * Firefox website problem: https://support.mozilla.org/questions/new/desktop/websites * Thunderbird other problem: https://support.mozilla.org/questions/new/thunderbird/other On either page, scroll down past article links to continue with the form.
Franknca 0 solutions 3 answers

Composing in T-bird. I'll post on another forum as you suggest.

Composing in T-bird. I'll post on another forum as you suggest.