X
Tap here to go to the mobile version of the site.

Support Forum

How can i disable "This connection is not secure" in mozilla.cfg file?

Posted

Hi Guys,

I need to configure firefox for deployment in my organization, I have a .cfg file that i am currently using and i need to add another option to it.

I need to disable the secure connection warning "This connection is not secure. Logins entered here could be compromised.

The below shows how to manually fix the issue but i need this done for every deployment of firefox

To Remove the Warning Panels

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste insec and pause while the list is filtered

(3) Double-click the security.insecure_field_warning.contextual.enabled preference to switch the value from true to false

(4) Assume this login could be easily stolen and avoid re-using it on important sites

Thank you

Hi Guys, I need to configure firefox for deployment in my organization, I have a .cfg file that i am currently using and i need to add another option to it. I need to disable the secure connection warning "This connection is not secure. Logins entered here could be compromised. The below shows how to manually fix the issue but i need this done for every deployment of firefox To Remove the Warning Panels (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste insec and pause while the list is filtered (3) Double-click the security.insecure_field_warning.contextual.enabled preference to switch the value from true to false (4) Assume this login could be easily stolen and avoid re-using it on important sites Thank you

Chosen solution

Added this line:

lockPref("security.insecure_field_warning.contextual.enabled", false);

resolved

Read this answer in context 14

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.79 Safari/537.36

More Information

philipp
  • Top 25 Contributor
  • Moderator
5306 solutions 23422 answers

hi, please see https://developer.mozilla.org/en-US/Firefox/Enterprise_deployment on how to deploy about:config settings through a mozilla.cfg file.

hi, please see https://developer.mozilla.org/en-US/Firefox/Enterprise_deployment on how to deploy about:config settings through a mozilla.cfg file.

Chosen Solution

Added this line:

lockPref("security.insecure_field_warning.contextual.enabled", false);

resolved

Added this line: lockPref("security.insecure_field_warning.contextual.enabled", false); resolved