Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I've set everything to German (!), but Firefox still assumes that I prefer Spanish although I do not speak Spanish!

  • 7 replies
  • 2 have this problem
  • 108 views
  • Last reply by McCoy

more options

I've set everything to German (!), But Firefox still assumes that I prefer Spanish although I do not speak Spanish, probably because I installed Firefox for the first time, when I went on holiday with my notebook in Spain and used Spanish Wi-Fi. Since then, many platforms such as LinkedIn or Google always open up in Spanish for the first time. What can I do to ONLY get German or English at the first call of new pages? With the Chrome browser, the pages ALWAYS come in German or English, never in Spanish.

All Replies (7)

more options

Download Firefox For All languages And Systems {web link} Select the language you want.

more options

You could also delete cookies.

more options

Hello gxmx,

Are we to assume that you don't wish to continue this in the thread you started earlier (and where Franz_von_Suppé posted answers in your own language) :

https://support.mozilla.org/en-US/questions/1246846  ?

If so : let us know and a moderator can lock that thread.

more options

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
more options

I have Google set to English (UK), the same for Microsoft and Firefox. Despite this (I live in Austria) GMail opens now in German, which I don't speak. I usually have to change languages twice!

It happened after a Firefox update a couple of months ago.

It sounds like others have similar problems.

[I wanted to log in to Mozilla.at to ask for help, but my new Firefox warned me that the site did not have the proper permissions :-)]

more options

Hello qorval,

Would you try to use this link to post your question and start a new thread :

https://support.mozilla.org/en-US/questions/new/desktop/other

(you'll have to scroll down)

more options

@ qorval :

If you feel more comfortable posting on a German forum :

https://www.camp-firefox.de/forum/