Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Not Saving History

  • 13 replies
  • 1 has this problem
  • 59 views
  • Last reply by FredMcD

more options

Hello-

Firefox doesn't save my history with Quantum 64. This is is really frustrating. I had this issue prior to installing Quantum earlier this year. The minute Midnight strikes on my computer and start up FF it only reveals "Yesterday" history but nothing further back in date. I even tried changing the date back a few days for a moment and no previous history appeared. So there is nothing wrong with my clock/date.

Here's what I have done to try to correct /investigate this:

1. Restored FF Quantum. 2. Deleted all the Places.sqlite files and restarted FF to refresh them. 3. Checked Norton 360 to make sure History Clean Up is OFF. 4. Disabled Malwarebytes, IOBIT's Advance System Care 12 and similar programs for a couple of days. 5. I've had this issue before and even tried to reinstall FF and that didn't do anything.

6. Verify Integrity Results:

> Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: originFrecencyStats + Recalculated origin frecency stats > Task: vacuum + Initial database size is 5120KiB + The database has been vacuumed + Final database size is 5120KiB > Task: stats + Places.sqlite size is 5120KiB + Favicons.sqlite size is 768KiB + pragma_user_version is 52 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 112348 unique pages + Table moz_origins has 250 records + Table moz_places has 380 records + Table moz_historyvisits has 137 records + Table moz_inputhistory has 0 records + Table moz_bookmarks has 516 records + Table moz_bookmarks_deleted has 0 records + Table moz_keywords has 0 records + Table sqlite_sequence has 0 records + Table moz_anno_attributes has 2 records + Table moz_annos has 2 records + Table moz_items_annos has 0 records + Table moz_meta has 7 records + Table sqlite_stat1 has 16 records + Index sqlite_autoindex_moz_origins_1 + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index moz_places_url_hashindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_places_guid_uniqueindex + Index moz_places_originidindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_bookmarks_dateaddedindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex > Task: _refreshUI

7. Attached is the list of add-ons. In the past I have disabled and/or deleted them them and still had the issue

I am using Windows 7.

Any tangible help and known cause you have is much appreciated.

Thank you, Steven

Attached screenshots

Chosen solution

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Read this answer in context 👍 0

All Replies (13)

more options

Separate Issue; Your System Details shows;

Extensions

Open Link in New Tab 1.0 ({c064b4e8-a82e-415f-9d31-8516e613182e})

Open Link with New Tab 1.0 (Open-Link-with-New-Tab@sienori)
Having more than one version of a program may cause issues.

more options

Chosen Solution

You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

more options

Thank you very much for both replies I will try the later on today when I get to my computer. Though I do not understand the resolve above about 'New Tab 1.0.' You got me here -- no idea what you're talking about and how to do this. Thank you again. I'll try these things today and I'll let you know if these fixes work. Thanks

more options

Thank you . I followed your instructions and checked off/on the the boxes suggested. I will wait a couple of days to see if this does trick and saves my browsing history, and will let you know.

Why would I want to leave checked/on FF to automatically 'Clear Form & Search History' and 'Cache' as the top of this dialogue box says, 'When closed, Firefox should automatically clear all...' Wouldn't I want to have those unchecked too?

more options

FredMcD said

Separate Issue; Your System Details shows; Extensions Open Link in New Tab 1.0 ({c064b4e8-a82e-415f-9d31-8516e613182e}) Open Link with New Tab 1.0 (Open-Link-with-New-Tab@sienori)
Having more than one version of a program may cause issues.

I have no idea what this means or how to do this above. ??

more options

FredMcD said

Separate Issue; Your System Details shows; Extensions Open Link in New Tab 1.0 ({c064b4e8-a82e-415f-9d31-8516e613182e}) Open Link with New Tab 1.0 (Open-Link-with-New-Tab@sienori)
Having more than one version of a program may cause issues.

Never mind, I figured out what you were referring to. Much thanks!

more options

StevenLAX16 said

Why would I want to leave checked/on FF to automatically 'Clear Form & Search History' and 'Cache' as the top of this dialogue box says, 'When closed, Firefox should automatically clear all...' Wouldn't I want to have those unchecked too?

Checking the box means that data is cleared.

more options

FredMcD said

StevenLAX16 said
Why would I want to leave checked/on FF to automatically 'Clear Form & Search History' and 'Cache' as the top of this dialogue box says, 'When closed, Firefox should automatically clear all...' Wouldn't I want to have those unchecked too?

Checking the box means that data is cleared.

Excuse my confusion, but why would I want to clear the data when I am trying to perverse that data (broswing history) so it doesn't get cleared each time I close FF. (???). I'd assume that you'd want to have all the boxes unchecked, no?

more options

StevenLAX16 said

I am trying to perverse that data (broswing history) so it doesn't get cleared each time I close FF. (???). I'd assume that you'd want to have all the boxes unchecked, no?

Cache is where websites store some data on your system, like page setup. Not to be confused with cookies which are used to store website settings and such.

Form And Search History is part of the auto-complete. Some would prefer that this is cleared between sessions.

If history is selected, history would be cleared. We don't want that.

more options

Thanks Fred, I will look at this history in a couple of days to see if it's now fixed and let you know. Thanks for your prompt help.

Steven

more options

Thanks for helping the problem has been solved. Sorry getting back in touch with you.

more options

Glad to help. Safe Surfing.