Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

birthdays are missing from facebook

  • 8 replies
  • 1 has this problem
  • 33 views
  • Last reply by McCoy

more options

Every since the most recent Firefox update, Facebook Birthdays are missing from the column to the right of my Facebook Newsfeed. Birthdays do show up when I use a different browser, so it seems to be a browser issue. How to fix?

All Replies (8)

more options

Hello johnaukerman,

Your system details show that you have this extension installed :

F.B Purity - Cleans up Facebook (WX) 26.1.2.0

It's no longer listed on the addons.mozilla.org page .....

Would you please disable it and see if that will make a difference  ?

more options

If the above doesn't turn out to be the problem; maybe you'd like to take a look at this :

https://www.facebook.com/adblockplus/posts/some-of-you-might-have-noticed-that-facebook-looks-broken-it-is-due-to-a-filter-/521450097896415/

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block (wanted) content.

Firefox shows the shield icon at the left end of the location/address bar in case Content Blocking is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console about what content is blocked

more options

I tried both of these. Neither one helped.

more options

johnaukerman said

I tried both of these. Neither one helped.

Would you try this please :

You can try these steps in case of issues with web pages : Reload the page : Hold down the Shift key and left-click the Reload button or press 'Ctrl + F5' or press 'Ctrl + Shift + R'

Another thing to try :

Would you try this please :

Clear the Firefox cache :

https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

"Remove the cookies" from websites that cause problems :

https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored (scroll down to : "Delete cookies for a single site")


If the above doesn't help, then let's try Firefox in Safe Mode :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Firefox's Safe Mode disables: - extensions (apparantly not relevant in your case) - hardware acceleration of graphics - JavaScript compilers - userChrome.css/userContent.css customization files (usually wouldn't affect performance but could affect layout

more options

Thanks for your help. I tried these steps, but birthdays are still not showing.

more options

johnaukerman said

Thanks for your help. I tried these steps, but birthdays are still not showing.

Bummer  !

Stab in the dark, and this has probably nothing to do with the birthdays not showing up, but could it be that you have inadvertently switched off the Facebook Birthday Notifications  ?

https://bigtechquestion.com/2018/01/25/online/social-media/how-do-i-switch-off-facebook-birthday-notifications/

Modified by McCoy

more options

No point asking you if you have checked 'Birthdays' here :

https://calendar.google.com/calendar/r?tab=wc

As they do show when you use other browsers ......