Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

On startup, firefox asking for master password

  • 23 replies
  • 12 have this problem
  • 367 views
  • Last reply by jscher2000

more options

Hi

Today Firefox started to ask "master password" on startup. Yes I use master password, but Firefox never asked it on startup. Why this could be happening? It does not matter what startup page I load, it could be blank page or any other. No sync or other Mozilla account is connected. Tried to disable all add-ons, does not help. Firefox version: 63.0.3 (64-bit).

Modified by procc

Chosen solution

Yes I had my suspicions about kaspersky. Now I reinstalled it, and problem is almost gone. Now MP on startup appears only one time, when computer is restarted.

Read this answer in context 👍 0

All Replies (20)

more options

Hi procc, Firefox will ask for the Master Password the first time you need to use a saved login to sign in to something. At startup, it's usually your Firefox Account for Sync, or your home page. But if it's not one of those, then it could be one of your extensions that needs to connect to an account. It sounds as though you have ruled those out, too.

So please cancel the dialog since there seems to be no good reason for it, and keep an eye on when it appears again.

Meanwhile, what sites have you saved logins for? I would think you wouldn't see the dialog unless Firefox was trying to connect to a site for which you have saved a login. If you want to view the list without having to enter the Master Password, you can view the raw data file, as follows:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Resize this window so you can see the Troubleshooting Information page behind it.

Drag and drop the logins.json file into the Troubleshooting Information page to load it there. After a few moments, Firefox should display a structured view of the file listing your saved logins. Some data is encrypted, but site addresses should be in plain text.

more options

There are many saved logins, but it does not matter. Firefox asking for master password on startup even if I load blank page. I think this is some kind of bug.

more options

Are you sure that Sync isn't enabled?

If that is the case then there is an email address present in the "3-bar" Firefox menu button drop-down list instead of "Sign in to Sync".

Does the about:networking page give a clue whether some pages are requested?

What happens if you cancel the prompt? Do you get another not requested prompt or only a prompt when you visit a website with saved login data?

more options

In Firefox menu it says "Sign in to Sync".

In "about:networking" there are many addresses, I don't really know what they mean.

If I cancel the prompt, then Firefox asks master password on some sites. If I enter master password on startup, Firefox does not ask master password later.

more options

"Sign in to Sync" means that you aren't connected to Sync, so that is a confirmation that Sync isn't involved.

Do you still get the MP prompt when you start Firefox in Safe Mode?

You can start Firefox in Safe Mode to see if that has any effect.

  • Windows: hold down the Shift key while starting Firefox
  • Mac: hold down the Options key while starting Firefox
more options

Safe mode - MP prompt is still there.

more options

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

As expected, with new profile, MP startup prompt disappears. But this is not a solution.

more options

This was meant for testing and this means that it is caused by your profile and not by an external cause.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Try to rename prefs.js to see if a preference is causing it.

more options

On another site, I saw a reference to this issue possibly being caused by having the following preference customized. You could try restoring the default value:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste enterp and pause while the list is filtered

(3) If the security.enterprise_roots.enabled preference is bolded and "modified" or "user set" to true, double-click it to restore the default value of false

Source: http://forums.mozillazine.org/viewtopic.php?p=14817882#p14817882

more options

I played a few hours with profile files. Copied back and forth, deleted them and etc... Then noticed that cert9.db is probably the problem. I think this file have something to do with certificates. When I deleted this file, Firefox created a new one, and on startup MP prompt was gone. Everything else also works fine, problem is probably solved.

more options

Well looks like problem returned when FF updated to v64.0 ... And now to delete cert9.db file is not enough.

more options

This is the only new information I've seen:

According to users in the following thread on a different forum, this could be caused by an interaction with a recent Kaspersky update:

http://forums.mozillazine.org/viewtopic.php?f=38&t=3044561

more options

Chosen Solution

Yes I had my suspicions about kaspersky. Now I reinstalled it, and problem is almost gone. Now MP on startup appears only one time, when computer is restarted.

more options

I have this problem too on a Windows computer with the latest firefox. 1. Not using Sync 2. Not using Kaspersky 3. Does not occur in safe mode 4. Does occur in normal mode but with ALL addons disabled 5. Verified that no sites on start page have a stored password

I just cancel the master password box and all is OK, but I am concerned there might be something illegally asking for the MP and using the info.

Any ideas?

more options

I type this with a VERY red face! My bad.

When I looked at the saved passwords, I thought they were in alphabetical order, but no. When I used the (very convenient) search mechanism, I did indeed see that I had a saved password for one of the sites that was my home page, even though I was not logging on to that site as part of loading the page. When I removed the saved password for that site, the "problem" went away.

Oops!

more options

I've marked your above reply as the solution. Feel free to click Undo if you still have further questions.

more options

cor-el said

I've marked your above reply as the solution. Feel free to click Undo if you still have further questions.

It did not solve my problem.

more options

I do not use the password saver in Firefox. I use lastPass and only have one password for both Mozilla and for Firefox. I cancel the request for password and everything is fine until the next time I start Firefox and comes back again.

more options

How is it possible that this problem has not been solved for such a long time? It seems impossible to find out why FF would ask four times upon startup for the master password, even though no page is loaded.

It should also be possible to switch of the autofill in the options, and while I tried to use "signon.autofillForms" set to false, this did not work at all, so I guess FF is not safe at all.

And if "security.enterprise_roots.enabled" is not set to true, then FF is unusable!

What has become of FF? Please fix this ASAP!!!!!!!!!!!!

  1. 1
  2. 2