X
Tap here to go to the mobile version of the site.

Support Forum

I keep getting "Warning: unresponsive add-on script" and can't find any way to stop it

Posted

Windows 7 Professional Firefox 64 bit stable, up to date

Its is running on a 10 year old slow computer, the add-on script is unresponsive because it is running on a slow computer.

I had a similar problem with "Warning: Unresponsive script" but was able to get rid of those annoying notices by setting dom.max_script_run_time to zero.

I do not want to stop the script, the add-on adds security. I just do not want to ever see one of these notices on that computer ever again. I have to deal with them dozens of times each day and only use the computer for a few hours. Each time it interrupts what I'm doing to take me to a different tab to slowly deal with the problem.

The problem isn't the add-on script being slow, its the computer being slow. And the fact that the warning gives me no way to disable it so I keep getting it time after time after time...

Thanks

Windows 7 Professional Firefox 64 bit stable, up to date Its is running on a 10 year old slow computer, the add-on script is unresponsive because it is running on a slow computer. I had a similar problem with "Warning: Unresponsive script" but was able to get rid of those annoying notices by setting dom.max_script_run_time to zero. I do not want to stop the script, the add-on adds security. I just do not want to ever see one of these notices on that computer ever again. I have to deal with them dozens of times each day and only use the computer for a few hours. Each time it interrupts what I'm doing to take me to a different tab to slowly deal with the problem. The problem isn't the add-on script being slow, its the computer being slow. And the fact that the warning gives me no way to disable it so I keep getting it time after time after time... Thanks

Modified by Roland Tanglao

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

More Information

WestEnd
  • Top 25 Contributor
60 solutions 5376 answers

What addons do you have installed?

What addons do you have installed?

Question owner

Why? As I said originally I just want to tell Firefox to never bother me with these useless warnings again.

I want the add-ons to run, IIRC, all the warnings I've see are for add-ons which improve security.

Off the top of my head, I've seen warning for Noscript, uBlock and Canvas Blocker.

Why? As I said originally I just want to tell Firefox to never bother me with these useless warnings again. I want the add-ons to run, IIRC, all the warnings I've see are for add-ons which improve security. Off the top of my head, I've seen warning for Noscript, uBlock and Canvas Blocker.
FredMcD
  • Top 10 Contributor
4225 solutions 58977 answers

We need to know what is causing the issue and why.

What is the full error message?


Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.

We need to know what is causing the issue and why. What is the full error message? -------------- Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Now in the Reply Box on the forum page, do a right-click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.'''

Question owner

Okay, let me simplify my question as you don't seem to understand my problem:

Is there anyway to tell Firefox to stop giving me the useless and annoying "Warning: Unresponsive add-on script message"?

What is causing the problem is that the computer is slow. We have four other computers (Windows and Ubuntu) and none of these computers get these messages. The problem isn't with any add-on, the underlying problem is that the computer is slow. My problem is that I have been unable to find a way to tell Firefox to stop wasting my time with this useless warning.

For example, upon getting your original reply I spent five minutes before giving up trying to get the add-on page to display. During this time I got interrupted to go to one page due to a Firefox warning about an unresponsive add-on script. (Firefox demands that I deal with it immediately, switching me from my current tab/window to the one with the unresponsive script, which then takes tens of seconds to display (slow computer), then briefly hangs while the computer swaps memory to display the warning message. After dealing with the warning I then switch back to the window/tab I was on and wait for it to be displayed again.

The computer is adequate for its purpose, slow or not. The Firefox warning is useless, annoying and a big waste of time.

Don't try to debug the add-ons just tell me is there some way to stop Firefox from giving me these warnings.

Thanks

Okay, let me simplify my question as you don't seem to understand my problem: Is there anyway to tell Firefox to stop giving me the useless and annoying "Warning: Unresponsive add-on script message"? What is causing the problem is that the computer is slow. We have four other computers (Windows and Ubuntu) and none of these computers get these messages. The problem isn't with any add-on, the underlying problem is that the computer is slow. My problem is that I have been unable to find a way to tell Firefox to stop wasting my time with this useless warning. For example, upon getting your original reply I spent five minutes before giving up trying to get the add-on page to display. During this time I got interrupted to go to one page due to a Firefox warning about an unresponsive add-on script. (Firefox demands that I deal with it immediately, switching me from my current tab/window to the one with the unresponsive script, which then takes tens of seconds to display (slow computer), then briefly hangs while the computer swaps memory to display the warning message. After dealing with the warning I then switch back to the window/tab I was on and wait for it to be displayed again. The computer is adequate for its purpose, slow or not. The Firefox warning is useless, annoying and a big waste of time. Don't try to debug the add-ons just tell me is there some way to stop Firefox from giving me these warnings. Thanks
jscher2000
  • Top 10 Contributor
8637 solutions 70654 answers

I've never heard of that message before, and there are only 8 results for this search, which suggests it is incredibly rare:

https://www.google.com/search?q="Warning%3A+Unresponsive+add-on+script"

Maybe you can search differently to learn more about it.

I've never heard of that message before, and there are only 8 results for this search, which suggests it is incredibly rare: [https://www.google.com/search?q=%22Warning%3A+Unresponsive+add-on+script%22 https://www.google.com/search?q="Warning%3A+Unresponsive+add-on+script"] Maybe you can search differently to learn more about it.

Modified by jscher2000

jscher2000
  • Top 10 Contributor
8637 solutions 70654 answers

Also, your Firefox identified itself to the forum as version 56. As you may know, the current versions of Firefox compatible with Windows 7 are:

(Note for 64-bit Windows users: How to switch from 32-bit to 64-bit Firefox)

If something is holding you back from upgrading Firefox, please let us know so we can suggest solutions or workarounds. Version 56 is not secure.

Also, your Firefox identified itself to the forum as version 56. As you may know, the current versions of Firefox compatible with Windows 7 are: * Regular release: 63.0.1 ([https://www.mozilla.org/firefox/all/ Installers]) * Extended Support Release (ESR): 60.3.0esr ([https://www.mozilla.org/firefox/organizations/all/ Installers] ''(Note for 64-bit Windows users: [[How to switch from 32-bit to 64-bit Firefox]])'' If something is holding you back from upgrading Firefox, please let us know so we can suggest solutions or workarounds. Version 56 is not secure.

Question owner

Yes I know. I searched online, did some digging in about:config and seached the mozilla.org site before posting a question here. Most of my searches kept coming back with the common "Warning: Unresponsive script" as the main result. And while Google isn't my first choice for searches, I did see all those results.

The computer I am working on now is using an older version of Firefox as the change to Quantum broke a number of add-ons that I use and I have been waiting for decent replacements for enough of them before upgrading.

My slow computer has the latest version of Firefox as I stated. It doesn't need the same add-ons so I upgraded when the basic security add-ons I use had Quantum version or replacements.

Yes I know. I searched online, did some digging in about:config and seached the mozilla.org site before posting a question here. Most of my searches kept coming back with the common "Warning: Unresponsive script" as the main result. And while Google isn't my first choice for searches, I did see all those results. The computer I am working on now is using an older version of Firefox as the change to Quantum broke a number of add-ons that I use and I have been waiting for decent replacements for enough of them before upgrading. My slow computer has the latest version of Firefox as I stated. It doesn't need the same add-ons so I upgraded when the basic security add-ons I use had Quantum version or replacements.
Pj 42 solutions 869 answers

Luke said

  • I just want to tell Firefox to never bother me with these useless warnings again.
  • Off the top of my head, I've seen warning for NoScript, uBlock and Canvas Blocker.
  • The most frequent pop-up of "Warning: Unresponsive script" I ever had was with NoScript. This Extension and AdBlock Plus were the most troublesome for my 'slow' computer (Nov 2010, 8GB, Dual 3GHz).
  • Script Blockers can be great for what they do, but can severely mess-up your browsing, also!
  • Since my removal of NoScript, many months ago, I've only seen, maybe one time, "Warning: Unresponsive script". If I remember correctly, NoScript wants to be INSTALLED FIRST ahead of all other Extensions (and maybe Addons).
  • FireFox may be showing you these 'useless warnings', but the cause is more likely the Extension, NoScript and NOT FF itself. (I've been there, done that.) (Wink)
  • You could lengthen the Script Time-Out in About:Config...
  • dom.max_script_run_time 10 (This is the default in my FF 61.02.)... but why? You'll hafta to wait longer and may end-up with freezes or crashes.


~Pj

''Luke [[#answer-1170445|said]]'' <blockquote> *'''I just want to tell Firefox to never bother me with these useless warnings again.''' *Off the top of my head, I've seen warning for '''NoScript''', uBlock and Canvas Blocker. </blockquote> *The most frequent pop-up of "'''Warning: Unresponsive script'''" I ever had was with '''NoScript'''. This Extension and '''AdBlock Plus''' were the most troublesome for my 'slow' computer (Nov 2010, 8GB, Dual 3GHz). *Script Blockers can be great for what they do, but can severely mess-up your browsing, also! *Since my removal of '''NoScript''', many months ago, I've only seen, maybe one time, "'''Warning: Unresponsive script'''". If I remember correctly, '''NoScript''' wants to be '''INSTALLED FIRST''' ahead of all other Extensions (and maybe Addons). *FireFox may be showing you these 'useless warnings', but the cause is more likely the Extension, '''NoScript''' and NOT FF itself. (I've been there, done that.) (Wink) *You could lengthen the Script Time-Out in About:Config... *'''dom.max_script_run_time 10''' (This is the default in my FF 61.02.)... but why? You'll hafta to wait longer and may end-up with freezes or crashes. ~Pj

Modified by Pj

Question owner

Most of my warnings are for Canvas blocker. I haven’t tallied the warnings but I remember seeing NoScript and uBlock once each.

Script blockers are a security feature. There are almost always trade offs between security and convenience.

All other computers in the house have NoScript and no other computer is having this problem. Only one computer (this one) is running an older version of Firefox.

I chose the word “useless” carefully. Each time I get one I tell it to continue and it does. All Firefox is doing with this warning for this computer is interrupting me to tell me I have a slow computer, which I already knew. Imagine having a program that about once every ten minutes interrupts what you are doing and takes a minutes to say “Hey, your computer is really slow”.

Read my first post. I set dom.max_script_run_time to zero (from what I eventually found out, zero or negative gives it whatever time it wants). But this only prevented the much more common “Warning: Unresponsive script” error message from interrupting me.

What I was hoping to learn is what about:config setting I could use to do the same for this warning.

Most of my warnings are for Canvas blocker. I haven’t tallied the warnings but I remember seeing NoScript and uBlock once each. Script blockers are a security feature. There are almost always trade offs between security and convenience. All other computers in the house have NoScript and no other computer is having this problem. Only one computer (this one) is running an older version of Firefox. I chose the word “useless” carefully. Each time I get one I tell it to continue and it does. All Firefox is doing with this warning for this computer is interrupting me to tell me I have a slow computer, which I already knew. Imagine having a program that about once every ten minutes interrupts what you are doing and takes a minutes to say “Hey, your computer is really slow”. Read my first post. I set dom.max_script_run_time to zero (from what I eventually found out, zero or negative gives it whatever time it wants). But this only prevented the much more common “Warning: Unresponsive script” error message from interrupting me. What I was hoping to learn is what about:config setting I could use to do the same for this warning.

Question owner

Pj

I didn’t realize until replying to your post but you were talking about the Firefox message “Warning: Unresponsive script”

I solved my issue with that using the about:config edit to set dom.max_script_run_time to zero.

My current problem is with the message “Warning: Unresponsive ADD-ON script”

What I’d like is a similar solution, give the scripts the time they need to finish without bothering me.

Pj I didn’t realize until replying to your post but you were talking about the Firefox message “Warning: Unresponsive script” I solved my issue with that using the about:config edit to set dom.max_script_run_time to zero. My current problem is with the message “Warning: Unresponsive ADD-ON script” What I’d like is a similar solution, give the scripts the time they need to finish without bothering me.