X
Tap here to go to the mobile version of the site.

Safely share files online with encrypted links that “self-destruct.” Try Firefox Send.

Give hackers a swift kick in the cookies. See if your data has been affected by a breach with Firefox Monitor. Try it now.

Access your history, passwords and open tabs wherever you are with Sync. Connect a second device.

Support Forum

How do I change my default search engine from Google to Duckduckgo?

Posted

When I open Firefox my search engine always shows Google. I wish to get rid of Google. How can I do that? Thank you.

When I open Firefox my search engine always shows Google. I wish to get rid of Google. How can I do that? Thank you.

Chosen solution

mdmnd said

When I open Firefox my search engine always shows Google.

At startup Firefox shows your homepage .....

Have you set DuckDuckGo as your homepage  ?

See :

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.0.1 Safari/605.1.15

More Information

FredMcD
  • Top 10 Contributor
3979 solutions 55446 answers

Type about:preferences#search<enter> in the address bar. You can select any search engine to be your default from here.

Type '''about:preferences#search'''<enter> in the address bar. You can select any search engine to be your default from here.
Was this helpful to you? 0
Quote

Question owner

I did the change in preferences as suggested, I did try this before. I closed out of Firefox and then re-entered to find Google was still the default search engine. Please, any other suggestions?

I did the change in preferences as suggested, I did try this before. I closed out of Firefox and then re-entered to find Google was still the default search engine. Please, any other suggestions?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3979 solutions 55446 answers

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save '''Note:''' Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.
Was this helpful to you? 0
Quote

Question owner

Don't have Advanced SystemCare as far as I can tell. Thank you for trying

Don't have Advanced SystemCare as far as I can tell. Thank you for trying
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
319 solutions 2843 answers

Hello mdmnd,

Would you please check in Preferences => Add-ons => Extensions and see if maybe there's an extension called "Search Updater" installed  ? If so : please disable or remove it, cause after that you should be able to regain control of your settings and set DuckDuckGo as your default search engine.

See : Change your default search settings in Firefox

Hello mdmnd, Would you please check in Preferences => Add-ons => Extensions and see if maybe there's an extension called "Search Updater" installed ? If so : please disable or remove it, cause after that you should be able to regain control of your settings and set DuckDuckGo as your default search engine. See : [https://support.mozilla.org/en-US/kb/change-your-default-search-settings-firefox Change your default search settings in Firefox]
Was this helpful to you?
Quote

Question owner

Thank you for your persistence. The only items listed in Extensions is AdBlock and DuckDuckGo Privacy Essentials. I previously removed Google from my list of default search engines and made DuckDuckGo my default, but that still has not changed Google from coming up as my default search engine.

Thank you for your persistence. The only items listed in Extensions is AdBlock and DuckDuckGo Privacy Essentials. I previously removed Google from my list of default search engines and made DuckDuckGo my default, but that still has not changed Google from coming up as my default search engine.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
319 solutions 2843 answers

Chosen Solution

mdmnd said

When I open Firefox my search engine always shows Google.

At startup Firefox shows your homepage .....

Have you set DuckDuckGo as your homepage  ?

See :

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page

''mdmnd [[#question-1239288|said]]'' <blockquote> When I open Firefox my search engine always shows Google. </blockquote> At startup Firefox shows your homepage ..... Have you set DuckDuckGo as your homepage ? See : https://support.mozilla.org/en-US/kb/how-to-set-the-home-page
Was this helpful to you? 1
Quote

Question owner

It worked. Thank you so very much!

It worked. Thank you so very much!
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
319 solutions 2843 answers

mdmnd said

It worked. Thank you so very much!

My pleasure - I'm really glad everything's okay now.

''mdmnd [[#answer-1170093|said]]'' <blockquote> It worked. Thank you so very much! </blockquote> My pleasure - I'm really glad everything's okay now.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.