X
Tap here to go to the mobile version of the site.

Support Forum

Recent Update makes tabs and icons unreadable

Posted

Hello,

After the recent update the top bar, tabs, and even back forth home, and bookmarks and everything is unreadable. Firefox updated with a cool dark like navy blue, it looks nice, but the text stayed black. I have not been able to find a way to change this...

I would like to be able to make the text and icons be white on this dark navy blue. When A tab is selected it is showing correctly. The tab turns white, and the text is black, but all unselected tabs are very, very hard to read, in fact i cannot read them, i can just barely see where they are, especially if they have a favicon to show me where they are.

Please allow options for changes the icon colors, and the tab colors... Because right now I am struggling to use firefox, and i didn't have any issues with it before this previous update...

Hello, After the recent update the top bar, tabs, and even back forth home, and bookmarks and everything is unreadable. Firefox updated with a cool dark like navy blue, it looks nice, but the text stayed black. I have not been able to find a way to change this... I would like to be able to make the text and icons be white on this dark navy blue. When A tab is selected it is showing correctly. The tab turns white, and the text is black, but all unselected tabs are very, very hard to read, in fact i cannot read them, i can just barely see where they are, especially if they have a favicon to show me where they are. Please allow options for changes the icon colors, and the tab colors... Because right now I am struggling to use firefox, and i didn't have any issues with it before this previous update...
Attached screenshots
Quote
philipp
  • Top 25 Contributor
  • Moderator
5214 solutions 23056 answers

Helpful Reply

hi, i'm not entirely sure why this happened after the update. have you set windows 10 to be in dark mode within the system's appearance settings? if so, could you try go to the firefox menu ≡ > addons > themes panel to switch to a different theme to see if things are getting better readable then.

if you want to have total freedom to adjust the firefox colour scheme, then please see https://color.firefox.com/ :))

hi, i'm not entirely sure why this happened after the update. have you set windows 10 to be in dark mode within the system's appearance settings? if so, could you try go to the firefox ''menu ≡ > addons > themes'' panel to switch to a different theme to see if things are getting better readable then. if you want to have total freedom to adjust the firefox colour scheme, then please see https://color.firefox.com/ :))
Was this helpful to you? 1
Quote
jscher2000
  • Top 10 Contributor
8200 solutions 67063 answers

There is some work ongoing about how Firefox reads and understands Windows 10 system themes when you use the "Default" theme.

If you don't like any of the

one option might be to experiment with the following setting I saw mentioned but can't test because I'm on Windows 7:

(1) Select and copy the following preference name:

ui.systemUsesDarkTheme

(2) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(3) In the search box above the list, type theme and pause while the list is filtered

(4) In a blank area of the page, right-click, then click New, then click Integer

(5) Paste ui.systemUsesDarkTheme as the name of the preference and click OK

(6) Type 0 (that's a zero) as the value of the preference and click OK

That might not have any effect until your next Firefox startup, or the next time you change the theme, but as noted earlier, I haven't tried it myself.

There is some work ongoing about how Firefox reads and understands Windows 10 system themes when you use the "Default" theme. If you don't like any of the * built-in themes ([[Built-in themes in Firefox - alternative to complete themes]]) * add-on themes ([https://addons.mozilla.org/firefox/themes/]) * custom color options (as noted by philipp, [https://color.firefox.com/]) one option might be to experiment with the following setting I saw mentioned but can't test because I'm on Windows 7: (1) Select and copy the following preference name: ui.systemUsesDarkTheme (2) In a new tab, type '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (3) In the search box above the list, type '''theme''' and pause while the list is filtered (4) In a blank area of the page, right-click, then click New, then click Integer (5) Paste '''ui.systemUsesDarkTheme''' as the name of the preference and click OK (6) Type '''0''' (that's a zero) as the value of the preference and click OK That might not have any effect until your next Firefox startup, or the next time you change the theme, but as noted earlier, I haven't tried it myself.
Was this helpful to you?
Quote

Question owner

I think you were right, it has something to do with windows being in dark mode.

While trying again to see if there was a font color setting or something i stumbled into the theme section, and soon as i hovered over the default theme it automatically showed the correct color, however I am unable to select default.

When I select default it automatically changes it to the dark theme. this doesn't happen with the other themes, as I can select them and they work normally.

So it seems this has something to do with the windows theme being dark or normal, they are linked somehow, and honestly I don't really like that, but I sort of understand it.

I would like FF to be whichever them I want it to be individually from windows, as the windows theme is really only supposed to effect the main windows UI, but I guess that might effect some top windows bars, in this instance FF.

I think you were right, it has something to do with windows being in dark mode. While trying again to see if there was a font color setting or something i stumbled into the theme section, and soon as i hovered over the default theme it automatically showed the correct color, however I am unable to select default. When I select default it automatically changes it to the dark theme. this doesn't happen with the other themes, as I can select them and they work normally. So it seems this has something to do with the windows theme being dark or normal, they are linked somehow, and honestly I don't really like that, but I sort of understand it. I would like FF to be whichever them I want it to be individually from windows, as the windows theme is really only supposed to effect the main windows UI, but I guess that might effect some top windows bars, in this instance FF.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8200 solutions 67063 answers

Helpful Reply

Hi ongaku, Firefox 63 adapting to system themes on Windows 10 is a new feature. It seems that it just isn't fully working yet...

https://www.mozilla.org/firefox/63.0/releasenotes/

Hi ongaku, Firefox 63 adapting to system themes on Windows 10 is a new feature. It seems that it just isn't fully working yet... https://www.mozilla.org/firefox/63.0/releasenotes/
Was this helpful to you? 1
Quote
Roland Tanglao
  • Administrator
71 solutions 780 answers

Hi ongaku, thanks for your patience on this issue

On my Windows 10 computer the following steps (I'm not sure what order I did them in)

1. Windows 10 Settings > Personalization > Colors. Scroll down and select the “Dark” option under the “Choose your app mode” section. (I've also checked "Automatically pick an accent color from my background")

2. in Firefox about:addons -> Themes, select Default

3. in Firefox about:config set ui.systemUsesDarkTheme to 0 as per the fab jscher's instructions above above. Unfortunately as always changing anything in about:config can lead to things breaking at any moment and there's no real support for about:config changes. But hopefully you can remove the above:config tweak in a future release.

Anyhow the above works for me (see screenshot) and the tab icons are visible and tab text is white. I believe if you "play around" with Windows 10 settings and can figure out how to select the default Firefox theme (not sure why you can't, perhaps it's another Firefox theme you installed or a Firefox add-on you installed; check out 1,2,3 for help on this) you can get something readable and that you like.

Finally copying and pasting about:support into a reply on this thread should help further if the above doesn't work.

Cheers! ...Roland

p.s. over the 9 years i've worked on thunderbird and firefox support, people always have issues with the dark theme on Windows, has it got better? what do people use dark mode for ? i've heard folks use it because of movie editing and photo editing and of course personal preference, my personal preference is all things bright even when editing photos but of course your mileage may vary

Hi ongaku, thanks for your patience on this issue On my Windows 10 computer the following steps (I'm not sure what order I did them in) 1. Windows 10 Settings > Personalization > Colors. Scroll down and select the “Dark” option under the “Choose your app mode” section. (I've also checked "Automatically pick an accent color from my background") 2. in Firefox about:addons -> Themes, select Default 3. in Firefox about:config set ui.systemUsesDarkTheme to 0 as per [https://support.mozilla.org/en-US/questions/1238343#answer-1167155 the fab jscher's instructions above] above. Unfortunately as always changing anything in about:config can lead to things breaking at any moment and there's no real support for about:config changes. But hopefully you can remove the above:config tweak in a future release. Anyhow the above works for me (see screenshot) and the tab icons are visible and tab text is white. I believe if you "play around" with Windows 10 settings and can figure out how to select the default Firefox theme (not sure why you can't, perhaps it's another Firefox theme you installed or a Firefox add-on you installed; check out [https://support.mozilla.org/en-US/kb/disable-or-remove-add-ons 1],[https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems 2],[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode 3] for help on this) you can get something readable and that you like. Finally copying and pasting about:support into a reply on this thread should help further if the above doesn't work. Cheers! ...Roland p.s. over the 9 years i've worked on thunderbird and firefox support, people always have issues with the dark theme on Windows, has it got better? what do people use dark mode for ? i've heard folks use it because of movie editing and photo editing and of course personal preference, my personal preference is all things bright even when editing photos but of course your mileage may vary
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.