Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Won't Play Steaming Audio: Certain Websites Only

  • 8 replies
  • 1 has this problem
  • 1222 views
  • Last reply by FredMcD

more options

Recently Firefox has stopped playing streaming audio from Google Play or Slacker. It has worked on those sites well, an for years. Audio from Spotify or Youtube work flawlessly. Slacker provides a popup error message that says "Your browser is disabling audio from Slacker Radio. Please update your browser settings. " Google is playing, but no audio is produced. Volume settings on the website are fine. I am running Windows 10 1803 and Firefox 62.0.3 (64-bit). I have tried:

        running Firefox in safe mode; 
        cleared the cache; and 
        disabling Flash Player 

I still have the problem.

Any ideas?

Modified by spwood

Chosen solution

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

Read this answer in context 👍 0

All Replies (8)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

I have tried running is safe mode, and still have the problem. I don't see the content-blocking icon in the address bar, and permissions for the page show tracking protection is off.

more options

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Most of what you suggested above I've already tried, without success. I have just tried deleting cookies and affected sites won't stream audio. They work well on Chrome (which I absolutely don't want to use) . Spotify and Youtube continue to work well, but Slacker and Google Play will not.

more options

Did you Clear the Cache and Remove Cookies?

Have you tried Firefox Safe Mode?

more options

Yes... as stated in my original post.

I have cleared the cache, cleared cookies, run in safe mode, disabled and re-enabled Flash Player. None of those things helped.

more options

Problem solved!

Some time ago, I had used about:config and change several settings to disable video autoplay as recommended here: https://support.mozilla.org/en-US/questions/1150702

On a whim, I restored all of those media settings to their default values - and now Slacker and Google Play work perfectly.

I suggest modifying the article cited above to mention that the settings might also affect some streaming audio services.

more options

Chosen Solution

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.