X
Tap here to go to the mobile version of the site.

Support Forum

search suggestions no longer work like before

Posted

Today the search suggestions on the Google search page stopped working in Firefox (safe mode too) after Firefox update 62.0.2 (64-bit). Regardless of what settings I choose in about:preferences#search I can't make the search suggestions work as before which is showing in the Google page search bar and not in the address or Firefox search toolbar. This is extremely annoying that is making me use Chrome instead of Firefox. My home page is Google search and opening a new window comes with the insertion point for typing text in the Google search bar in the middle of the page not the address bar. I'm using latest version of Firefox today which is Sep 23 2018 and I'm using Windows 7 64bit

Please help!

Today the search suggestions on the Google search page stopped working in Firefox (safe mode too) after Firefox update 62.0.2 (64-bit). Regardless of what settings I choose in about:preferences#search I can't make the search suggestions work as before which is showing in the Google page search bar and not in the address or Firefox search toolbar. This is extremely annoying that is making me use Chrome instead of Firefox. My home page is Google search and opening a new window comes with the insertion point for typing text in the Google search bar in the middle of the page not the address bar. I'm using latest version of Firefox today which is Sep 23 2018 and I'm using Windows 7 64bit Please help!

Modified by Startup123

Chosen solution

try to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

Read this answer in context 1
FFus3r 50 solutions 757 answers

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.
The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen.
Pj 42 solutions 869 answers

Startup123 said

Today, the search suggestions on the Google search page stopped working in Firefox (safe mode too) after Firefox update 62.0.2 (64-bit)...
  • I don't know about Google, but there is still some Address Bar Autofill issues in FF 62.0.2:


~Pj

''Startup123 [[#question-1235020|said]]'' <blockquote> Today, the search suggestions on the Google search page stopped working in Firefox (safe mode too) after Firefox update 62.0.2 (64-bit)... </blockquote> * I don't know about Google, but there is still some Address Bar Autofill issues in FF 62.0.2: * [https://bugzilla.mozilla.org/show_bug.cgi?id=1488879#c49 Bug 1488879] * [https://bugzilla.mozilla.org/buglist.cgi?short_desc_type=allwordssubstr&short_desc=Autofill&resolution=---&query_format=advanced&product=Firefox More on Autofill on BugZilla] (Click on the ''''Changed'''' column one or more times to re-order the list for most recent postings.) ~Pj

Modified by Pj

Question owner

Thank you for your replies but unfortunately the problem remains. The Refresh did not help. I refreshed twice. After the first refresh I set Google as a home page and open a new window. The insertion point for typing text was in the address bar and not in the Google web page search bar. I clicked in the Google page search bar and it showed search suggestions when I typed and I thought this part is fixed. But now when opening a new page I have the problem with the text insertion point being in the address bar instead in the Google page search bar. I couldn't find any settings in the Options for changing the default place for the text insertion point. In an attempt to fix that I checked 'Add search bar in toolbar' in the search options. Then new pages opened with the text insertion point in the Google page toolbar but again the search suggestion stop appearing when I type and I couldn't bring it back. Then I made a second refresh which didn't fix the problem at all but looks like brought the state of Firefox before the first refresh because after the first refresh my custom settings and extensions were gone but after the second refresh they were back as If noting happened.

edit: On first check after the second refresh I saw the extensions I installed were back and they were missing after the first refresh. However after I check again now I see two more extensions added meanwhile automatically. Telemetry coverage 7.0 and something else that I couldn't remember because both of these extensions disappeared after I refreshed the Add-ons page. What on earth is going on?

I will greatly appreciate any further help and suggestions

Thank you for your replies but unfortunately the problem remains. The Refresh did not help. I refreshed twice. After the first refresh I set Google as a home page and open a new window. The insertion point for typing text was in the address bar and not in the Google web page search bar. I clicked in the Google page search bar and it showed search suggestions when I typed and I thought this part is fixed. But now when opening a new page I have the problem with the text insertion point being in the address bar instead in the Google page search bar. I couldn't find any settings in the Options for changing the default place for the text insertion point. In an attempt to fix that I checked 'Add search bar in toolbar' in the search options. Then new pages opened with the text insertion point in the Google page toolbar but again the search suggestion stop appearing when I type and I couldn't bring it back. Then I made a second refresh which didn't fix the problem at all but looks like brought the state of Firefox before the first refresh because after the first refresh my custom settings and extensions were gone but after the second refresh they were back as If noting happened. edit: On first check after the second refresh I saw the extensions I installed were back and they were missing after the first refresh. However after I check again now I see two more extensions added meanwhile automatically. Telemetry coverage 7.0 and something else that I couldn't remember because both of these extensions disappeared after I refreshed the Add-ons page. What on earth is going on? I will greatly appreciate any further help and suggestions

Modified by Startup123

FFus3r 50 solutions 757 answers
see this answer: * https://support.mozilla.org/en-US/questions/1175449#answer-1006468

Question owner

FFus3r thank for your reply but I have already checked that answer before starting this topic. As sadFFuser replied there, I also don't see a checkbox or anything that can turn on Google search suggestions on the link provided https://www.google.com/preferences?hl=en http://www.google.com/preferences?hl=en

Does anyone see such thing on that link?

FFus3r thank for your reply but I have already checked that answer before starting this topic. As sadFFuser replied there, I also don't see a checkbox or anything that can turn on Google search suggestions on the link provided [https://www.google.com/preferences?hl=en https://www.google.com/preferences?hl=en] http://www.google.com/preferences?hl=en Does anyone see such thing on that link?

Question owner

Can anyone please confirm that with the latest version of Firefox, and home page set to Google have search suggestions appear when typing in the Google page search bar?

I just would like to know if it is only me so far with this problem

I will greatly appreciate your reply

Can anyone please confirm that with the latest version of Firefox, and home page set to Google have search suggestions appear when typing in the Google page search bar? I just would like to know if it is only me so far with this problem I will greatly appreciate your reply

Modified by Startup123

Question owner

As a workaround I can use Firefox as a home page with Google set as default search engine where the search suggestions appear but then the problem remains with fixing the text insertion point being in the Google bar and not the address bar when opening a new window. Is there a way to set the default position of the text insertion to be in the Search bar instead of the address bar?

As a workaround I can use Firefox as a home page with Google set as default search engine where the search suggestions appear but then the problem remains with fixing the text insertion point being in the Google bar and not the address bar when opening a new window. Is there a way to set the default position of the text insertion to be in the Search bar instead of the address bar?

Modified by Startup123

Pj 42 solutions 869 answers

Startup123 said

Can anyone please confirm that with the latest version of Firefox, and home page set to Google have search suggestions appear when typing in the Google page search bar? I just would like to know if it is only me so far with this problem I will greatly appreciate your reply


I don't know if this is Google-related, but there is bug with Auto-fill in the Address Bar.

~ Pj

''Startup123 [[#answer-1158358|said]]'' <blockquote> Can anyone please confirm that with the latest version of Firefox, and home page set to Google have search suggestions appear when typing in the Google page search bar? I just would like to know if it is only me so far with this problem I will greatly appreciate your reply </blockquote> I don't know if this is Google-related, but there is bug with Auto-fill in the Address Bar. ~ Pj
FFus3r 50 solutions 757 answers

Chosen Solution

try to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. (Firefox 57 and above) Click the Library button 57 library icon and choose History.
    (Click the menu button New Fx Menu and choose History in older Firefox versions.)
  2. In the History menu, choose "Clear Recent History...".
  3. Under "Time range to clear", select "Everything".
  4. Now, click the arrow next to Details to toggle the Details list active.
  5. From the details list, check Cache and Cookies and uncheck everything else.
  6. Now click the "Clear Now" button.

Further information can be found in the Delete browsing, search and download history on Firefox article.

try to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #('''Firefox 57 and above''') Click the Library button [[Image:57 library icon]] and choose History.<br>(Click the menu button [[Image:New Fx Menu]] and choose History in older Firefox versions.) #In the History menu, choose "Clear Recent History...". #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the "Clear Now" button. Further information can be found in the [[Delete browsing, search and download history on Firefox]] article.

Question owner

FFus3r,

It was the cookies, I cleared the cash completely before but was hoping to save the cookies and clear them as a last resort in order to avoid logging again on each site that remembers me.

Well, at least this fixed it.

Thank you all for all the help, I really appreciate it

FFus3r, It was the cookies, I cleared the cash completely before but was hoping to save the cookies and clear them as a last resort in order to avoid logging again on each site that remembers me. Well, at least this fixed it. Thank you all for all the help, I really appreciate it