X
Tap here to go to the mobile version of the site.

Support Forum

In Firefox, Google search-box does not show the popular search terms as you type in but Google in Safari does! Any suggestions why?

Posted

Hi all, This problem is bothering me for quite a while !! There was no problem until I updated my Firefox to version 55.0.3 (64-bit, OSX).

Please see the two screenshots from google page. The one with search texts "why i" in Google search box is accessed by Firefox and the other screenshot showing the search suggestions accessed by Safari.

Why the Google search box in Mozilla-Firefox not suggesting popular search terms? Don't put the blame on Google as it is evidently not happening with Safari.

Any suggestion is much appreciated.

P:S: It does not happen either in my work computer (another MAC-OSX) where the same Firefox account is being used and syncing is fine. Cheers

Hi all, This problem is bothering me for quite a while !! There was no problem until I updated my Firefox to version 55.0.3 (64-bit, OSX). Please see the two screenshots from google page. The one with search texts "why i" in Google search box is accessed by Firefox and the other screenshot showing the search suggestions accessed by Safari. Why the Google search box in Mozilla-Firefox not suggesting popular search terms? Don't put the blame on Google as it is evidently not happening with Safari. Any suggestion is much appreciated. P:S: It does not happen either in my work computer (another MAC-OSX) where the same Firefox account is being used and syncing is fine. Cheers
Attached screenshots

Chosen solution

Note that Google has a checkbox on its settings page to enable suggestions.

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox -> Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox -> Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:55.0) Gecko/20100101 Firefox/55.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17689 solutions 160039 answers

Chosen Solution

Note that Google has a checkbox on its settings page to enable suggestions.

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox -> Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox -> Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"
Note that Google has a checkbox on its settings page to enable suggestions. * http://www.google.com/preferences?hl=en Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache": *Firefox -> Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now" "Remove the cookies" from websites that cause problems. *Firefox -> Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"
sadFFuser 0 solutions 2 answers

Helpful Reply

I can't se ANY setting on given webpage that would enable or disable search suggestions. I can enable/disable SafeSearch filter, I can set amount of results per search page, I can decide if search results will be open in new or the same window and set region. That's all. Also I don't get what you mean by "remove cookies from websites that cause problems". Do you have list of websites that cause problem in this case? I have problem with Firefox which does not work correctly with google website, and not with any other websites. At least - not in this case.

I can't se ANY setting on given webpage that would enable or disable search suggestions. I can enable/disable SafeSearch filter, I can set amount of results per search page, I can decide if search results will be open in new or the same window and set region. That's all. Also I don't get what you mean by "remove cookies from websites that cause problems". Do you have list of websites that cause problem in this case? I have problem with Firefox which does not work correctly with google website, and not with any other websites. At least - not in this case.
cor-el
  • Top 10 Contributor
  • Moderator
17689 solutions 160039 answers

If you have a problem with a specific website and that website uses cookies then you can remove the cookies used by this web page (domain) to see if that has effect. Corrupted cookies can cause a lot of weird issues.

You can also check for malware.

If you have a problem with a specific website and that website uses cookies then you can remove the cookies used by this web page (domain) to see if that has effect. Corrupted cookies can cause a lot of weird issues. You can also check for malware. *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware