X
Tap here to go to the mobile version of the site.

Support Forum

Problem playing videos

Posted

This is a link to my university video courses: http://video.tau.ac.il/index.php?option=com_videos&view=video&id=14444&Itemid=53&lang=he when I enter a video I get the following error message: "Error loading player: No playable sources found". when I enter the web console I can see the following error message: "Cannot play media. No decoders for requested formats: application/vnd.apple.mpegurl". I disabled all of my add-ons/plugins and the video still doesn't play. what can I do? in chrome I can see the videos but I want to use firefox. Thank you in advance

This is a link to my university video courses: http://video.tau.ac.il/index.php?option=com_videos&view=video&id=14444&Itemid=53&lang=he when I enter a video I get the following error message: "Error loading player: No playable sources found". when I enter the web console I can see the following error message: "Cannot play media. No decoders for requested formats: application/vnd.apple.mpegurl". I disabled all of my add-ons/plugins and the video still doesn't play. what can I do? in chrome I can see the videos but I want to use firefox. Thank you in advance

Modified by cellularplaya

Chosen solution

cellularplaya said

the problem is still happening and the shield icon doesn't appear. any more ideas that might help me solve the problem?

Maybe try this :

3-bar menu => Options => General

Scroll down to "Digital Rights Management (DRM) Content"

Make sure that "Play DRM-controlled content" is checked.


Another thing to try :

3-bar menu => Add-ons => plugins

Make sure that "Shockwave Flash" is set to "Always Activate".

(assuming that you have Adobe Flash installed on your system)

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0

More Information

FredMcD
  • Top 10 Contributor
3774 solutions 52224 answers

Helpful Reply

The website requires one to log in. Have you contacted their support?

The website requires one to log in. Have you contacted their support?
Was this helpful to you? 2
Quote

Question owner

so far not, it's holiday now and its hard to get them. any chance I can solve the issue on my side?

so far not, it's holiday now and its hard to get them. any chance I can solve the issue on my side?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3774 solutions 52224 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}
Was this helpful to you? 1
Quote

Question owner

the problem is still happening and the shield icon doesn't appear. any more ideas that might help me solve the problem?

the problem is still happening and the shield icon doesn't appear. any more ideas that might help me solve the problem?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers

Chosen Solution

cellularplaya said

the problem is still happening and the shield icon doesn't appear. any more ideas that might help me solve the problem?

Maybe try this :

3-bar menu => Options => General

Scroll down to "Digital Rights Management (DRM) Content"

Make sure that "Play DRM-controlled content" is checked.


Another thing to try :

3-bar menu => Add-ons => plugins

Make sure that "Shockwave Flash" is set to "Always Activate".

(assuming that you have Adobe Flash installed on your system)

''cellularplaya [[#answer-1157399|said]]'' <blockquote> the problem is still happening and the shield icon doesn't appear. any more ideas that might help me solve the problem? </blockquote> Maybe try this : 3-bar menu => Options => General Scroll down to "Digital Rights Management (DRM) Content" Make sure that "Play DRM-controlled content" is checked. -------------------------------------------------------------------------------------------------------- Another thing to try : 3-bar menu => Add-ons => plugins Make sure that "Shockwave Flash" is set to "Always Activate". (assuming that you have Adobe Flash installed on your system)
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16657 solutions 150560 answers

If that is the only content type that is available then you may be out of luck with Firefox.

For this MIME type you may have to use another browser.

If that is the only content type that is available then you may be out of luck with Firefox. For this MIME type you may have to use another browser. *application/vnd.apple.mpegurl *https://developer.mozilla.org/Apps/Build/Audio_and_video_delivery
Was this helpful to you? 1
Quote

Question owner

McCoy said

cellularplaya said
the problem is still happening and the shield icon doesn't appear. any more ideas that might help me solve the problem?

Maybe try this :

3-bar menu => Options => General

Scroll down to "Digital Rights Management (DRM) Content"

Make sure that "Play DRM-controlled content" is checked.


Another thing to try :

3-bar menu => Add-ons => plugins

Make sure that "Shockwave Flash" is set to "Always Activate".

(assuming that you have Adobe Flash installed on your system)

Well apparently the flash was disabled because in was vulnerable. so I updated it to the last version and activate it and the problem solved. thank you very much!

''McCoy [[#answer-1157410|said]]'' <blockquote> ''cellularplaya [[#answer-1157399|said]]'' <blockquote> the problem is still happening and the shield icon doesn't appear. any more ideas that might help me solve the problem? </blockquote> Maybe try this : 3-bar menu => Options => General Scroll down to "Digital Rights Management (DRM) Content" Make sure that "Play DRM-controlled content" is checked. -------------------------------------------------------------------------------------------------------- Another thing to try : 3-bar menu => Add-ons => plugins Make sure that "Shockwave Flash" is set to "Always Activate". (assuming that you have Adobe Flash installed on your system) </blockquote> Well apparently the flash was disabled because in was vulnerable. so I updated it to the last version and activate it and the problem solved. thank you very much!
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers

cellularplaya said

Well apparently the flash was disabled because in was vulnerable. so I updated it to the last version and activate it and the problem solved.

Well done, you - I'm glad that you can follow your courses  !

''cellularplaya [[#answer-1157702|said]]'' <blockquote> Well apparently the flash was disabled because in was vulnerable. so I updated it to the last version and activate it and the problem solved. </blockquote> Well done, you - I'm glad that you can follow your courses !
Was this helpful to you? 1
Quote

Question owner

can you please help me with the relate matter ?

https://support.mozilla.org/en-US/questions/1234978

can you please help me with the relate matter ? https://support.mozilla.org/en-US/questions/1234978
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers

cellularplaya said

can you please help me with the relate matter ? https://support.mozilla.org/en-US/questions/1234978

This is what you posted in that closed thread :

"Now, after I managed to see the videos I'm trying to set the following command in the web console in order to watch the video faster:

theVideo.playbackRate = 2

but I get the following error message:

"TypeError: theVideo is null[Learn More]"

and this is the link to the learn more: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Unexpected_type

so, any idea how to increase the playback rate of the video whilst watching it in firefox?

Thank you in advance "

''cellularplaya [[#answer-1158078|said]]'' <blockquote> can you please help me with the relate matter ? https://support.mozilla.org/en-US/questions/1234978 </blockquote> This is what you posted in that closed thread : "Now, after I managed to see the videos I'm trying to set the following command in the web console in order to watch the video faster: theVideo.playbackRate = 2 but I get the following error message: "TypeError: theVideo is null[Learn More]" and this is the link to the learn more: https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference/Errors/Unexpected_type so, any idea how to increase the playback rate of the video whilst watching it in firefox? Thank you in advance "

Modified by McCoy

Was this helpful to you? 1
Quote

Question owner

yes, any idea?

yes, any idea?
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers

cellularplaya said

yes, any idea?

I've called for help .......

''cellularplaya [[#answer-1158104|said]]'' <blockquote> yes, any idea? </blockquote> I've called for help .......
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers
All I can come up with are these add-ons : https://addons.mozilla.org/en-US/firefox/addon/videospeed/?src=featured https://addons.mozilla.org/en-US/firefox/addon/playback-speed/ https://addons.mozilla.org/en-US/firefox/addon/faster-video/
Was this helpful to you?
Quote

Question owner

ohh thanks, but none of them worked cause they're good for html5 videos and I deal with flash videos

ohh thanks, but none of them worked cause they're good for html5 videos and I deal with flash videos
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers

cellularplaya said

ohh thanks, but none of them worked cause they're good for html5 videos and I deal with flash videos

My bad (sorry ..... )

I am sooo glad that I called for help ....

''cellularplaya [[#answer-1158132|said]]'' <blockquote> ohh thanks, but none of them worked cause they're good for html5 videos and I deal with flash videos </blockquote> My bad (sorry ..... ) I am sooo glad that I called for help ....
Was this helpful to you? 1
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers

....... and I'm back.

Fellow contributor jscher2000 told me in a private message :

" I don't think it's a question for Mozilla Support. The video plays. It just doesn't have a speed control, which is a feature controlled by the player (SWF file), not by the browser."


And I found this :

https://smallbusiness.chron.com/speed-up-video-playback-adobe-flash-player-78580.html

Does that help  ?

....... and I'm back. Fellow contributor jscher2000 told me in a private message : "'' I don't think it's a question for Mozilla Support. '' The video plays. It just doesn't have a speed control, which is a feature '' '' controlled by the player (SWF file), not by the browser.''" ------------------------------------------------------------------------------------------------- And I found this : https://smallbusiness.chron.com/speed-up-video-playback-adobe-flash-player-78580.html Does that help ?
Was this helpful to you? 1
Quote

Question owner

McCoy said

....... and I'm back. Fellow contributor jscher2000 told me in a private message : " I don't think it's a question for Mozilla Support. The video plays. It just doesn't have a speed control, which is a feature controlled by the player (SWF file), not by the browser."

And I found this :

https://smallbusiness.chron.com/speed-up-video-playback-adobe-flash-player-78580.html

Does that help  ?

yes, I also think that the question related to Adobe, Thank you very much anyway for the help

''McCoy [[#answer-1158182|said]]'' <blockquote> ....... and I'm back. Fellow contributor jscher2000 told me in a private message : "'' I don't think it's a question for Mozilla Support. '' The video plays. It just doesn't have a speed control, which is a feature '' '' controlled by the player (SWF file), not by the browser.''" ------------------------------------------------------------------------------------------------- And I found this : https://smallbusiness.chron.com/speed-up-video-playback-adobe-flash-player-78580.html Does that help ? </blockquote> yes, I also think that the question related to Adobe, Thank you very much anyway for the help
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
204 solutions 1710 answers

cellularplaya said

Thank you very much anyway for the help

My pleasure - good luck with your studies  !

''cellularplaya [[#answer-1158191|said]]'' <blockquote> Thank you very much anyway for the help </blockquote> My pleasure - good luck with your studies !
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.