X
Tap here to go to the mobile version of the site.

Support Forum

How can I use unity web player in firefox 60?

Posted

Hello, I want to use unity web player and cannot seem to get it to work with Firefox 60, and cannot download Firefox 52 ESR to use it with an older version. Can you please tell me how to use unity web player on Firefox 60, or provide a download link to Firefox 52 ESR, this link will not work: https://www.mozilla.org/en-US/firefox/organizations/all/ I can only download ESR for Firefox 60, and unity web player does not show up in about:addons plugins section. Thanks

Hello, I want to use unity web player and cannot seem to get it to work with Firefox 60, and cannot download Firefox 52 ESR to use it with an older version. Can you please tell me how to use unity web player on Firefox 60, or provide a download link to Firefox 52 ESR, this link will not work: https://www.mozilla.org/en-US/firefox/organizations/all/ I can only download ESR for Firefox 60, and unity web player does not show up in about:addons plugins section. Thanks

Modified by ajax146

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

Wesley Branton
  • Top 10 Contributor
573 solutions 4884 answers

Firefox ESR 52 has since been discontinued, which is why you can no longer download it. Therefore, NPAPI plugins are no longer supported in Firefox.

Unfortunately, this includes the Unity Web Player. Unity has also discontinued the Web Player also to pursue the new browser technology.

Firefox ESR 52 has since been discontinued, which is why you can no longer download it. Therefore, [https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/ NPAPI plugins] are no longer supported in Firefox. Unfortunately, this includes the Unity Web Player. Unity has also discontinued the Web Player also to pursue the new browser technology.
James
  • Moderator
1593 solutions 11224 answers

Wesley Branton said

Therefore, NPAPI plugins are no longer supported in Firefox.

To be more clear, only the NPAPI Flash Player Plugin from Adobe is allowed to run in Firefox 52.0 Release and later including 62.0.2 Release and 60.2.0 ESR. Only the 52.9.0esr allowed on Plugins to run, on Windows one needed the 32-bit version.

However even the Flash Player Plugin is going to be used under increasing restrictions as time goes on and Adobe will stop shipping security updates for Flash at the end of 2020. https://developer.mozilla.org/en-US/docs/Plugins/Roadmap

''Wesley Branton [[#answer-1157153|said]]'' <blockquote> Therefore, [https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/ '''NPAPI plugins] are no longer supported in Firefox'''. </blockquote> To be more clear, '''only the NPAPI Flash Player Plugin from Adobe is allowed to run in Firefox 52.0 Release and later including 62.0.2 Release and 60.2.0 ESR'''. Only the 52.9.0esr allowed on Plugins to run, on Windows one needed the 32-bit version. However even the Flash Player Plugin is going to be used under increasing restrictions as time goes on and Adobe will stop shipping security updates for Flash at the end of 2020. https://developer.mozilla.org/en-US/docs/Plugins/Roadmap

Modified by James