X
Tap here to go to the mobile version of the site.

Support Forum

Proxy UserName and Password not saved

Posted

Firefox 60.2.0 ESR on Win7 and Win10 - but a lot of versions below had same problem

We use a proxy - normally with a .PAC file via System Settings but tested settings within FF with .PAC file or directly entered proxy.

It prompts after every launch of FF for Proxy credentials and NEVER shows the "Would you like Firefox to save this login..."

For any other site it always offers storing the credetials and it works like it should be.

EXCEPT I found one solution: When launching FF Cancel the "Authentication Required" (sometimes 3 to 7 times canceling). Than open any page on the web and authenticate against the proxy - it will show the "Would you like Firefox to save this login..." and it is visible in the password store. Thereafter everything is operational.

Another problem: If you ever click on "Never save" for proxy saving credential this proxy site it NOT added to the Exceptions list and cannot be removed and I did not find any way to solve it except removing the Firefox profile.

Tested with German and English Version Searched for a solution since a year ever and ever again configured dozens of parameters in about:config which I found on the web. Credentials for every other site are always saved.

Users with a old Firefox profiles with saved proxy credential do not have this problem, only new FF profiles - since at least a year possilbly longer.

Firefox 60.2.0 ESR on Win7 and Win10 - but a lot of versions below had same problem We use a proxy - normally with a .PAC file via System Settings but tested settings within FF with .PAC file or directly entered proxy. It prompts after every launch of FF for Proxy credentials and NEVER shows the "Would you like Firefox to save this login..." For any other site it always offers storing the credetials and it works like it should be. EXCEPT I found one solution: When launching FF Cancel the "Authentication Required" (sometimes 3 to 7 times canceling). Than open any page on the web and authenticate against the proxy - it will show the "Would you like Firefox to save this login..." and it is visible in the password store. Thereafter everything is operational. Another problem: If you ever click on "Never save" for proxy saving credential this proxy site it NOT added to the Exceptions list and cannot be removed and I did not find any way to solve it except removing the Firefox profile. Tested with German and English Version Searched for a solution since a year ever and ever again configured dozens of parameters in about:config which I found on the web. Credentials for every other site are always saved. Users with a old Firefox profiles with saved proxy credential do not have this problem, only new FF profiles - since at least a year possilbly longer.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/65.0.3325.183 Safari/537.36 Vivaldi/1.96.1147.64

More Information

FFus3r
  • Top 10 Contributor
50 solutions 757 answers

hi,

  • In Address bar write about:config
  • In filter write network.auth.use-sspi
  • Double click on true and it should become false
hi, * In Address bar write '''about:config''' * In filter write '''network.auth.use-sspi''' * '''Double click''' on true and it should become '''false'''
Was this helpful to you? 0
Quote

Question owner

sorry for late answer -was on Holiday.

Problem not solved, still the same, tested with 60.2.2 ESR

Still same: Need to cancel INITIAL Proxy authentication several times until no authentication question - than open any new web page and after authenticating to Proxy the questionair to save the Password for Proxy Server is popping up.

sorry for late answer -was on Holiday. Problem not solved, still the same, tested with 60.2.2 ESR Still same: Need to cancel INITIAL Proxy authentication several times until no authentication question - than open any new web page and after authenticating to Proxy the questionair to save the Password for Proxy Server is popping up.
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
224 solutions 1911 answers

Hello KlaBa,

On the about:config page, would you check the values of these preferences :

network.negotiate-auth.allow-proxies and : signon.autologin.proxy

Hello KlaBa, On the '''about:config''' page, would you check the values of these preferences : '''network.negotiate-auth.allow-proxies''' and : '''signon.autologin.proxy'''
Was this helpful to you?
Quote

Question owner

both values are set to "true"

both values are set to "true"
Was this helpful to you?
Quote

Question owner

Problem solved: Proxy Server was replaced:

company used a Proxy Cyan Secure Web with Basic LDAP to AD authentication with CharSet ISO 8859-1 which was not opertional - see above discription

now replaced with a proxy Cisco Web Security with NTLM authentication and fall back to Basic LDAP with CodePage UTF-8

everything operational now - possibly someone may help this Information.

Problem solved: Proxy Server was replaced: company used a Proxy Cyan Secure Web with Basic LDAP to AD authentication with CharSet ISO 8859-1 which was not opertional - see above discription now replaced with a proxy Cisco Web Security with NTLM authentication and fall back to Basic LDAP with CodePage UTF-8 everything operational now - possibly someone may help this Information.
Was this helpful to you?
Quote
WestEnd
  • Top 10 Contributor
57 solutions 3517 answers

Proxy issues isn't something firefox browser end user help forum can't resolve.

Proxy issues isn't something firefox browser end user help forum can't resolve.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.