Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why can't I access yahoo mail through Firefox?

  • 3 replies
  • 1 has this problem
  • Last reply by jscher2000

more options

After months, maybe even years of seeing banners on Firefox saying things like PROTECT NET NEUTRALITY, Firefox now seems to be exploiting the end of Net Neutrality by throttling Yahoo. The last Firefox update did not even include Yahoo and a possible browser. I had to go through a bunch of mumbo jumbo I found on another website to find out how to add Yahoo as a browser in Firefox. Here's the news: I have had Yahoo Mail for 15 years. Now I can't access it. I can't even confirm my registration to this forum BECAUSE I CAN'T ACCESS MY EMAIL ACCOUNT. Naturally, this pisses me off. Fix it.

All Replies (3)

more options

Hi Frustratedpoopiebutt, could you describe in more detail what happens when you try to access Yahoo mail in Firefox. For example: blank screen, login rejected, security certificate error, Inbox doesn't load fully, buttons not functioning, something else.

If you are using an old bookmark for Yahoo mail, try starting from the generic address:

Or start from your Yahoo home page or My Yahoo page.

If a site is generally known to work in Firefox, these are general suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature and extensions that counter ads and tracking may break websites that weren't built to operate normally without the blocked components.

Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: What happened to Tracking Protection?.

Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "Clear Cookies and Site Data"
  • (menu bar) Tools > Page Info > Security > "Clear Cookies and Site Data"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "Clear Cookies and Site Data" button

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Yes, I've cleaned my cache and cookies. I don't think it's the content blocker. All I get is a picture of a sad dinosaur along with the message, "The connection has timed out." Then it says, "The server at is taking too long to respond." Also, I've discovered that it's also happening in Chrome and Explorer. No other sites seem to be affected.

more options

Hmm, Yahoo search is working for me at the moment. I don't know why all of your browsers would be blocked from it.

Is that also the message you get for email using ?