X
Tap here to go to the mobile version of the site.

Support Forum

signon.rememberSignons preference does not work after 62.0

Posted

Hi! After updating to Firefox 62.0 seems to preference signon.rememberSignons does not work anymore. It was set using defaultPref as unchecked, but in 62.0 it appear as selected. Also, seems to lockPref does not work. Confusing for many users. Any ideas? More thanks, Alar.

Hi! After updating to Firefox 62.0 seems to preference signon.rememberSignons does not work anymore. It was set using defaultPref as unchecked, but in 62.0 it appear as selected. Also, seems to lockPref does not work. Confusing for many users. Any ideas? More thanks, Alar.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

Shadow110 1072 solutions 14836 answers

Separate Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Do not know any thing further than below, all info archived will need to see below or wait for someone that knows.

https://support.mozilla.org/en-US/products/firefox-enterprise Should maybe find some info here as is new home of MDM Web Docs.

''Separate'' Security Issue, please update your Flash 27.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> Do not know any thing further than below, all info archived will need to see below or wait for someone that knows. https://support.mozilla.org/en-US/products/firefox-enterprise Should maybe find some info here as is new home of MDM Web Docs.

Question owner

Ok, fixed it, thanks. We'll wait then for someone to reply on subject. Alar.

Ok, fixed it, thanks. We'll wait then for someone to reply on subject. Alar.
Mike Kaply
  • Moderator
38 solutions 198 answers

Can you provide more details on your usage of signon.rememberSignons?

I assume you mean in autoconfig?

It's possible your autoconfig is not being read at all because of sandbox and you need to set a pref for that.

Do you see errors on the console?

Can you provide more details on your usage of signon.rememberSignons? I assume you mean in autoconfig? It's possible your autoconfig is not being read at all because of sandbox and you need to set a pref for that. Do you see errors on the console?
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157991 answers

^Quote: Do you see errors on the console?

Note that this is about the Browser Console.

See also:

^Quote: ''Do you see errors on the console?'' Note that this is about the Browser Console. *https://developer.mozilla.org/en-US/Tools/Browser_Console See also: *https://www.mozilla.org/en-US/firefox/62.0/releasenotes/

Question owner

Hi and thanks! Sorry for delay. Yes, using autoconfig. Can’t say about console, must study it, but no other settings missed, as far I’m aware of. More thanks, Alar.

Hi and thanks! Sorry for delay. Yes, using autoconfig. Can’t say about console, must study it, but no other settings missed, as far I’m aware of. More thanks, Alar.
Mike Kaply
  • Moderator
38 solutions 198 answers

I've verified that signon.rememberSignons is definitely the pref that maps to "Asl to save logins and password for websites"

I've verified that signon.rememberSignons is definitely the pref that maps to "Asl to save logins and password for websites"
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157991 answers

The signon.rememberSignons pref should work in an autoconfig file (I use it myself, but with a defaultPref() call), so if it isn't working then something else is wrong. That is why I suggested to check the Browser Console for right-click context menu.

Can you post the content of the autoconfig file?


You aren't using GPO or a policies.json file that might interfere?

The signon.rememberSignons pref should work in an autoconfig file (I use it myself, but with a defaultPref() call), so if it isn't working then something else is wrong. That is why I suggested to check the Browser Console for right-click context menu. Can you post the content of the autoconfig file? ---- You aren't using GPO or a policies.json file that might interfere? *https://support.mozilla.org/en-US/kb/customizing-firefox-using-group-policy *https://support.mozilla.org/en-US/kb/customizing-firefox-using-policiesjson *https://support.mozilla.org/en-US/kb/customizing-firefox-using-autoconfig *https://github.com/mozilla/policy-templates/blob/master/README.md

Question owner

Hi and thanks! Well, yes, nothing to-do with named in subject preference. “ReferenceError: Components is not defined”. Used in cfg one “components” and as this became obsolete (at least for using in cfg as used to) … error and rest of cfg wasn’t processed. … Why not just to ignore such obsolete references by design!? More thanks, Alar.

Hi and thanks! Well, yes, nothing to-do with named in subject preference. “ReferenceError: Components is not defined”. Used in cfg one “components” and as this became obsolete (at least for using in cfg as used to) … error and rest of cfg wasn’t processed. … Why not just to ignore such obsolete references by design!? More thanks, Alar.

Modified by MozAlf

Mike Kaply
  • Moderator
38 solutions 198 answers

This is because autoconfig is sandboxed by default on Firefox 62.

Add the pref

general.config.sandbox_enabled and set it to false in autoconfig.js

What are you using Components.classes for?

This is because autoconfig is sandboxed by default on Firefox 62. Add the pref general.config.sandbox_enabled and set it to false in autoconfig.js What are you using Components.classes for?
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 157991 answers

If you do not need that JavaScript code then simply remove this code or use a try/catch block.

The autoconfig.cfg file is run as privileged JavaScript code and an error in the file throws an exception.

If you do not need that JavaScript code then simply remove this code or use a try/catch block. The autoconfig.cfg file is run as privileged JavaScript code and an error in the file throws an exception.

Question owner

mkaply said

This is because autoconfig is sandboxed by default on Firefox 62. Add the pref general.config.sandbox_enabled and set it to false in autoconfig.js What are you using Components.classes for?

Hi and thanks! Yes, I read out about sandbox’ing and tried also pref You mentioned, but … probably couldn’t set it work properly. Anyway, I used “Components.classes["@mozilla.org/toolkit/crash-reporter;1"].getService(Components.interfaces.nsICrashReporter).submitReports = false;”, from old time. No more “components” involved. More thanks, Alar.

''mkaply [[#answer-1158845|said]]'' <blockquote> This is because autoconfig is sandboxed by default on Firefox 62. Add the pref general.config.sandbox_enabled and set it to false in autoconfig.js What are you using Components.classes for? </blockquote> Hi and thanks! Yes, I read out about sandbox’ing and tried also pref You mentioned, but … probably couldn’t set it work properly. Anyway, I used “Components.classes["@mozilla.org/toolkit/crash-reporter;1"].getService(Components.interfaces.nsICrashReporter).submitReports = false;”, from old time. No more “components” involved. More thanks, Alar.

Question owner

cor-el said

If you do not need that JavaScript code then simply remove this code or use a try/catch block. The autoconfig.cfg file is run as privileged JavaScript code and an error in the file throws an exception.

Hi and thank You! Yes, as soon I find it (~ code) out and wasn’t able to get it work by using other means I commented it out, not so important to have it there, I think. More thanks, Alar.

''cor-el [[#answer-1159053|said]]'' <blockquote> If you do not need that JavaScript code then simply remove this code or use a try/catch block. The autoconfig.cfg file is run as privileged JavaScript code and an error in the file throws an exception. </blockquote> Hi and thank You! Yes, as soon I find it (~ code) out and wasn’t able to get it work by using other means I commented it out, not so important to have it there, I think. More thanks, Alar.