X
Tap here to go to the mobile version of the site.

Support Forum

Firefox slow ONLY with facebook, 1 or 2 tabs. Others fine w/30+ tabs.

Posted

After scrolling only down a couple-three posts, fb slows to a crawl, memory spikes in all processes. On other pages, able to fill the screen with open tabs and all work fine. Have disabled add ons (adblocker, firegestures, and FB Purity) but problem persists.

After scrolling only down a couple-three posts, fb slows to a crawl, memory spikes in all processes. On other pages, able to fill the screen with open tabs and all work fine. Have disabled add ons (adblocker, firegestures, and FB Purity) but problem persists.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

Shadow110 1072 solutions 14836 answers

Separate Security Issue, please update your Flash 28.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Hi, please give this a try since your browser is out of date : Move to the Extended Release Version as per below or a Clean Reinstall of Release Version :

uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

To be Checked and turned off unless needed for accessibility : Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Multi-Processor Support : Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on.

Only Disable as last resort.

Multi-processor Can completely disable it this way in about:config : dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false

Only move to esr if low ram and old system.

Firefox Extended Release Version : Firefox ESR does not come with the latest features but it has the latest security and stability fixes.

If do please :

Please let us know if this solved your issue or if need further assistance.

''Separate'' Security Issue, please update your Flash 28.0 r0 by removing it with this tool : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html If you use it Reinstall with Flash Player Version: 30.0.0.154 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> Hi, please give this a try since your browser is out of date : Move to the Extended Release Version as per below or a Clean Reinstall of Release Version : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ '''''To be Checked and turned off unless needed for accessibility : ''''' Please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser. '''''Multi-Processor Support : ''''' Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. Note : Hardware Acceleration is for Video Card, Monitor to see if remain off or to turn back on. Only Disable as last resort. '''''Multi-processor Can completely disable it this way in about:config :''''' dom.ipc.processCount set to 1 browser.tabs.remote.autostart = false browser.tabs.remote.autostart.2 = false *http://kb.mozillazine.org/About:config Only move to esr if low ram and old system. '''''Firefox Extended Release Version :''''' Firefox ESR does not come with the latest features but it has the latest security and stability fixes. *https://support.mozilla.org/en-US/kb/switch-to-firefox-extended-support-release-esr If do please : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Please let us know if this solved your issue or if need further assistance.
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159841 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite database (bookmarks and history) in the Firefox profile folder.

  • use "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page
    in case errors are reported close and restart Firefox and retry

See also:

If "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems ---- If you use Sync then best is to disconnect Sync temporarily during troubleshooting. You can check for problems with the <b>places.sqlite</b> database (bookmarks and history) in the Firefox profile folder. *use "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page<br>in case errors are reported close and restart Firefox and retry See also: *http://kb.mozillazine.org/Locked_or_damaged_places.sqlite *https://support.mozilla.org/en-US/kb/Bookmarks+not+saved#w_fix-the-bookmarks-file If "Verify Integrity" on the "Help -> Troubleshooting Information" (about:support) page cannot repair places.sqlite then remove all places.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder. *keep a backup copy of places.sqlite in case a new places.sqlite database has to be created *http://kb.mozillazine.org/Unable_to_process_the_backup_file_-_Firefox You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox

Question owner

Been futzing online since my first Blue Wave Mail Reader and BBs, and with the internet (via the local Navy base, typing IPs) before the browsers came out (bought my first Netscape CD) and have been able to solve just about every problem I (and most everyone else around me) have had but this one was a bummer.

Having researched the problem, I finally came here. The only item that has worked is removing Adobe's flash.

Currently have 11 tabs on FB, two other windows (here) and on a news channel (also a tab with youtube) and everything is running fine.

Having disliked Adobe's products for decades (their reader bit me back in '81), this was the final item still used.

Used.. as in "not any ******** more.

Thanks for the removal utility. Adobe? Nevah!

Been futzing online since my first Blue Wave Mail Reader and BBs, and with the internet (via the local Navy base, typing IPs) before the browsers came out (bought my first Netscape CD) and have been able to solve just about every problem I (and most everyone else around me) have had but this one was a bummer. Having researched the problem, I finally came here. The only item that has worked is removing Adobe's flash. Currently have 11 tabs on FB, two other windows (here) and on a news channel (also a tab with youtube) and everything is running fine. Having disliked Adobe's products for decades (their reader bit me back in '81), this was the final item still used. Used.. as in "not any ******** more. Thanks for the removal utility. Adobe? Nevah!
cor-el
  • Top 10 Contributor
  • Moderator
17670 solutions 159841 answers

Note that you can set plugins to "Ask to Activate" on the about:addons page ("3-bar" menu button or Tools -> Add-ons -> Plugins)

You will find a Lego block icon at the left end of the location bar indicating that the web page uses a plugin (Flash) that Firefox might block. You can click this Lego block icon to allow or block this plugin.

Note that you can set plugins to "Ask to Activate" on the about:addons page ("3-bar" menu button or Tools -> Add-ons -> Plugins) You will find a Lego block icon at the left end of the location bar indicating that the web page uses a plugin (Flash) that Firefox might block. You can click this Lego block icon to allow or block this plugin. *https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins