Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is firefox refusing to load any images on webpages properly?

  • 5 replies
  • 1 has this problem
  • 10315 views
  • Last reply by Crudey

more options

Firefox will not load pages properly such as, the homepage, youtube, soundcloud, spotify, etc. I have tried other solutions, but literally nothing works so far. I have no clue what is going on, this new firefox seems to have broken the browser. I have some images below.

Alright it won't let me upload the images properly so here's a imgur link: https://imgur.com/a/0uXQ2Lw

Chosen solution

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

  • click the shield icon for more detail and possibly disable the protection
  • You can check the Web Console by Tracking Protection
  • "3-bar" menu button or Tools -> Web Developer
Read this answer in context 👍 0

All Replies (5)

more options

HI, please try a Clean install : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

more options

Chosen Solution

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.

  • click the shield icon for more detail and possibly disable the protection
  • You can check the Web Console by Tracking Protection
  • "3-bar" menu button or Tools -> Web Developer
more options

Pkshadow said

HI, please try a Clean install : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 61.0.2 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

This did not do a single thing.

more options

cor-el said

You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems:
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data
"Clear the Cache":
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.
  • click the shield icon for more detail and possibly disable the protection
  • You can check the Web Console by Tracking Protection
  • "3-bar" menu button or Tools -> Web Developer

This is a brand new installation of firefox, I've got no extensions or themes. Nor do I have any cache or web data, as I've cleared that already. The images show up for a split second when I reload the webpage but then they are gone. Hardware acceleration on/off doesn't do anything either.

more options

Crudey said

cor-el said
You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Remove the Cookies" from websites that cause problems:
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data
"Clear the Cache":
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Firefox shows the shield icon at the left end of the location/address bar in case content is blocked by Tracking Protection.
  • click the shield icon for more detail and possibly disable the protection
  • You can check the Web Console by Tracking Protection
  • "3-bar" menu button or Tools -> Web Developer

This is a brand new installation of firefox, I've got no extensions or themes. Nor do I have any cache or web data, as I've cleared that already. The images show up for a split second when I reload the webpage but then they are gone. Hardware acceleration on/off doesn't do anything either.

Scratch that. Hardware acceleration was just resetting, and I've managed to turn it off and it's working now. Thanks everyone.