Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Financial site's Payment tab tells me that Cookies are blocked.

  • 4 replies
  • 1 has this problem
  • 25 views
  • Last reply by nodos

more options

The financial website I use to pay my bills online has been giving me a message the last 4 - 6 weeks that my browser, Firefox 61.0.1, has 'Cookies are blocked'. I can view everything else on the (secure) site fine without any issue except this screen. I have gone into the Privacy and Security section of the browser's Options and verified the Cookies portion matches everything you list in your Help Guide when I search for this issue.

This website has 4 tabs for the various services and 1 of them is listed as 'Payments'. Nested under this particular tab is Bill Payments with (clickable) options of Pay your bills and PopMoney. When I click the Pay your bills link I get a screen that says -

       Cookies are blocked.  Cookies are blocked. We noticed your browser doesn’t allow cookies. To access Bill Pay, you must change    your browser settings.  After you complete your changes, close your browser, reopen it, and sign in again.

I assume the credit union must have changed something on their site since I never had this error before. I have had to fall back to using IE 11 when I need to access this option on their site.

Chosen solution

Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History)?

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Read this answer in context 👍 0

All Replies (4)

more options

Tracking Protection being enabled may cause that type of mistaken message. https://support.mozilla.org/en-US/kb/tracking-protection

You could try disabling protection for that website and see if that message doesn't appear. https://support.mozilla.org/en-US/kb/tracking-protection#w_turn-off-tracking-protection-for-individual-sites

more options

I tried changing the option to Never in the Privacy and Security section since the shield icon reports there are no trackers on the individual website. Unfortunately that didn't fix the issue.

more options

Chosen Solution

Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History)?

  • Options/Preferences -> Privacy & Security
    Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Safe Mode let that particular window open. I had tried disabling/pausing the extensions I thought might be causing the issue, but obviously didn't pick the right one, or the combination of ones that were the root of the problem. Thanks for the help and at least a temporary fix until I stumble upon the extension(s) causing it.