Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube videos can't go fullscreen

  • 4 replies
  • 2 have this problem
  • 6510 views
  • Last reply by ArgulKit

more options

But it can in other browsers. Also other video platform such as full30 works just fine. The biggest killing blow for me that if I put video id into this line https://www.youtube.com/embed/(video ID)?wmode=direct&hd=1 it can go into fullscreen like it could the day before. Whats going on? :( I updated my video driver, I updated flash player (after uninstalling it). And everything was just fine last night.

Chosen solution

Hey, I'm gonna mark cor-el respond as helpful but here is the thing. I came back home, having a dinner, watching a video not in the fullscreen mode (because it didn't work before I started my dinner). So I'm having a tendency to have like 2-5 videos in a row ready so I can enjoy them while enjoying my food and guess what. After like 15 min I'm sitting, watching video in a fullscreen and thinking: "WAIT! But it didn't work when I came back home!!! WHAT THE?!?!?!" Well, it's fixed now. But I guess clearing all cookies and cache might helped me. Because I actually already tried yesterday clearing cookies or cache (I don't remember, but I did clear only one of them) and it didn't helped me.

Read this answer in context 👍 1

All Replies (4)

more options

Hi, it could be because of your VPN and your Proxy, to test please : Try Firefox Safe Mode to TEST & see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Hey, thanks for responding. I forgot to mention that I already tried the safe mode. But I tried it again. And again, it's working on other platforms. And it's working if using that embed option. Something just isn't right with my Firefox after last lunch. I have no clue what, because last time I didn't install any add-ons or plugins. I also wonder if it's possible to reinstall firefox with saving my tabs (I'm having over 100 of them and I really need them, well, most of them). There used to be an add-on, like the session manager so I could be sure that my session is saved, now I don't know if it's possible. But troubleshooting that problem would be the best option. I just don't know where to start. I'll leave to the next day. I hope it will go away just like a nightmare. :c

more options

This issue can be caused by corrupted cookies or cookies that are blocked.

  • check the permissions for the domain in the currently selected tab in "Tools -> Page Info -> Permissions"

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" from websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear
more options

Chosen Solution

Hey, I'm gonna mark cor-el respond as helpful but here is the thing. I came back home, having a dinner, watching a video not in the fullscreen mode (because it didn't work before I started my dinner). So I'm having a tendency to have like 2-5 videos in a row ready so I can enjoy them while enjoying my food and guess what. After like 15 min I'm sitting, watching video in a fullscreen and thinking: "WAIT! But it didn't work when I came back home!!! WHAT THE?!?!?!" Well, it's fixed now. But I guess clearing all cookies and cache might helped me. Because I actually already tried yesterday clearing cookies or cache (I don't remember, but I did clear only one of them) and it didn't helped me.