Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

No prompt to save login details on one site - all others work as expected

  • 7 replies
  • 1 has this problem
  • Last reply by cor-el

more options

The prompt to save login details does not display when submitting the login form on the following site - please try it yourself:

All other sites that I've used work as expected. What part of the site is preventing this option?

Things I have tried/checked: Everything on here:, but to summarise: "Ask to save logins and passwords for websites" checked; No sites in [Exceptions...]; Normal browsing, not private; No other password managers.

Changing the password field's autocomplete option from off to on using the built-in Developer Tools Inspector. I have also tried the site on another PC with a fresh install of Windows 10 and Firefox Quantum 62 and it does the same.

One hacky way I've managed to save it in the past was manually adding it to my profile's login.json file, but there should be an easier way than this. I also don't think this method syncs correctly when using the inbuilt Firefox Sycn.

Modified by matt.baker

All Replies (7)

more options

HI, you mention a hacky way you have done before. I would think this means there is something in source code of the page that prevents browsers from saving the password and username.

Personally I have sites that will save the password and not the username and then the opposite as well. Also some sites that refuse also.

Running a Beta also maybe the issue. Since no information was supplied when you asked the question regarding your Extensions You can  : Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".


If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

Thanks for the reply.

I've tried it in Safe Mode, but with the same result unfortunately.

I have tried this on another PC using the mainstream release as well. From at least V57 onwards I think.

I have created a temporary account for test purposes: Details removed

Do you experience the same results if you login using the following link:

Do you have any ideas which part of the page is preventing it so that I can manually override on my machine?

What elements does Firefox use to determine if the save login dialog should not be displayed?


Modified by matt.baker

more options

Hi, please edit out your Temp info from the Right Side of question, Edit Unfortunately need to be in the UK, As Volunteer Support is from around the world and on at their own time there is no way to check that.

What happens when you use Internet Explorer or Edge ?

more options

Details removed as requested.

I tried it in Edge and it immediately asked if I would like to save the details. The same with IE.

Modified by matt.baker

more options

Hi Ya, as this is a open forum did not want those hanging around for to long.

Try and find your Cookies for that site and delete them :

Just to make sure clear the cache while you are there also so it does not pull up a remembered version of the site.

Now with luck it will ask you.

Now the other way of getting this done is allow it in Edge or in IE to remember the details of the login and save it.

Then Copy/Paste about:preferences#privacy to the Firefox Address Bar and Enter Right at the top is Forms & Passwords. Click on Saved Logins then Import which will ask you Edge or IE. As have never done that I do not know what follows. Save I would guess.

A hassle for sure.

Please let us know if this solved your issue or if need further assistance.

more options

Unfortunately that's already been tested with another PC and a fresh (formatted no restore) install of Windows.

I have tried it anyway, by doing a clear everything, but it's still the same :/

I'd like to find the root cause rather than bodging round it ideally. Is there any documentation on what Firefox checks for to prevent the pop-up from showing. I've read that certain bank sites indicate that login details should not be saved/autocompleted.

Or would it be a case of trawling through the source code?

Thanks for the suggestions

Modified by matt.baker

more options

Firefox does offer to store username and password on this page where I'm redirected to: