X
Tap here to go to the mobile version of the site.

Support Forum

FF won't show search history from Addresbar (except in Safe Mode.) Help.

Posted

(Desktop version of FF v60.0.2.)

I used to be able to type a keyword in the address bar and a drop-down list of results from both my bookmarks and browsing history would appear, but no longer. Now, when I try typing in the Address bar, it simply uses auto-complete to guess the URL. No more "drop down" list of suggestions (which was helpful in finding sites I visited by simply typing a keyword.)

I checked my Settings. I've tried checking/unchecking all settings under "Provide search suggestions" on the Search Settings page. Ditto for the options below "Address Bar" on the "Privacy & Security" page.

I discovered if I run FF in its own "Safe Mode", the feature returns, so I tried manually disabling every Extension & Plug-in, but it didn't help.

Can anyone tell me why I can't display link suggestions from my History via the Address bar anymore, and how to get it back? Other than Add-Ons, what else does "safe mode" disable that could be causing this? It used to work fine once upon a time. :(

(Desktop version of FF v60.0.2.) I used to be able to type a keyword in the address bar and a drop-down list of results from both my bookmarks and browsing history would appear, but no longer. Now, when I try typing in the Address bar, it simply uses auto-complete to guess the URL. No more "drop down" list of suggestions (which was helpful in finding sites I visited by simply typing a keyword.) I checked my Settings. I've tried checking/unchecking all settings under "Provide search suggestions" on the Search Settings page. Ditto for the options below "Address Bar" on the "Privacy & Security" page. I discovered if I run FF in its own "Safe Mode", the feature returns, so I tried manually disabling every Extension & Plug-in, but it didn't help. Can anyone tell me why I can't display link suggestions from my History via the Address bar anymore, and how to get it back? Other than Add-Ons, what else does "safe mode" disable that could be causing this? It used to work fine once upon a time. :(
Attached screenshots

Chosen solution

A couple other changes made by Firefox's Safe Mode:

(1) Disabling hardware acceleration of graphics

This doesn't sound like the most likely problem, but you can change this setting in regular mode as well. Please see the steps in this article: Firefox's performance settings.

(2) Disabling userChrome.css and userContent.css customization files

If you have created or installed a userChrome.css file that modifies the address bar in any way, it would be worth checking this. The file would be in your profile folder, in a chrome subfolder.

You can open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Look for a folder named chrome and if you have such a folder (Firefox doesn't create it on its own), double-click into that.

If you have a file named userChrome.css then you may need to review its content to see whether any might affect the address bar.

Note: by default, Windows hides the .css file extension. To set Windows to show all file extensions, see: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0

More Information

Pkshadow
  • Top 10 Contributor
920 solutions 12057 answers

Separate Security Issue, please update your Flash 27.0 r0 Flash Player Version: 30.0.0.113 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

HI, please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

Separate Security Issue, please update your Flash 27.0 r0 Flash Player Version: 30.0.0.113 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> HI, please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.
Was this helpful to you? 0
Quote

Question owner

Pkshadow said

Separate Security Issue, please update your Flash 27.0 r0 Flash Player Version: 30.0.0.113 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> HI, please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer Please let us know if this solved your issue or if need further assistance.

Thanks for the reply, but uninstalling an otherwise perfectly working copy of FF just to fix this issue seems like massive overkill. If I backup my History, passwords/cookies, Bookmarks, then reinstall & reconfigure every AddOn/Plugin only to end up with the same result, I would NOT be a Happy Camper.

The fact the features returns when in safe mode suggests there is a something else being enabled/disabled that I'm missing.

PS: I'm assuming the note about "updating Flash" was not specific to my problem? I have the latest version installed.

''Pkshadow [[#answer-1121267|said]]'' <blockquote> Separate Security Issue, please update your Flash 27.0 r0 Flash Player Version: 30.0.0.113 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only> HI, please try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance. </blockquote> Thanks for the reply, but uninstalling an otherwise perfectly working copy of FF just to fix this issue seems like massive overkill. If I backup my History, passwords/cookies, Bookmarks, then reinstall & reconfigure every AddOn/Plugin only to end up with the same result, I would NOT be a Happy Camper. The fact the features returns when in safe mode suggests there is a something else being enabled/disabled that I'm missing. PS: I'm assuming the note about "updating Flash" was not specific to my problem? I have the latest version installed.
Was this helpful to you?
Quote

Question owner

I went ahead and tried uninstalling and reinstalling Firefox. The problem was not fixed.

I use the Sync feature, so I don't know if it just carried the problem over from before. I can't figure out what is behind the bug or how to fix it. :(

I went ahead and tried uninstalling and reinstalling Firefox. The problem was not fixed. I use the Sync feature, so I don't know if it just carried the problem over from before. I can't figure out what is behind the bug or how to fix it. :(
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Chosen Solution

A couple other changes made by Firefox's Safe Mode:

(1) Disabling hardware acceleration of graphics

This doesn't sound like the most likely problem, but you can change this setting in regular mode as well. Please see the steps in this article: Firefox's performance settings.

(2) Disabling userChrome.css and userContent.css customization files

If you have created or installed a userChrome.css file that modifies the address bar in any way, it would be worth checking this. The file would be in your profile folder, in a chrome subfolder.

You can open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Look for a folder named chrome and if you have such a folder (Firefox doesn't create it on its own), double-click into that.

If you have a file named userChrome.css then you may need to review its content to see whether any might affect the address bar.

Note: by default, Windows hides the .css file extension. To set Windows to show all file extensions, see: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

A couple other changes made by Firefox's Safe Mode: (1) Disabling hardware acceleration of graphics This doesn't sound like the most likely problem, but you can change this setting in regular mode as well. Please see the steps in this article: [[Firefox's performance settings]]. (2) Disabling userChrome.css and userContent.css customization files If you have created or installed a userChrome.css file that modifies the address bar in any way, it would be worth checking this. The file would be in your profile folder, in a chrome subfolder. You can open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows Explorer. Look for a folder named '''chrome''' and if you have such a folder (Firefox doesn't create it on its own), double-click into that. If you have a file named '''userChrome.css''' then you may need to review its content to see whether any might affect the address bar. Note: by default, Windows hides the .css file extension. To set Windows to show all file extensions, see: https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/
Was this helpful to you? 1
Quote

Question owner

jscher2000 said

A couple other changes made by Firefox's Safe Mode: (2) Disabling userChrome.css and userContent.css customization files If you have created or installed a userChrome.css file that modifies the address bar in any way, it would be worth checking this. The file would be in your profile folder, in a chrome subfolder.

Ah! This appears to be the cause. I don't know WHAT it is about the "userChrome.css" file causing this very odd bug, but removing it "fixed" the problem.

I had a modified "userChrome.css" to move the tabs below the Address Bar. This worked fine before v60, but apparently, no longer does. If I had to guess, having the tabs below the Address Bar was suppressing the dropdown from opening.

Thanks.

''jscher2000 [[#answer-1122394|said]]'' <blockquote> A couple other changes made by Firefox's Safe Mode: (2) Disabling userChrome.css and userContent.css customization files If you have created or installed a userChrome.css file that modifies the address bar in any way, it would be worth checking this. The file would be in your profile folder, in a chrome subfolder.</blockquote> Ah! This appears to be the cause. I don't know WHAT it is about the "userChrome.css" file causing this very odd bug, but removing it "fixed" the problem. I had a modified "userChrome.css" to move the tabs below the Address Bar. This worked fine before v60, but apparently, no longer does. If I had to guess, having the tabs below the Address Bar was suppressing the dropdown from opening. Thanks.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Hi Mugsy, what's your code to move the Tabs bar?

You can compare with the one I posted for Firefox 57 to see whether it works any better for you (I haven't heard of any new problems in Firefox 60): https://www.userchrome.org/what-is-userchrome-css.html#movetabbar

Hi Mugsy, what's your code to move the Tabs bar? You can compare with the one I posted for Firefox 57 to see whether it works any better for you (I haven't heard of any new problems in Firefox 60): https://www.userchrome.org/what-is-userchrome-css.html#movetabbar
Was this helpful to you?
Quote

Question owner

Hmm, I can't seem to spot the differences to my css files.

I uploaded my old CSS files here if you'd like to examine them. The script came from (IIRC) a link on how to do this in v57 (tab customization at bottom of "userChrome.css".)

I'll try the css you linked to (but I must post this before closing/reopening the browser.)

Okay, back. I must have put the "userChrome.css" in the wrong place (same folder as the exe) because it had no effect.

Hmm, I can't seem to spot the differences to my css files. I uploaded my old CSS files [https://mega.nz/#!zMUmkAJC!kq3iAPdlS8M2oCRt6Cd5g8vkp7nwo2xKg3U-pcm05RA here] if you'd like to examine them. The script came from (IIRC) a link on how to do this in v57 (tab customization at bottom of "userChrome.css".) I'll try the css you linked to (but I must post this before closing/reopening the browser.) Okay, back. I must have put the "userChrome.css" in the wrong place (same folder as the exe) because it had no effect.

Modified by Mugsy

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Are other changes made by the Classic Theme Restorer code important? If so, you may want to update from version 1.3.0 to version 1.9.1.

https://github.com/Aris-t2/CustomCSSforFx

I believe that involves downloading all the corresponding files linked into that userChrome.css file, but I haven't tried it myself.

Then if you search in the userChrome.css file for TABS BELOW NAVIGATION you can find the line you need to "un-comment" to move the tab bar. This probably is safer than mixing and matching code from different sources. (See attached screenshot.)

Hopefully using the updated code will resolve the address bar drop-down issue.

Are other changes made by the Classic Theme Restorer code important? If so, you may want to update from version 1.3.0 to version 1.9.1. https://github.com/Aris-t2/CustomCSSforFx I believe that involves downloading all the corresponding files linked into that userChrome.css file, but I haven't tried it myself. Then if you search in the userChrome.css file for TABS BELOW NAVIGATION you can find the line you need to "un-comment" to move the tab bar. This probably is safer than mixing and matching code from different sources. (See attached screenshot.) Hopefully using the updated code will resolve the address bar drop-down issue.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Mugsy said

Okay, back. I must have put the "userChrome.css" in the wrong place (same folder as the exe) because it had no effect.

Which exe? userChrome.css goes into a chrome folder in your profile. More info: https://www.userchrome.org/how-create-userchrome-css.html

''Mugsy [[#answer-1122568|said]]'' <blockquote> Okay, back. I must have put the "userChrome.css" in the wrong place (same folder as the exe) because it had no effect. </blockquote> Which exe? userChrome.css goes into a chrome folder in your profile. More info: https://www.userchrome.org/how-create-userchrome-css.html
Was this helpful to you?
Quote

Question owner

jscher2000 said

Mugsy said Which exe? userChrome.css goes into a chrome folder in your profile. More info: https://www.userchrome.org/how-create-userchrome-css.html

The browser ("firefox.exe").

I'll try editing the css again with this new install. My old userChrome.css did uncomment the setting below the "TABS BELOW NAVIGATION" section.

Follow-up: The new userChrome.css already has the command uncommented (and the recommended code above added to the bottom), yet my tabs are still on top.

''jscher2000 [[#answer-1122672|said]]'' <blockquote> ''Mugsy [[#answer-1122568|said]]'' Which exe? userChrome.css goes into a chrome folder in your profile. More info: https://www.userchrome.org/how-create-userchrome-css.html </blockquote> The browser ("firefox.exe"). I'll try editing the css again with this new install. My old userChrome.css did uncomment the setting below the "TABS BELOW NAVIGATION" section. ''Follow-up: '' The new userChrome.css already has the command uncommented (and the recommended code above added to the bottom), yet my tabs are still on top.

Modified by Mugsy

Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

The "classic" CSS file makes a lot of changes. I have attached a screenshot showing what happens when I install the files into a "clean" profile. If you don't see any changes, the file set might be incomplete or in the wrong folder.

Could you try the method I describe on my website:

(A) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have voiceover videos for both Windows and Mac, on that same page.

If you already have this folder, skip to (B).

(B) Set your OS to show file extensions

See Step #4 in the above article.

(C) Download the following file and move it into your new chrome folder

https://www.userchrome.org/samples/userChrome-tabs_on_bottom.css

(D) Rename the file to just userChrome.css

If you already have a userChrome.css file in this folder, right-click > rename it to OLDuserChrome.css temporarily.

Windows: You can right-click the file, then Rename, then remove the -tabs_on_bottom part from the file name so you end up with exactly userChrome.css and then click away to complete the edit.

Mac: To make the name of a file editable, you can select the file in Finder and press Return, or you can "force-click" it if you have one of the new touchpads. Remove the -tabs_on_bottom part from the file name so you end up with exactly userChrome.css and then click away to complete the edit.

The next time you quit Firefox and start it up again, it should discover that file and apply the rules.

Success?

The "classic" CSS file makes a lot of changes. I have attached a screenshot showing what happens when I install the files into a "clean" profile. If you don't see any changes, the file set might be incomplete or in the wrong folder. Could you try the method I describe on my website: '''(A) Create a new '''chrome''' folder in your profile folder''' The following article has the detailed steps for that (#1, #2, and I recommend #3) https://www.userchrome.org/how-create-userchrome-css.html ''I have voiceover videos for both Windows and Mac, on that same page.'' ''If you already have this folder, skip to (B).'' '''(B) Set your OS to show file extensions''' See Step #4 in the above article. '''(C) Download the following file and move it into your new chrome folder''' https://www.userchrome.org/samples/userChrome-tabs_on_bottom.css '''(D) Rename the file to just ''userChrome.css''''' ''If you already have a userChrome.css file in this folder, right-click > rename it to OLDuserChrome.css temporarily.'' ''Windows:'' You can right-click the file, then Rename, then remove the <code>-tabs_on_bottom</code> part from the file name so you end up with exactly userChrome.css and then click away to complete the edit. ''Mac:'' To make the name of a file editable, you can select the file in Finder and press Return, or you can "force-click" it if you have one of the new touchpads. Remove the <code>-tabs_on_bottom</code> part from the file name so you end up with exactly userChrome.css and then click away to complete the edit. The next time you quit Firefox and start it up again, it should discover that file and apply the rules. Success?
Was this helpful to you? 0
Quote

Question owner

I opened "about:support" to display my Profiles folder. It contains a folder named: "g0koqjno.default-1490129471087-1528932382718".

I created a new folder named "chrome" and saved the css file to it.

I then closed and reopened FF. No change. Tabs still on top.

I tried moving the css file to the oddly named profile folder and deleting the now empty "chrome" folder. Close/reopen. No change.

This FF v60.0.2 64-bit.

I opened "about:support" to display my Profiles folder. It contains a folder named: "g0koqjno.default-1490129471087-1528932382718". I created a new folder named "chrome" and saved the css file to it. I then closed and reopened FF. No change. Tabs still on top. I tried moving the css file to the oddly named profile folder and deleting the now empty "chrome" folder. Close/reopen. No change. This FF v60.0.2 64-bit.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Hi Mugsy, you need to have userChrome.css with precisely the right name (step D) in precisely the right folder (steps A-C).

Your long profile folder name may have resulted from having use the Refresh feature twice. I've never seen that before and I don't know if there is a folder name length that could cause problems reading files.

Hi Mugsy, you need to have '''userChrome.css''' with precisely the right name (step D) in precisely the right folder (steps A-C). Your long profile folder name may have resulted from having use the Refresh feature twice. I've never seen that before and I don't know if there is a folder name length that could cause problems reading files.
Was this helpful to you? 0
Quote

Question owner

Thanks for the reply.

The obscure profile folder name is not unusual (to me at least) as I have seen Firefox generate cryptic Profile Folder names as far back as I can remember. And renaming the folder to something less cryptic would break the connection such that FF would no longer be able to find it.

I did not try renaming my working Profile folder to "chrome". Unless the css references the profile folder by name, it wouldn't make a difference.

The folder FF generates is the folder I am taken to from the "about:support" page. Creating a second profile folder named "chrome" and placing the css file inside did not work.

The css file was renamed properly to "userChrome.css" as noted and placed unedited in said folder.

I followed all steps (I already had "Show extensions" on). The script just is not being read.

Thanks for the reply. The obscure profile folder name is not unusual (to me at least) as I have seen Firefox generate cryptic Profile Folder names as far back as I can remember. And renaming the folder to something less cryptic would break the connection such that FF would no longer be able to find it. I did not try renaming my working Profile folder to "chrome". Unless the css references the profile folder by name, it wouldn't make a difference. The folder FF generates is the folder I am taken to from the "about:support" page. Creating a second profile folder named "chrome" and placing the css file inside did not work. The css file was renamed properly to "userChrome.css" as noted and placed unedited in said folder. I followed all steps (I already had "Show extensions" on). The script just is not being read.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Helpful Reply

Hi Mugsy, I definitely do not recommend renaming any Firefox folders and I apologize if you read my comments to suggest that. To be clear: do not rename any folders created by Firefox (unless you want to hide them from Firefox).

The chrome subfolder needs to be inside your currently active profile folder, and the userChrome.css file inside that folder, both with that exact spelling:

C:\Users\username\AppData\Roaming\Mozilla\Firefox\Profiles\g0koqjno.default-1490129471087-1528932382718\chrome\userChrome.css

Firefox should always load and apply [profile]\chrome\userChrome.css unless it is starting up in its "Safe Mode" (in which case the file is intentionally ignored). I am not aware of any other reason the file would be ignored.

Hi Mugsy, I definitely do not recommend renaming any Firefox folders and I apologize if you read my comments to suggest that. To be clear: do not rename any folders created by Firefox (unless you want to hide them from Firefox). The '''chrome''' subfolder needs to be ''inside'' your currently active profile folder, and the userChrome.css file inside that folder, both with that exact spelling: C:\Users\''username''\AppData\Roaming\Mozilla\Firefox\Profiles\g0koqjno.default-1490129471087-1528932382718\chrome\userChrome.css Firefox should always load and apply [profile]\chrome\userChrome.css unless it is starting up in its "Safe Mode" (in which case the file is intentionally ignored). I am not aware of any other reason the file would be ignored.
Was this helpful to you? 1
Quote

Question owner

jscher2000 said

The chrome subfolder needs to be inside your currently active profile folder

Ah, that was it. Putting the css in a "chrome" folder inside my profile folder solved the issue.

Thx.

''jscher2000 [[#answer-1123204|said]]'' <blockquote> The '''chrome''' subfolder needs to be ''inside'' your currently active profile folder</blockquote> Ah, that was it. Putting the css in a "chrome" folder ''inside'' my profile folder solved the issue. Thx.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.