X
Tap here to go to the mobile version of the site.

Support Forum

Firefox v60 is having problem with video reproduction on YouTube, 1080p videos are stuttering/lagging

Posted

Hello, i read a lot before posting this, tryed to disable/enable all the things recommended for media playback in about:config on Firefox but i still have problem. I tryed to switch firefox to performance GPU on laptop, didnt help either. Tryed other browsers (Chrome and Edge) and video is just fine there, no stuttering. I checked these to be absolutely sure my hardware is not the problem. I tried SAFE mode but again stuttering on 1080p videos. I have installed h264, adobe flash, and widevine content decryption.... Tried clean install, newest adobe flash, windows 10 update... Tryed to disable hardware acceleration also. Cant remember all the things i tried :).

I really like Firefox, using it for years, i dont wanna switch to any other browser, i hope developers will look into the problem. Its quite frequent as i can see online...

Hello, i read a lot before posting this, tryed to disable/enable all the things recommended for media playback in about:config on Firefox but i still have problem. I tryed to switch firefox to performance GPU on laptop, didnt help either. Tryed other browsers (Chrome and Edge) and video is just fine there, no stuttering. I checked these to be absolutely sure my hardware is not the problem. I tried SAFE mode but again stuttering on 1080p videos. I have installed h264, adobe flash, and widevine content decryption.... Tried clean install, newest adobe flash, windows 10 update... Tryed to disable hardware acceleration also. Cant remember all the things i tried :). I really like Firefox, using it for years, i dont wanna switch to any other browser, i hope developers will look into the problem. Its quite frequent as i can see online...

Additional System Details

Installed Plug-ins

  • Shockwave Flash 29.0 r0

Application

  • Firefox 60.0.1
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
  • Support URL: https://support.mozilla.org/1/firefox/60.0.1/WINNT/en-US/

Extensions

  • AdBlock 3.14.0 (jid1-NIfFY2CA8fy1tg@jetpack)
  • Google Translator for Firefox 3.0.3.1 (translator@zoli.bod)
  • Adblock Plus 3.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Inactive)
  • Greasemonkey 4.4.0 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • Notifier for Gmail™ 0.9.3 (jid0-GjwrPchS3Ugt7xydvqVK4DQk8Ls@jetpack) (Inactive)
  • Video DownloadHelper 7.3.0 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d}) (Inactive)
  • X-notifier (for Gmail™,Hotmail,Yahoo,AOL...) 4.2.2 ({37fa1426-b82d-11db-8314-0800200c9a66}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0046
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 143a103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'blockedMismatchedVersion']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.17134.1
  • driverDate: 5-30-2016
  • driverDate2:
  • driverVersion: 9.15.10.2900
  • driverVersion2:
  • failures: [u'CP+[GFX1-]: Mismatched driver versions between the registry 9.15.10.2900 and DLL(s) 8.15.10.2900, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 9.15.10.2900 and DLL(s) 8.15.10.2900, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 9.15.10.2900 and DLL(s) 8.15.10.2900, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 9.15.10.2900 and DLL(s) 8.15.10.2900, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 9.15.10.2900 and DLL(s) 8.15.10.2900, reported.', u'CP+[GFX1-]: Mismatched driver versions between the registry 9.15.10.2900 and DLL(s) 8.15.10.2900, reported.']
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'blacklisted', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_', u'type': u'env'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blacklisted', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blacklisted', u'message': u'#BLOCKLIST_', u'type': u'env'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'available', u'description': u'Off Main Thread Painting', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'OMTP'}]}
  • indices: [0, 1, 2, 3, 4, 5]
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'blockedMismatchedVersion']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: True
  • offMainThreadPaintWorkerCount: 0
  • usesTiling: False
  • webgl1DriverExtensions: GL_ANGLE_client_arrays GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_program_cache_control GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_color_buffer_float_rgb GL_CHROMIUM_color_buffer_float_rgba GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc_srgb GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_surfaceless_context GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_sRGB EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_compressed_texture_s3tc_srgb WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context
  • webgl1Renderer: Google Inc. -- ANGLE (Microsoft Basic Render Driver Direct3D11 vs_5_0 ps_5_0)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.7edc21933ef1)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 000000000000f6b3) EGL_VERSION: 1.4 (ANGLE 2.1.0.7edc21933ef1) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_CHROMIUM_sync_control EGL_EXT_pixel_format_float EGL_KHR_surfaceless_context EGL_ANGLE_display_texture_share_group EGL_ANGLE_create_context_client_arrays EGL_ANGLE_program_cache_control EGL_ANGLE_robust_resource_initialization EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL creation failed: * Refused to create WebGL2 context because of blacklist entry:
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No

Question owner

Ok i now found out about different codecs. There must be problem.

Does anyone know how to force Firefox to use avc 1.6 codec?

Ok i now found out about different codecs. There must be problem. Does anyone know how to force Firefox to use avc 1.6 codec?
WestEnd 60 solutions 5387 answers

Link is needed so other can verify the problem your having to see what is happening.

Link is needed so other can verify the problem your having to see what is happening.

Question owner

Link of what? Video?

https://www.youtube.com/watch?v=YM1hGgyqR1c&t=410s

I tried to force that codec i posted before with some add-ons, it worked but video is still stuttering...

Link of what? Video? https://www.youtube.com/watch?v=YM1hGgyqR1c&t=410s I tried to force that codec i posted before with some add-ons, it worked but video is still stuttering...

Question owner

I tested on other computer, win 7 also, there firefox uses avc 1.6 and playback is smooth. I couldnt find way to force avc 1.6/opus 251...

i could set it to avc 1.6/ h264 something but still stuterring is going on

I would say its hardware but on edge its completely smooth playback...

Please anyone with idea of how to force that codec combination

I tested on other computer, win 7 also, there firefox uses avc 1.6 and playback is smooth. I couldnt find way to force avc 1.6/opus 251... i could set it to avc 1.6/ h264 something but still stuterring is going on I would say its hardware but on edge its completely smooth playback... Please anyone with idea of how to force that codec combination
Shadow110 1072 solutions 14836 answers
Hi you could try this : https://addons.mozilla.org/en-US/firefox/addon/h264ify/ Firefox on youtube is using HTML5 or Flash *https://support.google.com/youtube/topic/3014746 *https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues *https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox *https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows As to what your Video Card is trying to use or your sound no idea.

Question owner

Thanks for answering but my problem is unfortunately not solved.

Yes I understand first codes is for video and second for audio. I also tryed that add on wich changed video codec but stutter is still present on 1080p YouTube video.

I shall use Edge as my full HD video playback, until Firefox solves this problem.

Anyway 720p is also good enough.

Thank you all for help!

Thanks for answering but my problem is unfortunately not solved. Yes I understand first codes is for video and second for audio. I also tryed that add on wich changed video codec but stutter is still present on 1080p YouTube video. I shall use Edge as my full HD video playback, until Firefox solves this problem. Anyway 720p is also good enough. Thank you all for help!
WestEnd 60 solutions 5387 answers

I went to the site and loaded without problems. The problem I see going on is you go in Safe Mode and have issues which to me tells that FF was corrupted or a bad install. Anytime you have issue with software that can run in Safe Mode something is wrong with that software and needs to be uninstalled completely and deleting the Mozilla folder and reinstalling again to fix the bad install.

I went to the site and loaded without problems. The problem I see going on is you go in Safe Mode and have issues which to me tells that FF was corrupted or a bad install. Anytime you have issue with software that can run in Safe Mode something is wrong with that software and needs to be uninstalled completely and deleting the Mozilla folder and reinstalling again to fix the bad install.

Question owner

WestEnd said

I went to the site and loaded without problems. The problem I see going on is you go in Safe Mode and have issues which to me tells that FF was corrupted or a bad install. Anytime you have issue with software that can run in Safe Mode something is wrong with that software and needs to be uninstalled completely and deleting the Mozilla folder and reinstalling again to fix the bad install.

Hello, thanks for answer, i already reinstalled Firefox, problem is not instalation. But thanks anyway. Maybe it is something with my laptop, on PC it works without problem (although without flash player installed). I will try to uninstall flash and test.

''WestEnd [[#answer-1121094|said]]'' <blockquote> I went to the site and loaded without problems. The problem I see going on is you go in Safe Mode and have issues which to me tells that FF was corrupted or a bad install. Anytime you have issue with software that can run in Safe Mode something is wrong with that software and needs to be uninstalled completely and deleting the Mozilla folder and reinstalling again to fix the bad install. </blockquote> Hello, thanks for answer, i already reinstalled Firefox, problem is not instalation. But thanks anyway. Maybe it is something with my laptop, on PC it works without problem (although without flash player installed). I will try to uninstall flash and test.
Shadow110 1072 solutions 14836 answers

Well, the issue at this time is with you and your install. I have no problems with any videos on any sites. You could try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer

So if above does not work it maybe something you have done and is saved in your Profile. Profile : Make a new one and test ...:

If is your Profile :

Please let us know if this solved your issue or if need further assistance.

Well, the issue at this time is with you and your install. I have no problems with any videos on any sites. You could try this : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 60.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ So if above does not work it maybe something you have done and is saved in your Profile. Profile : Make a new one and test ...: *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles If is your Profile : *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Please let us know if this solved your issue or if need further assistance.