Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 60 breaks fonts on all sites. I went back to 59.0.2. WTF.

  • 5 replies
  • 1 has this problem
  • 9 views
  • Last reply by jscher2000

more options

Firefox 60 turned fonts on all websites into boxes with questionmarks within the boxes. I went back to 59.0.2 and it's fine. Running MacBook Pro 10.11.6.

Attached screenshots

All Replies (5)

more options

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Let me know if this helps.

What extensions do you have installed?

And also, you are using an older version of Mac OS, free to upgrade, just letting you know. Not good to be on an old operating systems.

more options

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1

more options

This can happen when Firefox has a problem to access locally installed fonts because of sandbox security issues.

You can set this pref to 2 or 1 on the about:config page to lower the sandbox security setting.

  • security.sandbox.content.level = 1
  • close and restart Firefox to make the change effective.

If '1' still doesn't have effect then try '0' to disable the sandbox.

If this didn't work then undo/reverse the change and reset the pref via the right-click context menu to the default value.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Just fix the bug. I'm not updating until you do--or I'm going to use a different browser, which sucks because I've been using Firefox for YEARS.

more options

Hi avmgraphics, do you use a third party font manager? Please provide details. The security sandbox feature cor-el mentioned restricts where on disk Firefox will retrieve content for web pages, including font files. In order to "whitelist" all the relevant locations, the developers need more information about different users' font managers.