Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is SLOW

  • 4 replies
  • 1 has this problem
  • 125 views
  • Last reply by philipp

more options

Specifically, when using Duolingo (www.duolingo.com), Firefox is not responsive when I try to type input on the keyboard ... takes forever for letters to appear on screen. It also seems slow in other operations.

We have removed Firefox and reinstalled it, but it is no better.

I love Firefox, but this performance is UNACCEPTABLE. I will seek another browser, but do not want to.

Chosen solution

Ah, Philipp, I may have solved my OWN problem: I deleted the add-on "honey" before copying the Troubleshooting summary to send to you. Now Duolingo seems to work normally.

Could the coupon add-on "Honey" have caused the problem?

Claudia

Read this answer in context 👍 0

All Replies (4)

more options

hi, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum (or if it's too long through a site like https://pastebin.mozilla.org/ and provide the link here)?

this might give us a clue what is going on. thank you!

more options

Thank you for your quick response. I tried to copy Troubleshooting. Does this work?

https://pastebin.mozilla.org/9085404

more options

Chosen Solution

Ah, Philipp, I may have solved my OWN problem: I deleted the add-on "honey" before copying the Troubleshooting summary to send to you. Now Duolingo seems to work normally.

Could the coupon add-on "Honey" have caused the problem?

Claudia

more options

ok great, yes we got a couple of similar reports from other users with the honey addon and lags after the firefox 60 update. firefox developers are currently looking into a fix for this, but keeping the extension disabled should be a godd workaround for the meantime.