Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't disable hardware acceleration nor establish a limit of subprocesses

  • 3 replies
  • 1 has this problem
  • 9 views
  • Last reply by Shadow110

more options

So, I have hardware acceleration unchecked and I have established a limit of 4 subprocesses to run with firefox. However, I have discovered that even if that's the case, firefox is usually running with 6 to 7 subprocesses under it and that hardware acceleration is still getting activated after some time of use, it shows in my task-manager that firefox is using the GPU 0 - 3D thing and that only appears with software which is using hardware acceleration.

Is this intentional from mozilla's side? Cause, Hardware acceleration causes more troubles for me instead of making the browser run more smoothly.

All Replies (3)

more options

Hi, confusing issue sometimes for all. Hardware acceleration is for your video card and should be left on unless it helps cure issues.

With multi-thread and multi-processor you are suppose to be having those sub processes as they are add-ons, tabs, sandbox, and what ever... Limiting the multi-processor : Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 maybe try higher until find the sweet spot. Restart Firefox after making these changes please.

You should not need to do the above unless low on ram or system is hanging, more processes the better as it is working as intended.

Now I am not a Nvidia person but when I see drivers being stored in the Windows Repository that lets me know that it is possible Windows 10 is replacing your drivers with it's own. This can be confirmed in Device Manager. You can also do this :

Then Uninstall your Drivers and reinstall same or updated ones if available. There are WHQL Drivers released March 2018 available. https://www.geforce.com/drivers

I can see why you are having issues with your video card NVIDIA GeForce GTX 1050 Ti : direct2DEnabled: False u,available is good. u,unavailable is bad : featureLog: {u'fallbacks': [], u'features': [{u'status': u'disabled', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'disabled', u'message': u'Disabled by pref', u'type': u'user'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}

So how about try that out before trying to solve the Hardware Acceleration issue as doing the above may just fix that problem.

Please let us know if this solved your issue or if need further assistance.

more options

Hi.

Thank you for taking time to help me. Okay, my computer was freshly reformated at the beginning of March and I hadn't noticed the driver dated from 2016, my bad on that point. I just updated the driver. I will keep checking how it works with it and the multiprocess stuff. I did notice that now my GPU is constantly working around 17 to 20 % when Firefox is running a video, when before it sat still at 0%, I suppose the GPU is doing it's work now.

I am sorry if I was a nuissance, I'm an old lady who isn't exactly very tech-savy!

more options

Hi, not a problem at all that is what we are here for is to provide solutions which it seems we have done. So ya, Windows 10 has weird things they can do. I only noticed that myself as I updated my sound card drivers and minutes after Microsoft Updated and my Sound stuff was replaced.

So glad you are again running smoothly.

If you could please Mark the Solution that Solved your Issue so Others can Find it.