Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Updated from 57 to 59, now Firefox is very slow to open, and slow to display content of new tabs.

  • 5 replies
  • 4 have this problem
  • 22 views
  • Last reply by FredMcD

more options

Things were working fine with 57, I kept putting off the notices to upgrade because I knew something would go kerflooey (and it did!) and now Firefox is:

1) very slow to start 2) once it starts and opens, it can take another 30 seconds for the homepage (google) to render 3) clicking on a new tab takes forever for the homepage to render

I tried the fix suggested in a similar post (options > privacy & security > check 'Prevent accessibility services from accessing your browser' but it didn't improve things. I've been using the New Tab Homepage 0.6.2 add-on from Ben Basson without any problems (though he notes bug 1411465 reported to Firefox) but disabling this add-on didn't improve things. Any fixes to these problems???

Also, I've heard there is still regular Firefox that is available for organizations, maybe this would be a good fix over Quantum, can you give the download link to that if it's available?

Chosen solution

Thank you for the links, FredMcD, I think that solved the problem.

I spoke too soon about the new tabs opening faster after changing the Content process limit setting. And I discovered more anomalies with Quantum as the day went on. As other users have said, I find it difficult to believe that this update was thoroughly tested before being released. In fact, I've come to dread Firefox updates, because gone are the days when you could just click on the update, then go about your business without encountering a bunch of problems.

I removed Firefox Quantum and installed Firefox ESR 52.7.3, and everything is back to working again, except for the new tab homepage extension because it's incompatible with 52. For what it's worth, I think most users want just a basic, secure browser without all the bells and whistles and unfulfilled promises of faster this, and better that. KISS!

Read this answer in context 👍 0

All Replies (5)

more options

https://support.mozilla.org/en-US/kb/update-firefox-latest-version?cache=no Did you update Firefox to the latest version 59.0.2


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Separate Security Issue: Update your Flash Player or remove it using these links; http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html Uninstall Flash Player | Windows http://helpx.adobe.com/flash-player/kb/uninstall-flash-player-mac-os.html Uninstall Flash Player | Mac

Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.113

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

more options

1) Yes, I updated Firefox this morning to 59.0.2 (64-bit). I'm Win 7.

2) I started Firefox in safe mode (several times), but no change, still very slow to start, and when the browser finally appears, the first tab is very slow to load the homepage.

3) I have Flash Version 29.0.0.113 for Windows 64-bit , English , Firefox

One improvement, new tabs are now opening faster than before after I set the Content process limit to 2, as another link suggested.

more options

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

firefoxq said

I've heard there is still regular Firefox that is available for organizations, maybe this would be a good fix over Quantum, can you give the download link to that if it's available?

Firefox; Extended Support Release {web link} ESR Notes System Requirements

more options

Chosen Solution

Thank you for the links, FredMcD, I think that solved the problem.

I spoke too soon about the new tabs opening faster after changing the Content process limit setting. And I discovered more anomalies with Quantum as the day went on. As other users have said, I find it difficult to believe that this update was thoroughly tested before being released. In fact, I've come to dread Firefox updates, because gone are the days when you could just click on the update, then go about your business without encountering a bunch of problems.

I removed Firefox Quantum and installed Firefox ESR 52.7.3, and everything is back to working again, except for the new tab homepage extension because it's incompatible with 52. For what it's worth, I think most users want just a basic, secure browser without all the bells and whistles and unfulfilled promises of faster this, and better that. KISS!

Modified by firefoxq

more options

Glad to help. Safe Surfing.

firefoxq said

everything is back to working again, except for the new tab homepage extension because it's incompatible with 52

Go to that add-ons Mozilla page. At the bottom, you will find a list of old versions.