X
Tap here to go to the mobile version of the site.

Support Forum

Windows will not allow me to update Firefox. Can you help

Posted

Every time I open Firefox I get a message that says I need to update manually because it would not update automatically. I am unable to update manually. Any suggestions?

Every time I open Firefox I get a message that says I need to update manually because it would not update automatically. I am unable to update manually. Any suggestions?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 18.11.20036
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.161.2 for Mozilla browsers
  • McAfee MSC FF plugin DLL
  • McAfee Virtual Technician plugin
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 29.0 r0
  • 5.1.50907.0
  • NPWLPG
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

More Information

FredMcD
  • Top 10 Contributor
4248 solutions 59418 answers

Why does the computer not do the update? What is the full error message?

Many have reported issues using the 64bit Firefox. Install the 32bit version from; Download Firefox For All languages And Systems {web link}

Why does the computer not do the update? What is the full error message? Many have reported issues using the 64bit Firefox. Install the 32bit version from; '''[http://www.mozilla.org/en-US/firefox/all/ Download Firefox For All languages And Systems]''' {web link}
James
  • Moderator
1596 solutions 11250 answers

Fred the OP was already using the 32-bit version of Firefox 51.0 and your comments about 64-bit version is rather vague or misleading.

Christian62, If you were to do a internal update it would be a full update file anyways so you might as well install 59.0.2 with the full offline setup from www.mozilla.org/firefox/all/

Fred the OP was already using the 32-bit version of Firefox 51.0 and your comments about 64-bit version is rather vague or misleading. Christian62, If you were to do a internal update it would be a full update file anyways so you might as well install 59.0.2 with the full offline setup from www.mozilla.org/firefox/all/
Happy112 561 solutions 5694 answers

christian62 said

Every time I open Firefox I get a message that says I need to update manually because it would not update automatically. I am unable to update manually. Any suggestions?

Hi,

Your system details show that you are running plugins - if you really need those, you will have to download the latest Firefox ESR version, which you can download (in your preferred language) from here :

https://www.mozilla.org/firefox/organizations/all/

''christian62 [[#question-1211348|said]]'' <blockquote> Every time I open Firefox I get a message that says I need to update manually because it would not update automatically. I am unable to update manually. Any suggestions? </blockquote> Hi, Your system details show that you are running plugins - if you really need those, you will have to download the latest Firefox '''ESR''' version, which you can download (in your preferred language) from here : https://www.mozilla.org/firefox/organizations/all/