X
Tap here to go to the mobile version of the site.

Support Forum

Always activate flash

Posted

Hello,

How do I disable the "Run Flash" icon in firefox? I'm not looking for a button to click on in the settings, I'd appreciate if there was a about:config flag I can set to allow always running flash content wherever.

I don't care about flash's vunerabilities, I'm only using firefox to run flash/.swf files from my local system's HDD (Literally no internet browsing) since chrome insists on downloading those instead of playing them.

Hello, How do I disable the "Run Flash" icon in firefox? I'm not looking for a button to click on in the settings, I'd appreciate if there was a about:config flag I can set to allow always running flash content wherever. I don't care about flash's vunerabilities, I'm only using firefox to run flash/.swf files from my local system's HDD (Literally no internet browsing) since chrome insists on downloading those instead of playing them.

Chosen solution

Firefox will always show a Lego block icon on the location/address bar if there is Flash content on a web page. Flash is usually disabled by default as a safety feature.

Current Firefox releases have a setting to "Block dangerous and intrusive Flash content" that you can find if you click the "More" button of the Shockwave Flash plugin.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 22.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
3668 solutions 50313 answers

Helpful Reply

Eskir said

How do I disable the "Run Flash" icon in firefox?

Are you talking about the allow button?


Separate Security Issue: Update your Flash Player Note: Windows users should download the ActiveX for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX.

Flash Player Version: Version 29.0.0.113

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download. <Windows Only>

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

''Eskir [[#question-1209200|said]]'' <blockquote> How do I disable the "Run Flash" icon in firefox? </blockquote> Are you talking about the allow button? ----------------- Separate Security Issue: Update your Flash Player '''Note: Windows users''' should download the '''ActiveX''' for ''Internet Explorer.'' '''and''' the '''plugin''' for ''Plugin-based browsers'' (like Firefox). '''Note: Windows 8 and Windows 10''' have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the ActiveX. Flash Player Version: '''Version 29.0.0.113 ''' https://get.adobe.com/flashplayer/ Direct link scans current system and browser '''Note: Other software''' is offered in the download. <Windows Only> https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) '''Note: Other software''' is offered in the download. <Windows Only> +++++++++++++++++++ See if there are updates for your graphics drivers https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration
Was this helpful to you? 2
Quote

Question owner

Yes, I'd like to just automatically play flash content instead of seeing that button.

Yes, I'd like to just automatically play flash content instead of seeing that button.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3668 solutions 50313 answers

Helpful Reply

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager. ''' Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins. ''' Make sure the ones you want to use are set to '''Ask''' or '''Allow. ''' ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and '''Left-click''' the icon. Select '''Permissions. ''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow. '''
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16395 solutions 147930 answers

Chosen Solution

Firefox will always show a Lego block icon on the location/address bar if there is Flash content on a web page. Flash is usually disabled by default as a safety feature.

Current Firefox releases have a setting to "Block dangerous and intrusive Flash content" that you can find if you click the "More" button of the Shockwave Flash plugin.

Firefox will always show a Lego block icon on the location/address bar if there is Flash content on a web page. Flash is usually disabled by default as a safety feature. Current Firefox releases have a setting to "Block dangerous and intrusive Flash content" that you can find if you click the "More" button of the Shockwave Flash plugin. *https://support.mozilla.org/en-US/kb/flash-blocklists *https://support.mozilla.org/en-US/kb/why-do-i-have-click-activate-plugins
Was this helpful to you? 1
Quote

Question owner

Huh. Like magic, I went to the addons page earlier and it was disabled - couldn't select "always active", I haven't checked back since playing around but I guess I enabled it with something I did. Probably what cor-el said

Huh. Like magic, I went to the addons page earlier and it was disabled - couldn't select "always active", I haven't checked back since playing around but I guess I enabled it with something I did. Probably what cor-el said
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3668 solutions 50313 answers

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.


Don't forget to update your flash.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support. ---------------------- Don't forget to update your flash.
Was this helpful to you?
Quote
James
  • Top 25 Contributor
  • Moderator
1441 solutions 9970 answers

addons.mozilla.org/blocked/

Flash Player version 27.0.0.159 and older is on blocklist for click to play soft blocking due to critical vulnerabilities.

addons.mozilla.org/blocked/ Flash Player version 27.0.0.159 and older is on blocklist for click to play soft blocking due to critical vulnerabilities.
Was this helpful to you?
Quote

Question owner

James said

addons.mozilla.org/blocked/ Flash Player version 27.0.0.159 and older is on blocklist for click to play soft blocking due to critical vulnerabilities.

I already disabled the blocklist.

Also @FredMcD - I upvoted the answer(s) in question as helpful, is that what you mean? I don't see a 'Accept answer' like there is on stackoverflow.

''James [[#answer-1088140|said]]'' <blockquote> addons.mozilla.org/blocked/ Flash Player version 27.0.0.159 and older is on blocklist for click to play soft blocking due to critical vulnerabilities. </blockquote> I already disabled the blocklist. Also @FredMcD - I upvoted the answer(s) in question as helpful, is that what you mean? I don't see a 'Accept answer' like there is on stackoverflow.
Was this helpful to you?
Quote

Question owner

Nevermind.

Nevermind.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
3668 solutions 50313 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.