X
Tap here to go to the mobile version of the site.

Support Forum

I can't watch NBC TV episodes because of ad-blocking. I don't see an ad-block plug-in, ad-on, or extension in Firefox. Help?

Posted

Tried to watch NBC television episodes but get this message-

"Sorry, we can't play this video in its intended experience because we're unable to load the accompanying message from our sponsors.

If you are using ad-blocking software, please disable it and try loading the page again."

I don't have any ad blocking programs on my PC that I know of. I am able to watch the NBC episodes on Internet Explorer. Is there something in Firefox that's preventing me from viewing the television episodes?

Tried to watch NBC television episodes but get this message- "Sorry, we can't play this video in its intended experience because we're unable to load the accompanying message from our sponsors. If you are using ad-blocking software, please disable it and try loading the page again." I don't have any ad blocking programs on my PC that I know of. I am able to watch the NBC episodes on Internet Explorer. Is there something in Firefox that's preventing me from viewing the television episodes?
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 18.11.20036
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.161.2 for Mozilla browsers
  • np-mswmp
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 28.0 r0
  • 5.1.50907.0
  • mydlink services plugin

Application

  • Firefox 52.6.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.6.0/WINNT/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Disconnect 5.18.21 (2.0@disconnect.me)
  • DuckDuckGo Plus 1.1.26 (jid1-ZAdIEUB7XOzOJw@jetpack)
  • Ebates: The Free Cash Back Shopping Assistant 4.26.1.0 ({35d6291e-1d4b-f9b4-c52f-77e6410d1326})
  • InvisibleHand 6.5 (canitbecheaper@trafficbroker.co.uk)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce 310
  • adapterDescription2:
  • adapterDeviceID: 0x0a66
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 512
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 8-9-2013
  • driverDate2:
  • driverVersion: 9.18.13.2078
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D9 API
  • webgl2Renderer: Google Inc. -- ANGLE (NVIDIA GeForce 310 Direct3D11 vs_4_1 ps_4_1)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce 310 Direct3D11 vs_4_1 ps_4_1)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
WestEnd
  • Top 10 Contributor
51 solutions 2486 answers

One adblocker on one browser doesn't affect another browser. The screen says there is a adblocker type software installed.

One adblocker on one browser doesn't affect another browser. The screen says there is a adblocker type software installed.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16406 solutions 148014 answers

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache:

  • Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now"

"Remove the Cookies" from websites that cause problems.

  • Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> cookies: "Show cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache: *Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now" "Remove the Cookies" from websites that cause problems. *Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> cookies: "Show cookies" Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
Was this helpful to you?
Quote

Question owner

cor-el said

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.
  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)
Clear the cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache:
  • Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now"
"Remove the Cookies" from websites that cause problems.
  • Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> cookies: "Show cookies"
Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.
  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

When I start Firefox in Safe Mode, I AM able to watch NBC episodes. When I went back to regular Firefox and cleared the cache & NBC cookies, I still was NOT able to view the episodes. There is still something in Firefox that is preventing me from watching NBC television shows.

''cor-el [[#answer-1086821|said]]'' <blockquote> Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can try these steps in case of issues with web pages: You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files. *hold down the Shift key and left-click the Reload button *press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux) *press "Command + Shift + R" (Mac) Clear the cache and remove the Cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences). "Clear the cache: *Options/Preferences -> Privacy & Security -> Cached Web Content: "Clear Now" "Remove the Cookies" from websites that cause problems. *Options/Preferences -> Privacy & Security -> "Use custom settings for history" -> cookies: "Show cookies" Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems </blockquote> When I start Firefox in Safe Mode, I AM able to watch NBC episodes. When I went back to regular Firefox and cleared the cache & NBC cookies, I still was NOT able to view the episodes. There is still something in Firefox that is preventing me from watching NBC television shows.
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
16406 solutions 148014 answers

That is weird since it is likely an extension issue if you would believe the warning.

Are you using Private Browsing mode?

Do you see a shield icon on the Navigation Toolbar indicating that Tracking Protection is actively blocking content?

I don't think that hardware acceleration could be causing this, but you can still give it a try.

Close and restart Firefox after modifying the setting to make the change effective.


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

That is weird since it is likely an extension issue if you would believe the warning. Are you using Private Browsing mode? Do you see a shield icon on the Navigation Toolbar indicating that Tracking Protection is actively blocking content? *https://support.mozilla.org/en-US/kb/tracking-protection-firefox I don't think that hardware acceleration could be causing this, but you can still give it a try. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting to make the change effective. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration ---- You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
Was this helpful to you?
Quote

Question owner

Not in Private Browsing, no shield in the Navigation Toolbar, and unchecking the "Use hardware acceleration when available" box did not solve the problem. I don't feel comfortable with the "Create a new profile" idea - guess I'll just have to watch the NBC episodes in Firefox Safe Mode?

Not in Private Browsing, no shield in the Navigation Toolbar, and unchecking the "Use hardware acceleration when available" box did not solve the problem. I don't feel comfortable with the "Create a new profile" idea - guess I'll just have to watch the NBC episodes in Firefox Safe Mode?
Was this helpful to you?
Quote

Question owner

I figured it out. I have DISCONNECT and simply added NBC.com as a WHITELIST site. Thanks for all your feedback & help!

I figured it out. I have DISCONNECT and simply added NBC.com as a WHITELIST site. Thanks for all your feedback & help!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.