Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox quantum 58 is not changing any fonts

  • 20 replies
  • 3 have this problem
  • 86 views
  • Last reply by 100Michael

more options

The font is the default, any other font isn't not working. As well, the bookmars column is the same, the font is the default, without any other fonts. Please can you help we. Thank you.

Chosen solution

Hello jscher2000, The "Arial" font for the "userChrome.css" is O.K., we have done that, not the "Ariel" font. But the default is as it was after restarting, not "Arial", I am afraid the *.css files are beyond me, I will be defaulting the font after all. Thank you for your efforts.

Read this answer in context 👍 0

All Replies (20)

more options

Hi,

Your 'Theme Font & Size Changer' could be the reason .....
Would you disable it and see if that will make a difference  ?

In that case you could contact the developer at his 'Support Email' .....

more options

Separate issue :

Your system details show that you need to update your Adobe Flash Player - you're running an older version, which can cause problems. Would you please uninstall your current version and install the latest version, which is 28.0.0.161

Uninstaller : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

https://get.adobe.com/flashplayer/

Note : some 'extras' may be offered in the download.

more options

Thank you for the Adobe Flash Player. We are still waiting for the first section of the message, the 'Theme Font & Size Changer' program isn't there at all. Thank you again.

more options

100Michael said

We are still waiting for the first section of the message, the 'Theme Font & Size Changer' program isn't there at all.

Your system details (to the right of your original post) show that you have the 'Theme Font & Size Changer' installed ......

You should see it when you go to  :

3-bar menu => Add-ons => Extensions

(Or type in the address bar about:addons => Extensions)

It's a wild guess, but it just might be the culprit ....

more options

Sorry, yes the 'Theme Font & Size Changer' was installed, but even after the 'Theme.....@ was uninstalled, the default fonts only were there, everything else is not there.

more options

100Michael said

Sorry, yes the 'Theme Font & Size Changer' was installed, but even after the 'Theme.....@ was uninstalled, the default fonts only were there, everything else is not there.

Maybe I'm getting this all wrong, but do you mean that when you go to Options => General => Fonts & Colors - only the default font shows in what should be a list of different fonts  ? Or when you click 'Advanced' - you can't change the settings  ?

I must confess that I don't really know what you mean by "everyting else is not there" ......

more options

Yes, we go to 'options=>general=>fonts and colors' and 'Advanced' is pressed, we can change it, but as soon as the 'options=>general.......' is done the default font is as before. Please help.

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

See also:

more options

Hi 100Michael, I think the setting on the Options page is for web content, not for the user interface parts of Firefox itself. For those areas, Firefox usually picks up your Windows settings.

What do you want to change within the user interface? Is it a matter of enlarging all the text? Or changing the font used from the system font to some other font? Or both?

more options

Interesting, both our replies are posted in the same second (24).

more options

100Michael said

Yes, we go to 'options=>general=>fonts and colors' and 'Advanced' is pressed, we can change it, but as soon as the 'options=>general.......' is done the default font is as before. Please help.

Just to make sure :

After you changed a setting in that contect menu - did you then click 'OK' (at the bottom) before closing the menu  ? And did you close and restart Firefox  ?

more options

cor-el said

Interesting, both our replies are posted in the same second (24).

And apparantly none of us saw a banner saying that 'so-and-so' is working on this problem ......

more options

Top 10 Contributor Happy112, yes the OK button is pressed, and we are closing Firefox and restarting. Even though the fonts are altered to 'Ariel' font, with the 'advanced' section done, after doing the OK buttons and Firefox has restarted the default fonts are in place again. Yet you help me.

Top 10 Contributor, Jscher 2000, Changing the font used from the system font to some other font in not working.

more options

Hi 100Michael, I think in Firefox 57+, extensions can change the font color in the toolbar/user interface area, but cannot change which font is used. To do that, you probably need to create a userChrome.css file with some custom style rules.

In case that was blah-blah-blah to you, I created a site about userChrome.css files. Unfortunately, it doesn't specifically cover the topic of fonts in the user interface so someone will need to find or come up with the rules to make the change.

https://www.userchrome.org/

Some questions:

(1) What parts do you want to change? For example:

  • menu bar (File, Edit, View...)
  • main toolbar / address bar
  • bookmarks toolbar
  • bookmarks sidebar (to the left of the page)

(2) What is your preferred font?

(3) Do you need the size larger?

more options

Hello jscher2000, 1) bookmark sidebar and main section. 2) Arial. 3) No thank you. The size is O. K. Thank you all the same.

more options

Hello 100Michael,

Quoting you :

" Yes, we go to 'options=>general=>fonts and colors' and 'Advanced' is pressed, we can change it, but as soon as the 'options=>general.......' is done the default font is as before. "

Please forgive me if this is a rhetorical question, but did you take a look at what cor-el posted earlier :

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Modified by Happy112

more options

Here's a first draft:

#navigator-toolbox *,
#mainPopupSet panel *, 
.panel-subview-body *, 
.panel-subview-footer *, 
#sidebar-box *,
.sidebar-placesTree treechildren::-moz-tree-cell-text {
  font-family: Arial !important;
}

It doesn't seem to affect the panels that drop down from add-on buttons, but should cover most of the built-in ones.

more options

Hello jscher2000, I have done the 'userChrome.css' file as promised, restarted Firefox, but the fonts are the same as before. I have done it with the file as before :-

#navigator-toolbox *,
...
...
...
  font-family: Ariel  ! important;

but the fonts are the same. Perhaps I am doing it wrong. Please could you advise.

Modified by cor-el

more options

Sorry, did you copy/paste directly from mine? I think Ariel is a mermaid and not a font?

more options

Chosen Solution

Hello jscher2000, The "Arial" font for the "userChrome.css" is O.K., we have done that, not the "Ariel" font. But the default is as it was after restarting, not "Arial", I am afraid the *.css files are beyond me, I will be defaulting the font after all. Thank you for your efforts.