X
Tap here to go to the mobile version of the site.

Support Forum

The fonts are not showing correctly i tried everything but its showing like this in all browsers please help!!!

Posted

Hi on most shopify websites, amazon and emirates website font show like this kindly help

Hi on most shopify websites, amazon and emirates website font show like this kindly help

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

Question owner

This is how it looks

This is how it looks
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Type about:preferences<enter> in the address bar.

  • Cookies; Select Privacy. Under History, select

Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.

  • Cache; Select Advanced > Network.

[v57+] Select Privacy. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 ---------------- Many site issues can be caused by corrupt cookies or cache. * Clear the Cache and * Remove Cookies '''Warning ! ! ''' This will log you out of sites you're logged in to. You may also lose any settings for that website. Type '''about:preferences'''<enter> in the address bar. * '''Cookies; ''' Select '''Privacy. ''' Under '''History, ''' select Firefox will '''Use Custom Settings. ''' Press the button on the right side called '''Show Cookies. ''' Use the search bar to look for the site. Note; There may be more than one entry. Remove '''All''' of them. * '''Cache; ''' Select '''Advanced > Network. ''' [v57+] Select '''Privacy. ''' Across from '''Cached Web Content, ''' Press '''Clear Now. ''' If there is still a problem, '''Start Firefox in Safe Mode''' https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Did this help? While you are in safe mode; Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. ''[https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration How to disable Hardware Acceleration]'' {web link}

Question owner

Tried everything mentioned still no luck.

Tried everything mentioned still no luck.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering

Would you please try this : Type in the address bar about:config (press Enter) (promise to be careful if asked)

Type in the search bar gfx.canvas and look for the preference: gfx.canvas.azure.backends and set its value to direct2d1.1,cairo,skia

Type in the search bar gfx.content and look for the preference: gfx.content.azure.backends and set its value to direct2d1.1,cairo,skia

Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking 'Reset'.


Execute cttune.exe from Win+R, and enable ClearType and follow the onscreen instruction, it may fix the issue.

Firefox 52+ has changed from Cairo to Skia for canvas/content rendering. When Direct2D on Windows isn't used, Skia is used for content rendering Would you please try this : Type in the address bar '''about:config''' (press Enter) (promise to be careful if asked) Type in the search bar '''gfx.canvas''' and look for the preference: '''gfx.canvas.azure.backends''' and set its value to '''direct2d1.1,cairo,skia ''' Type in the search bar '''gfx.content''' and look for the preference: '''gfx.content.azure.backends''' and set its value to '''direct2d1.1,cairo,skia ''' Then close and restart Firefox in order for the change to take effect. If this doesn't make a difference, change the values back to their default by clicking ''''Reset''''. --------------- Execute '''cttune.exe''' from Win+R, and enable ClearType and follow the onscreen instruction, it may fix the issue.