X
Tap here to go to the mobile version of the site.

Support Forum

YouTube will not load videos

Posted

Windows 10 Pro, 1709, 16299.192, Firefox 58.0.1 (64-bit). As of 02/03/2018, YouTube will not load videos. It just shows a spinning circle on a black screen. It will run in Safe Mode so I ended up doing a refresh and deleting all add-ons. But after the refresh and with no add-ons reinstalled, YouTube would still not load a video. YouTube works fine on Chrome.

Windows 10 Pro, 1709, 16299.192, Firefox 58.0.1 (64-bit). As of 02/03/2018, YouTube will not load videos. It just shows a spinning circle on a black screen. It will run in Safe Mode so I ended up doing a refresh and deleting all add-ons. But after the refresh and with no add-ons reinstalled, YouTube would still not load a video. YouTube works fine on Chrome.

Chosen solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
16471 solutions 148571 answers

Chosen Solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting to make the change effective. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration

Question owner

This actually worked! Although I'm still very curious why those settings (Use recommended performance settings & Use hardware acceleration when available), seemed to work fine for months and months up until 02/03/2018. Maybe a recent version tweak? In any event, I'm back in business. Many thanks Cor-El!

This actually worked! Although I'm still very curious why those settings (Use recommended performance settings & Use hardware acceleration when available), seemed to work fine for months and months up until 02/03/2018. Maybe a recent version tweak? In any event, I'm back in business. Many thanks Cor-El!