X
Tap here to go to the mobile version of the site.

Support Forum

Visited website links don't change color anymore.

Posted

Windows 10, latest Firefox Quantum version. This has been happening for a while, not sure which update it started with but irritating enough it may be a deal breaker if it cannot be fixed. I have gone to options, colors, and unvisited and visited link colors are different. I tried all three choices in "Override the colors specified by the page with your selections above" and none worked. Private browsing is unchecked. This is happening regardless of search engine being used; Google, Edge, and Bing. I have even tried adding the extension "Custom Google Visited Link Color" in add-ons and that did not work either. I also checked about:config page and layout.css.visited_links_enabled is set to default. What am I missing? Or is this option no longer available with the update to Firefox Quantum?

Visited links are a different color in both IE and Edge browsers (I installed both due to this problem to see if they also had it), so this seems to be an issue only with Firefox?

Windows 10, latest Firefox Quantum version. This has been happening for a while, not sure which update it started with but irritating enough it may be a deal breaker if it cannot be fixed. I have gone to options, colors, and unvisited and visited link colors are different. I tried all three choices in "Override the colors specified by the page with your selections above" and none worked. Private browsing is unchecked. This is happening regardless of search engine being used; Google, Edge, and Bing. I have even tried adding the extension "Custom Google Visited Link Color" in add-ons and that did not work either. I also checked about:config page and layout.css.visited_links_enabled is set to default. What am I missing? Or is this option no longer available with the update to Firefox Quantum? Visited links are a different color in both IE and Edge browsers (I installed both due to this problem to see if they also had it), so this seems to be an issue only with Firefox?

Chosen solution

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

scribbler1 3 solutions 10 answers

I've tried all of the same steps as the OP, which included Firefox support instructions (and its linked pages) here.

Visited links do not change color on the Firefox browser, no matter what search engine I use (DuckDuck Go, Google, Bing, etc).

My environment is MacOS Sierra 10.12.6 with Firefox 58.0.2

I've tried all of the same steps as the OP, which included Firefox support instructions (and its linked pages) [https://support.mozilla.org/en-US/questions/1190748 here]. Visited links do not change color on the Firefox browser, no matter what search engine I use (DuckDuck Go, Google, Bing, etc). My environment is MacOS Sierra 10.12.6 with Firefox 58.0.2
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158548 answers

Chosen Solution

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).

  • Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"
Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/Private+Browsing *Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode"
scribbler1 3 solutions 10 answers

Firefox is not running in permanent Private Browsing mode.

Firefox is not running in permanent Private Browsing mode.

Helpful Reply

cor-el said

Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History).
  • Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history"
  • remove checkmark: [ ] "Always use Private Browsing mode"

Thank you. I had already had Permanent Private Browsing mode unchecked, but I had the Remember my Browsing and Download History box unchecked as well. When I put a check mark in the Remember Browsing and Download History box, that solved my problem! Visited links now change color. Makes perfect sense now, doh. I would not have played around with that further had you not posted to my question, thank you!

''cor-el [[#answer-1081488|said]]'' <blockquote> Make sure you do not run Firefox in permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History). *https://support.mozilla.org/en-US/kb/Private+Browsing *Options/Preferences -> Privacy & Security -> Firefox will: "Use custom settings for history" *remove checkmark: [ ] "Always use Private Browsing mode" </blockquote> Thank you. I had already had Permanent Private Browsing mode unchecked, but I had the Remember my Browsing and Download History box unchecked as well. When I put a check mark in the Remember Browsing and Download History box, that solved my problem! Visited links now change color. Makes perfect sense now, doh. I would not have played around with that further had you not posted to my question, thank you!

Modified by Jonic

scribbler1 3 solutions 10 answers

Re-enabling 'Remember Browsing and Download History' worked for me, too. Thanks Jonic and cor-el.

Re-enabling 'Remember Browsing and Download History' worked for me, too. Thanks Jonic and cor-el.
hisself 0 solutions 3 answers

I, too, have this problem! I am running Firefox Beta for Android 61.0b15 on a Samsung Tab S2 T817T.

I, too, have this problem! I am running Firefox Beta for Android 61.0b15 on a Samsung Tab S2 T817T.
hisself 0 solutions 3 answers

Never mind, it just started working again.

Never mind, it just started working again.
hifromnz 4 solutions 46 answers

I have this problem. Remember Browsing and Download History has always been enabled. Never use private browsing.

I have this problem. Remember Browsing and Download History has always been enabled. Never use private browsing.
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158548 answers

Hi hifromnz

Can you confirm that the links show up in the History?

You can check this pref on the about:config page.

  • layout.css.visited_links_enabled

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
Hi hifromnz Can you confirm that the links show up in the History? You can check this pref on the <b>about:config</b> page. *layout.css.visited_links_enabled You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems