Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

DRM won't work on prime video - site insists Widevine isn't active

  • 9 replies
  • 3 have this problem
  • 638 views
  • Last reply by digiscape

more options

Attempts to play videos on Amazon produce a Digital Rights Error suggesting I enable Widevine CDM. When I check plugins it's already set to Always Activate.

This is FF 57.0.4 on Windows 10 x64 with plugins checked and up to date.

Attempts to play videos on Amazon produce a Digital Rights Error suggesting I enable Widevine CDM. When I check plugins it's already set to Always Activate. This is FF 57.0.4 on Windows 10 x64 with plugins checked and up to date.

Chosen solution

Problem solved - I tried a Netflix trial which also failed but did pop up a message suggesting install Windows Media Pack as I'm on an N edition of Windows.

That fixed Netflix & Prime playback. It's odd that the popup only appeared on attempts to play video in Netflix and not Prime but at least the issue is solved.

FireFox must depend on some OS components for video whilst Chrome uses something else.

Read this answer in context 👍 0

All Replies (9)

more options

Could you double-check the DRM checkbox:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type drm and Firefox should filter to the "Digital Rights Management" section where you can confirm the box is checked for "Play DRM-controlled content".

I don't know if sites might have trouble playing content if cookies or local storage (DOM storage) are disabled. Do you recall modifying any settings like that?

more options

Try to toggle DRM off/on in Options/Preferences to see if that has effect.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block (wanted) content (e.g. Adblock Plus, NoScript, Ghostery, uBlock Origin) always make sure such extensions do not block (wanted) content.

  • make sure your extensions and filters are updated to the latest version

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

I've checked the "Play DRM content" option is ticked.

I've not changed any default options from install - this was a clean install yesterday. Long time Chrome user thinking I'd give FF a try and watching videos happens to have been one of the first things I tried out.

I've got no adblock, ghostery type extensions enabled.

Issue persists in safe mode.

more options

digiscape said

I've checked the "Play DRM content" option is ticked. I've not changed any default options from install - this was a clean install yesterday. Long time Chrome user thinking I'd give FF a try and watching videos happens to have been one of the first things I tried out. I've got no adblock, ghostery type extensions enabled. Issue persists in safe mode.

Then this would mean it was a corrupted install. Did you uninstall it completely and deleted the Mozilla folder and then reinstall it?

more options

Did you try to toggle the DRM setting in Options/Preferences?

more options

Yes I've toggled the options...

This was a fresh install of FireFox - never before installed on this machine. I'll try doing a re-install now.

more options

Doesn't work after a reinstall.

After a refresh it prompts to say it's installing the required components when I try to watch something but then after a page re-load I'm back to the DRM message.

Very frustrating. I'll keep trying suggestions if there's any other ideas but I'll have to stick with Chrome a while longer it seems.

more options

digiscape said

Attempts to play videos on Amazon produce a Digital Rights Error suggesting I enable Widevine CDM. When I check plugins it's already set to Always Activate. This is FF 57.0.4 on Windows 10 x64 with plugins checked and up to date.

Did you contact Amazon about this problem as well? That is whom you should really ask since Amazon is telling you what to do.

more options

Chosen Solution

Problem solved - I tried a Netflix trial which also failed but did pop up a message suggesting install Windows Media Pack as I'm on an N edition of Windows.

That fixed Netflix & Prime playback. It's odd that the popup only appeared on attempts to play video in Netflix and not Prime but at least the issue is solved.

FireFox must depend on some OS components for video whilst Chrome uses something else.