Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since updating to the new Firefox it locks up my browser and I have to shut down and restart my computer.

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by Shadow110

more options

I am running Windows 7 Home Premium with 64 bit operating system. Since installing the latest version of Firefox my browser will lock up or is very slow to access and download pages. I have had Best Buy Geek Squad check my computer and perform diagnostics but it has not improved. When I use Google Chrome as my browser it works fine and has not locked up.

All Replies (1)

more options

please : go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check (put a tick in the box) the setting to Prevent Accessibility Services from accessing your browser.

Monitor in Task Manager. Should stay below 2 gigs. If excessive then do below and monitor and change if need to...Test and go up again , go back down, it will eventually get a zone you and it can live with.

Go to the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

Please let us know if this solved your issue or if need further assistance.