X
Tap here to go to the mobile version of the site.

Support Forum

How to stop Mozilla resetting my default search to Bing instead of Google?

Posted

This is a new computer with nothing Bing installed on it, period, no random search bar installations, just the basic programs with a new computer. I have NO extensions or addons. I've gone to about:config and searched for Bing anything and NOTHING appears. I've reset my browser and it's fully updated... all of this and STILL every single time I close the browser and restart it it resets my search engine to freakin' Bing AND adds it back to preferred searches after I've deleted it!

I'm at my wits end, it's driving me nuts and it's clearly an issue with Mozilla at this point. Everything is fresh install. What can I do to fix this?? I hate Bing; I want Google and I'm starting to hate Mozilla for forcing Bing on me.

This is a new computer with nothing Bing installed on it, period, no random search bar installations, just the basic programs with a new computer. I have NO extensions or addons. I've gone to about:config and searched for Bing anything and NOTHING appears. I've reset my browser and it's fully updated... all of this and STILL every single time I close the browser and restart it it resets my search engine to freakin' Bing AND adds it back to preferred searches after I've deleted it! I'm at my wits end, it's driving me nuts and it's clearly an issue with Mozilla at this point. Everything is fresh install. What can I do to fix this?? I hate Bing; I want Google and I'm starting to hate Mozilla for forcing Bing on me.

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0

More Information

jscher2000
  • Top 10 Contributor
7777 solutions 63337 answers

Firefox is designed to allow you to pick your default search engine and have it remain unchanged (at least until a new company sign up with Mozilla as the default search provider, but that doesn't happen very often).

Does the problem search engine show up as "Bing" or "Bing Search Engine"? The "Bing" is built in; the other one appears to be malware. See: Firefox will not stop changing search provider from Google to "Bing Search Engine" (Not standard "Bing"!)

Firefox is designed to allow you to pick your default search engine and have it remain unchanged (at least until a new company sign up with Mozilla as the default search provider, but that doesn't happen very often). Does the problem search engine show up as "Bing" or "Bing Search Engine"? The "Bing" is built in; the other one appears to be malware. See: [https://support.mozilla.org/questions/1194132 Firefox will not stop changing search provider from Google to "Bing Search Engine" (Not standard "Bing"!)]
cor-el
  • Top 10 Contributor
  • Moderator
16606 solutions 149946 answers

Try to rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild the search.json.mozlz4 file from the builtin search engines.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

See also:

Try to rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox Firefox will rebuild the search.json.mozlz4 file from the builtin search engines. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems See also: *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-caused-malware