X
Tap here to go to the mobile version of the site.

Support Forum

Why is the new, "improved" Firefox 57 hogging CPU resources (25-75% all the time) much more than the previous version did?

Posted

Ever since the latest "Quantum" Firefox update, the Firefox main process has been hogging between 25-50% minimum CPU resources. I have a dual core 3.0 GHz processor in my PC, and Firefox is using 25% minimum of one core and nearly 50% of the other core. I tried turning off hardware acceleration and turning off accessibility permission (as some other support personnel have suggested to other users with similar issues), but both revert back to enabled when I restart Firefox. I do not have any extensions installed, and I don't have any themes installed either (I'm using the default). Also, I don't have any add-ons except for Flash, which is set to "Ask for activation." So, I'm running a very basic installation of Firefox, as I always have, but I've never experienced this CPU resource hogging behavior. One thing I should mention is that I do have a lot of tabs open, and I use three Firefox windows to display them in. One of my FF windows probably has at least 50 tabs. But this is nothing new. I've always had lots of tabs and several FF windows open at one time but never experienced this slowness before the latest upgrade. The only workaround is for me to shut down FF and use Chrome until I need to access one of the FF tabbed pages that I visit on a regular basis. This is very disappointing because I definitely prefer FF to Chrome, but I may be forced to ditch FF or only use it minimally if this problem persists. I also can't stop that stupid Bookmarks sidebar from automatically appearing and taking up screen space every time I start FF. I've looked for solutions and tried them, but none have worked so far.

Ever since the latest "Quantum" Firefox update, the Firefox main process has been hogging between 25-50% minimum CPU resources. I have a dual core 3.0 GHz processor in my PC, and Firefox is using 25% minimum of one core and nearly 50% of the other core. I tried turning off hardware acceleration and turning off accessibility permission (as some other support personnel have suggested to other users with similar issues), but both revert back to enabled when I restart Firefox. I do not have any extensions installed, and I don't have any themes installed either (I'm using the default). Also, I don't have any add-ons except for Flash, which is set to "Ask for activation." So, I'm running a very basic installation of Firefox, as I always have, but I've never experienced this CPU resource hogging behavior. One thing I should mention is that I do have a lot of tabs open, and I use three Firefox windows to display them in. One of my FF windows probably has at least 50 tabs. But this is nothing new. I've always had lots of tabs and several FF windows open at one time but never experienced this slowness before the latest upgrade. The only workaround is for me to shut down FF and use Chrome until I need to access one of the FF tabbed pages that I visit on a regular basis. This is very disappointing because I definitely prefer FF to Chrome, but I may be forced to ditch FF or only use it minimally if this problem persists. I also can't stop that stupid Bookmarks sidebar from automatically appearing and taking up screen space every time I start FF. I've looked for solutions and tried them, but none have worked so far.

Chosen solution

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 4

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • Firefox 57.0.2
  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
  • Support URL: https://support.mozilla.org/1/firefox/57.0.2/WINNT/en-US/

Extensions

  • Places Maintenance 2.0.3 (places-maintenance@bonardo.net) (Inactive)
  • SQLite Manager 0.8.3.1-signed.1-signed (SQLiteManager@mrinalkant.blogspot.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: ATI Radeon HD 3400 Series
  • adapterDescription2:
  • adapterDeviceID: 0x95c0
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx32 aticfx32 atiumd64 atidxx64 atiumdag atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 256
  • adapterRAM2:
  • adapterSubsysID: 32431028
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.22164
  • driverDate: 4-19-2011
  • driverDate2:
  • driverVersion: 8.850.0.0
  • driverVersion2:
  • featureLog: {u'fallbacks': [{u'message': u'Unsupported by driver', u'name': u'NO_CONSTANT_BUFFER_OFFSETTING'}], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'available', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u"Build doesn't include WebRender", u'type': u'runtime'}], u'name': u'WEBRENDER'}, {u'status': u'available', u'description': u'Advanced Layers', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'available', u'message': u'Enabled for Windows 7 via user-preference', u'type': u'user'}], u'name': u'ADVANCED_LAYERS'}]}
  • info: {u'AzureContentBackend (UI Process)': u'skia', u'AzureCanvasBackend (UI Process)': u'skia', u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'AzureFallbackCanvasBackend (UI Process)': u'cairo', u'ApzAutoscrollInput': 1, u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'Direct2D 1.1', u'AzureContentBackend': u'Direct2D 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • offMainThreadPaintEnabled: False
  • webgl1DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl1Extensions: ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
  • webgl1Renderer: Google Inc. -- ANGLE (ATI Radeon HD 3400 Series Direct3D11 vs_4_1 ps_4_1)
  • webgl1Version: OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl1WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 00000000000117ac) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • webgl2DriverExtensions: GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_float GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_norm16 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_EGL_image_external_essl3 GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object
  • webgl2Extensions: EXT_color_buffer_float EXT_texture_filter_anisotropic EXT_disjoint_timer_query OES_texture_float_linear WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc
  • webgl2Renderer: Google Inc. -- ANGLE (ATI Radeon HD 3400 Series Direct3D11 vs_4_1 ps_4_1)
  • webgl2Version: OpenGL ES 3.0 (ANGLE 2.1.0.dec065540d5f)
  • webgl2WSIInfo: EGL_VENDOR: Google Inc. (adapter LUID: 00000000000117ac) EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f) EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11
  • windowUsingAdvancedLayers: True

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Pkshadow
  • Top 10 Contributor
831 solutions 10392 answers

Check to see if 57.01 fix worked : Go to the Firefox 3 Bar Menu --> Help ? --> Troubleshooting Information Page and take a look in the Accessibility section if accessibility is set to "true" there. if yes, go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check the setting to Prevent Accessibility Services from accessing your browser. Restart Firefox

If still yes : You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-proccesor = slow again. TRY 2 Restart Firefox after making these changes please.

Update Video Card Drivers. ATI Radeon HD 3400 Series driverDate: 4-19-2011 https://support.amd.com/en-us/download featureLog: {u'fallbacks': [{u'message': u'Unsupported by driver', u'name': u'NO_CONSTANT_BUFFER_OFFSETTING'}] Maybe time to think of new system.... or moving to the Extended Release Version. 52.5.0 ESR. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ Note : Legacy Extensions will be deleted or removed in any version update after May 2018.

You should make a backup of your Profile before going back and just because: https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Please let us know if this solved your issue or if need further assistance.

Check to see if 57.01 fix worked : Go to the Firefox 3 Bar Menu --> Help ? --> Troubleshooting Information Page and take a look in the Accessibility section if accessibility is set to "true" there. if yes, go to the Firefox 3 Bar Menu --> Options --> Privacy & Security panel and under Permissions check the setting to Prevent Accessibility Services from accessing your browser. Restart Firefox If still yes : You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-proccesor = slow again. TRY 2 Restart Firefox after making these changes please. Update Video Card Drivers. ATI Radeon HD 3400 Series driverDate: 4-19-2011 https://support.amd.com/en-us/download featureLog: {u'fallbacks': [{u'message': u'Unsupported by driver', u'name': u'NO_CONSTANT_BUFFER_OFFSETTING'}] Maybe time to think of new system.... or moving to the Extended Release Version. 52.5.0 ESR. It will continue to get security updates until May 2018, and you can download and install it from this page: https://www.mozilla.org/en-US/firefox/organizations/all/ <b>Note : Legacy Extensions will be deleted or removed in any version update after May 2018</b>. You should make a backup of your Profile before going back and just because: https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Please let us know if this solved your issue or if need further assistance.

Helpful Reply

Thanks for your reply, Pkshadow. My version of FF is 57.0.2, which is behaving the same as 57.0.0 was behaving. I've already tried your first suggestion, but FF won't let me Prevent Accessibility Services from accessing FF. I tried to do this several times, and every time I restart FF, the Accessibility Services is automatically enabled again. I mentioned this in my OP above. I also did try unchecking the Hardware Acceleration option (which I also mentioned in my OP above), but it was also re-checked when I started FF again. So, the only thing left for me to try is to update my video driver. However, I have to research the proper way to do this because I remember having problems doing this correctly in the past, so I want to make sure I do it right the first time.

In the meantime, I should tell you that I actually have at least 100 FF tabs open in three windows (not 50, as I said in my OP), but all of them are idle when I start FF (no ads or scripts running, etc.). Even so, the CPU usage is constantly ranging from 25-75%. Also, I have about 50 tabs open in three windows in Chrome, but it doesn't use any CPU resources when it's idle, and that's with my current video driver. So, I'm inclined to doubt that updating my video driver will make much of a difference, but I'm willing to try it. I just don't understand why can't FF do the same thing as Chrome when they're both following the same software development standards.

You also didn't address my complaint about the Bookmarks sidebar. I don't want it to appear every time I start FF, and I don't know how to stop it from doing that. This forces me to remove it in all three of my windows, which is very annoying and time consuming.

One more thing I should mention about my system. If I didn't have a 500 GB SSD in my system instead of a standard hard drive, I would be seriously considering a new system. But when I installed the SSD last year, the improvement in speed was substantial enough for me to keep my current system for a few more years. The only other software I've run on my PC that hogs the CPU more than FF is video capturing software, and I don't use it very often. So, I don't see any reason why I should have to upgrade my entire system at this point in time just because of one web browser (Firefox) that was working just fine a few weeks ago before the "new, improved, more efficient" update was released. To me, this is an absurd joke.

Thanks for your reply, Pkshadow. My version of FF is 57.0.2, which is behaving the same as 57.0.0 was behaving. I've already tried your first suggestion, but FF won't let me Prevent Accessibility Services from accessing FF. I tried to do this several times, and every time I restart FF, the Accessibility Services is automatically enabled again. I mentioned this in my OP above. I also did try unchecking the Hardware Acceleration option (which I also mentioned in my OP above), but it was also re-checked when I started FF again. So, the only thing left for me to try is to update my video driver. However, I have to research the proper way to do this because I remember having problems doing this correctly in the past, so I want to make sure I do it right the first time. In the meantime, I should tell you that I actually have at least 100 FF tabs open in three windows (not 50, as I said in my OP), but all of them are idle when I start FF (no ads or scripts running, etc.). Even so, the CPU usage is constantly ranging from 25-75%. Also, I have about 50 tabs open in three windows in Chrome, but it doesn't use any CPU resources when it's idle, and that's with my current video driver. So, I'm inclined to doubt that updating my video driver will make much of a difference, but I'm willing to try it. I just don't understand why can't FF do the same thing as Chrome when they're both following the same software development standards. You also didn't address my complaint about the Bookmarks sidebar. I don't want it to appear every time I start FF, and I don't know how to stop it from doing that. This forces me to remove it in all three of my windows, which is very annoying and time consuming. One more thing I should mention about my system. If I didn't have a 500 GB SSD in my system instead of a standard hard drive, I would be seriously considering a new system. But when I installed the SSD last year, the improvement in speed was substantial enough for me to keep my current system for a few more years. The only other software I've run on my PC that hogs the CPU more than FF is video capturing software, and I don't use it very often. So, I don't see any reason why I should have to upgrade my entire system at this point in time just because of one web browser (Firefox) that was working just fine a few weeks ago before the "new, improved, more efficient" update was released. To me, this is an absurd joke.
Pkshadow
  • Top 10 Contributor
831 solutions 10392 answers

So are you saying the "absurd joke* is on you. You can also keep this to your self as Support Volunteers help with questions only. The solutions above have worked for everyone else it seems.

Now, I did not provide solution for Bookmarks as wanted to see about how the other solutions worked out. Especially turning down to 2 the Multiprocessors being used from 4 to 2. This seems to work well for older systems or any issues regarding this. Also because of all the Tabs you have open is another thing. Solutions used can cause issues.

Again since it is a older system it should be on the ESR Version, a SSD does not give drivers to the aging Motherboard or to the Chipset brains of the operation.

Suggest to Close all Open Tabs/Windows. uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer

Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/

Please let us know if this solved your issue or if need further assistance.

So are you saying the "absurd joke* is on you. You can also keep this to your self as Support Volunteers help with questions only. The solutions above have worked for everyone else it seems. Now, I did not provide solution for Bookmarks as wanted to see about how the other solutions worked out. Especially turning down to 2 the Multiprocessors being used from 4 to 2. This seems to work well for older systems or any issues regarding this. Also because of all the Tabs you have open is another thing. Solutions used can cause issues. Again since it is a older system it should be on the ESR Version, a SSD does not give drivers to the aging Motherboard or to the Chipset brains of the operation. Suggest to Close all Open Tabs/Windows. uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 57.0.2 with a Full Version Installer https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

Question owner

I have some more info for you PKshadow. I just checked my wife's PC, which is a Dell Optiplex 780 (mine is a 760) and has the same video card as mine (ATI Radeon HD 3470) but a Quad core processor running at 3 GHz with 8 GB of RAM (mine has 6 GB RAM). I just restarted FF on her system to finish the update to the latest version. When it restarted, it was initially using 20-40% CPU in all four cores, but then it dropped to 0% after a minute or so and stayed there. I then checked the video driver and saw that it's even older than mine. Hers is from 2009 and is version 8.56. So, I seriously doubt that updating my video driver is going to make any difference, but I can still try it. But before I do that, I will reboot my system and only start FF so that no other programs are running (except those that autorun at bootup) to see how much CPU is being used. Perhaps this will make a difference because I rebooted her system after I restarted FF to finish the update. I just haven't rebooted mine in several weeks since the update.

I have some more info for you PKshadow. I just checked my wife's PC, which is a Dell Optiplex 780 (mine is a 760) and has the same video card as mine (ATI Radeon HD 3470) but a Quad core processor running at 3 GHz with 8 GB of RAM (mine has 6 GB RAM). I just restarted FF on her system to finish the update to the latest version. When it restarted, it was initially using 20-40% CPU in all four cores, but then it dropped to 0% after a minute or so and stayed there. I then checked the video driver and saw that it's even older than mine. Hers is from 2009 and is version 8.56. So, I seriously doubt that updating my video driver is going to make any difference, but I can still try it. But before I do that, I will reboot my system and only start FF so that no other programs are running (except those that autorun at bootup) to see how much CPU is being used. Perhaps this will make a difference because I rebooted her system after I restarted FF to finish the update. I just haven't rebooted mine in several weeks since the update.
Pkshadow
  • Top 10 Contributor
831 solutions 10392 answers

netbids said

I have some more info for you PKshadow. I just checked my wife's PC, which is a Dell Optiplex 780 (mine is a 760) and has the same video card as mine (ATI Radeon HD 3470) but a Quad core processor running at 3 GHz with 8 GB of RAM (mine has 6 GB RAM). I just restarted FF on her system to finish the update to the latest version. When it restarted, it was initially using 20-40% CPU in all four cores, but then it dropped to 0% after a minute or so and stayed there. I then checked the video driver and saw that it's even older than mine. Hers is from 2009 and is version 8.56. So, I seriously doubt that updating my video driver is going to make any difference, but I can still try it. But before I do that, I will reboot my system and only start FF so that no other programs are running (except those that autorun at bootup) to see how much CPU is being used. Perhaps this will make a difference because I rebooted her system after I restarted FF to finish the update. I just haven't rebooted mine in several weeks since the update.

I see you missed the last sentence : If still yes : You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-processor = slow again. TRY 2 Restart Firefox after making these changes please.

If I knew that you had not rebooted in that length of time, would have asked you to do so.

''netbids [[#answer-1049382|said]]'' <blockquote> I have some more info for you PKshadow. I just checked my wife's PC, which is a Dell Optiplex 780 (mine is a 760) and has the same video card as mine (ATI Radeon HD 3470) but a Quad core processor running at 3 GHz with 8 GB of RAM (mine has 6 GB RAM). I just restarted FF on her system to finish the update to the latest version. When it restarted, it was initially using 20-40% CPU in all four cores, but then it dropped to 0% after a minute or so and stayed there. I then checked the video driver and saw that it's even older than mine. Hers is from 2009 and is version 8.56. So, I seriously doubt that updating my video driver is going to make any difference, but I can still try it. But before I do that, I will reboot my system and only start FF so that no other programs are running (except those that autorun at bootup) to see how much CPU is being used. Perhaps this will make a difference because I rebooted her system after I restarted FF to finish the update. I just haven't rebooted mine in several weeks since the update. </blockquote> I see you missed the last sentence : If still yes : You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-processor = slow again. TRY 2 Restart Firefox after making these changes please. If I knew that you had not rebooted in that length of time, would have asked you to do so.

Modified by Pkshadow

Question owner

No, I didn't miss the last sentence. I told you twice already (including once in my OP) that I tried to untick everything at Tools-->Options-->Performance, and I even reduced the number of processes from 4 to 2, but when I restarted FF, the Performance box was automatically checked again.

Also, regarding the suggestions you made in your previous post, you didn't say anything about preserving my history. I wouldn't want to lose that either. But perhaps I won't have to reinstall FF if rebooting my system does the trick. And, yes, the "absurd joke" is on me. If I had known all this was going to happen after updating FF, I would have postponed it for another month or two when I had the time to deal with all these troubleshooting issues. But I should have known better because my mother has been having sluggishness issues with her computer (which is only five years old and is faster than mine) ever since she updated FF, and all she does on her computer is check her email and go on Facebook a few times a day! Unlike me, she only has one tab and one window open in FF. Every couple of days, her computer would slow down to the point that she couldn't do anything on it. I was able to figure out that FF was starting a second copy of itself whenever her RAM was getting maxed out (she only has 4 GB, but that should be enough for what she does with her computer). So, shutting down FF and restarting it wouldn't even fix the problem. I had to start Task Manager and kill the remaining FF process (the second copy that had been started) before FF could be restarted. So, my workaround solution that I gave her is to shut down and restart FF every day or every other day at the most BEFORE her RAM gets maxed out. Since then, she hasn't had any more sluggishness problems with her computer.

No, I didn't miss the last sentence. I told you twice already (including once in my OP) that I tried to untick everything at Tools-->Options-->Performance, and I even reduced the number of processes from 4 to 2, but when I restarted FF, the Performance box was automatically checked again. Also, regarding the suggestions you made in your previous post, you didn't say anything about preserving my history. I wouldn't want to lose that either. But perhaps I won't have to reinstall FF if rebooting my system does the trick. And, yes, the "absurd joke" is on me. If I had known all this was going to happen after updating FF, I would have postponed it for another month or two when I had the time to deal with all these troubleshooting issues. But I should have known better because my mother has been having sluggishness issues with her computer (which is only five years old and is faster than mine) ever since she updated FF, and all she does on her computer is check her email and go on Facebook a few times a day! Unlike me, she only has one tab and one window open in FF. Every couple of days, her computer would slow down to the point that she couldn't do anything on it. I was able to figure out that FF was starting a second copy of itself whenever her RAM was getting maxed out (she only has 4 GB, but that should be enough for what she does with her computer). So, shutting down FF and restarting it wouldn't even fix the problem. I had to start Task Manager and kill the remaining FF process (the second copy that had been started) before FF could be restarted. So, my workaround solution that I gave her is to shut down and restart FF every day or every other day at the most BEFORE her RAM gets maxed out. Since then, she hasn't had any more sluggishness problems with her computer.
Pkshadow
  • Top 10 Contributor
831 solutions 10392 answers

Sorry to hear. Yea is not much of a joke. Roll with the punches. https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data Make a copy of the folder for future, will have, will not say will always work. History included.

Your History may not be lost, did it create a 2nd Profile, would see in above ? Or it would have left a folder on your desktop called OldFirefoxData.

I am getting now confused. With the length of your answers that I have no idea what if anything has worked not if you followed some steps.

No idea why it condenses it into a read on, no breaks from subject to subject. Very hard to follow.

https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Think mentioned have had mine since 95, overwrite once ready.

Your Mothers Issues would be fixed with any or all of the suggestions already discussed.

They thing is to Update to 57.0.2 https://support.mozilla.org/en-US/kb/update-firefox-latest-version You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-processor = slow again. TRY 2 Restart Firefox after making these changes please.

Or the reinstall and then above.

Please let us know if this solved your issue or if need further assistance.

Sorry to hear. Yea is not much of a joke. Roll with the punches. https://support.mozilla.org/en-US/kb/profiles-where-firefox-stores-user-data Make a copy of the folder for future, will have, will not say will always work. History included. Your History may not be lost, did it create a 2nd Profile, would see in above ? Or it would have left a folder on your desktop called OldFirefoxData. I am getting now confused. With the length of your answers that I have no idea what if anything has worked not if you followed some steps. No idea why it condenses it into a read on, no breaks from subject to subject. Very hard to follow. https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Think mentioned have had mine since 95, overwrite once ready. Your Mothers Issues would be fixed with any or all of the suggestions already discussed. They thing is to Update to 57.0.2 https://support.mozilla.org/en-US/kb/update-firefox-latest-version You could try this please : Go the Menu then Tools --> Options --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 0 = No Multi-processor = slow again. TRY 2 Restart Firefox after making these changes please. Or the reinstall and then above. Please let us know if this solved your issue or if need further assistance.

Question owner

Okay, Pkshadow, here's a rundown of what I've done and haven't done so far to clear up your confusion:

1) Prevent Accessibility Services - I tried to do this several times, but FF won't let me. Every time I restart FF, the box is checked again.

2) Performance settings - I tried to uncheck this several times and reduce the number of processes to "2" twice, but FF won't let me make these changes either. Every time I restart FF, the "Use recommended performance settings" box is automatically checked.

3) Update to 57.0.2 - I updated to this version prior to submitting my original support request above because I though that it may solve my issues, but it didn't make any difference.

4) Reboot my computer - This is the next step that I intend to do, but I've been trying to finish up a project I was working on first, which I think I did last night. So, I should have time later today or tomorrow to close all my programs and reboot my PC. I will probably install any new Windows updates first as well. If this solves my issues, I won't be taking the next step, and I'll let you know.

5) Update my video driver - I will take this step after I reboot my computer.

6) Reinstall Firefox - This will be my last resort, I suppose, if rebooting, updating Windows, and updating my video driver doesn't do the trick. I will save my profile and my history file before doing this because I don't want to lose either one of them.

7) If the Bookmarks sidebar still keeps showing up every time I start FF after the sluggishness and CPU hogging issues are resolved, I will inform you so that you can tell me how to fix that issue as well.

8) Finally, I will, at some point (when I have the time) try some of these same steps on my mother's computer. (I have to do it remotely because she lives 2000 miles away from me.) My wife's computer is working just fine with the new FF update without taking any of these steps (except for rebooting her PC), so my mother's computer should be also because it's several years newer. I'll let you know how this turns out as well.

Okay, Pkshadow, here's a rundown of what I've done and haven't done so far to clear up your confusion: 1) Prevent Accessibility Services - I tried to do this several times, but FF won't let me. Every time I restart FF, the box is checked again. 2) Performance settings - I tried to uncheck this several times and reduce the number of processes to "2" twice, but FF won't let me make these changes either. Every time I restart FF, the "Use recommended performance settings" box is automatically checked. 3) Update to 57.0.2 - I updated to this version prior to submitting my original support request above because I though that it may solve my issues, but it didn't make any difference. 4) Reboot my computer - This is the next step that I intend to do, but I've been trying to finish up a project I was working on first, which I think I did last night. So, I should have time later today or tomorrow to close all my programs and reboot my PC. I will probably install any new Windows updates first as well. If this solves my issues, I won't be taking the next step, and I'll let you know. 5) Update my video driver - I will take this step after I reboot my computer. 6) Reinstall Firefox - This will be my last resort, I suppose, if rebooting, updating Windows, and updating my video driver doesn't do the trick. I will save my profile and my history file before doing this because I don't want to lose either one of them. 7) If the Bookmarks sidebar still keeps showing up every time I start FF after the sluggishness and CPU hogging issues are resolved, I will inform you so that you can tell me how to fix that issue as well. 8) Finally, I will, at some point (when I have the time) try some of these same steps on my mother's computer. (I have to do it remotely because she lives 2000 miles away from me.) My wife's computer is working just fine with the new FF update without taking any of these steps (except for rebooting her PC), so my mother's computer should be also because it's several years newer. I'll let you know how this turns out as well.
cor-el
  • Top 10 Contributor
  • Moderator
16321 solutions 147278 answers

Try to disable accessibility services in Firefox.

Try to disable accessibility services in Firefox. *Options/Preferences -> Privacy & Security -> Prevent accessibility services from accessing your browser *https://support.mozilla.org/en-US/kb/accessibility-services *http://techdows.com/2017/08/firefox-57-prevent-accessibility-services-accessing-browser.html

Question owner

cor-el, I HAVE tried to do that several times, but FF won't let me. I told Pkshadow this repeatedly, but he kept asking me to try this step. Please read the first step listed in my previous post. Thx!

cor-el, I HAVE tried to do that several times, but FF won't let me. I told Pkshadow this repeatedly, but he kept asking me to try this step. Please read the first step listed in my previous post. Thx!
Pkshadow
  • Top 10 Contributor
831 solutions 10392 answers

2) Performance settings - I tried to uncheck this several times and reduce the number of processes to "2" twice, but FF won't let me make these changes either. Every time I restart FF, the "Use recommended performance settings" box is automatically checked.

So how you think you fix this ? Reinstall as suggested.

2) Performance settings - I tried to uncheck this several times and reduce the number of processes to "2" twice, but FF won't let me make these changes either. Every time I restart FF, the "Use recommended performance settings" box is automatically checked. So how you think you fix this ? Reinstall as suggested.
cor-el
  • Top 10 Contributor
  • Moderator
16321 solutions 147278 answers

Chosen Solution

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox

Question owner

I finally was able to reboot my system, but it didn't affect FF's excessive CPU usage at all. So, I tried to backup my bookmarks in preparation for reinstalling FF, but the instructions on the page that PKshadow provided above do not apply to this version of FF. I looked around but couldn't find any menu item for backing up my bookmarks to an HTML file. Isn't there a bookmarks file located in the same folder as the history and profile files? I'll see if I can find it, but in the meantime, I'd like to know where the bookmarks backup menu item was moved to. I'm not reinstalling FF until I have my profile, history, and bookmarks backed up properly.

I finally was able to reboot my system, but it didn't affect FF's excessive CPU usage at all. So, I tried to backup my bookmarks in preparation for reinstalling FF, but the instructions on the page that PKshadow provided above do not apply to this version of FF. I looked around but couldn't find any menu item for backing up my bookmarks to an HTML file. Isn't there a bookmarks file located in the same folder as the history and profile files? I'll see if I can find it, but in the meantime, I'd like to know where the bookmarks backup menu item was moved to. I'm not reinstalling FF until I have my profile, history, and bookmarks backed up properly.
Pkshadow
  • Top 10 Contributor
831 solutions 10392 answers

Mouse to browser top to a empty spot and Right Click, Click Menu Bar. Will find what you need under Bookmarks --> Show All Bookmarks --> Import and Backup --> Export as HTML

Please do follow the instructions for a reinstall as those folders must be deleted.

Please let us know if this solved your issue or if need further assistance.

Mouse to browser top to a empty spot and Right Click, Click Menu Bar. Will find what you need under Bookmarks --> Show All Bookmarks --> Import and Backup --> Export as HTML Please do follow the instructions for a reinstall as those folders must be deleted. Please let us know if this solved your issue or if need further assistance.
cor-el
  • Top 10 Contributor
  • Moderator
16321 solutions 147278 answers

The items to create a backup, either JSON or HTML are still in the same place in the Bookmarks Manager (Library). Only the instruction to open the Bookmarks Manager (Library) are different since there is no longer a toolbar button that includes "Show All Bookmarks".

You can use the Bookmarks menu on the menu bar.

  • you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily
  • Bookmarks -> Show All Bookmarks -> Import & Backup

You can add the "Bookmarks Menu" button that shows the bookmarks in a drop-down list to the Navigation Toolbar via these steps:

  • click the bookshelf 57 library icon icon on the Navigation Toolbar or alternatively use the Library menu in the "3-bar" Firefox menu button New Fx Menu drop-down list
  • click Bookmarks
  • click "Bookmarking Tools", then click "Add Bookmarks Menu to Toolbar"
The Bookmark Menu button Bookmark Menu icon (star on tray) should appear on the Navigation Toolbar.

You can also drag the Bookmarks Menu button from the Customize palette to the Navigation Toolbar

See also "How do I add the Bookmarks Menu button to the toolbar?":

The items to create a backup, either JSON or HTML are still in the same place in the Bookmarks Manager (Library). Only the instruction to open the Bookmarks Manager (Library) are different since there is no longer a toolbar button that includes "Show All Bookmarks". You can use the Bookmarks menu on the menu bar. *you can tap the Alt key or press the F10 key to show the hidden Menu Bar temporarily *Bookmarks -> Show All Bookmarks -> Import & Backup You can add the "Bookmarks Menu" button that shows the bookmarks in a drop-down list to the Navigation Toolbar via these steps: *click the bookshelf [[Image:57 library icon]] icon on the Navigation Toolbar or alternatively use the Library menu in the "3-bar" Firefox menu button [[Image:New Fx Menu]] drop-down list *click Bookmarks *click "Bookmarking Tools", then click "Add Bookmarks Menu to Toolbar" <div>The Bookmark Menu button [[Image:Bookmark Menu icon (star on tray)]] should appear on the Navigation Toolbar. </div> You can also drag the Bookmarks Menu button from the Customize palette to the Navigation Toolbar See also "<i>How do I add the Bookmarks Menu button to the toolbar?</i>": *https://support.mozilla.org/en-US/kb/bookmarks-firefox#firefox:win10:fx57

Question owner

Okay, so I did find out how to backup my bookmarks per both of your instructions above. Thanks! Per cor-el's suggestion, I decided to create a new profile as a test before I went through the trouble of reinstalling FF. But even before I created a new profile, I copied my entire AppData/Roaming/Mozilla folder to a new folder I created named Roaming.temp in the AppData because I have several profiles, and I didn't want to take the risk of corrupting or messing them up. After I created a new profile, I copied my places, session store, and a few other files from my main profile to the test profile. Then I restarted FF and used the history menu to restore the previous session (because I don't have this enabled automatically in the test profile yet). When I checked the CPU usage history under Performance on the Windows Task Manager, there were fewer spikes into the above 50% range than before but still too many. So, I then went through the steps to Prevent Accessibility Services from accessing FF. This time, when I checked the box, a dialog box popped up telling me that I had to restart FF to enable this feature, which I did. After FF restarted, I watched the CPU usage history graph in the Task Manager for several minutes until it gradually settled down to near zero. Since then, it's been below 10-20% until I started typing this reply, and then it would briefly spike up above 50%. So, it appears that there is a problem in my original profile that was the culprit preventing me from turning off the accessibility feature. Do I still need to reinstall FF, or can I just replace my original profiles with new ones and copy the same few files (history, places, and session) from my original profile folder into the new one? I should also mention that I did not update my video driver yet either, but I think I'll still do that because the latest driver is 64-bit, which is what my OS is.

Okay, so I did find out how to backup my bookmarks per both of your instructions above. Thanks! Per cor-el's suggestion, I decided to create a new profile as a test before I went through the trouble of reinstalling FF. But even before I created a new profile, I copied my entire AppData/Roaming/Mozilla folder to a new folder I created named Roaming.temp in the AppData because I have several profiles, and I didn't want to take the risk of corrupting or messing them up. After I created a new profile, I copied my places, session store, and a few other files from my main profile to the test profile. Then I restarted FF and used the history menu to restore the previous session (because I don't have this enabled automatically in the test profile yet). When I checked the CPU usage history under Performance on the Windows Task Manager, there were fewer spikes into the above 50% range than before but still too many. So, I then went through the steps to Prevent Accessibility Services from accessing FF. This time, when I checked the box, a dialog box popped up telling me that I had to restart FF to enable this feature, which I did. After FF restarted, I watched the CPU usage history graph in the Task Manager for several minutes until it gradually settled down to near zero. Since then, it's been below 10-20% until I started typing this reply, and then it would briefly spike up above 50%. So, it appears that there is a problem in my original profile that was the culprit preventing me from turning off the accessibility feature. Do I still need to reinstall FF, or can I just replace my original profiles with new ones and copy the same few files (history, places, and session) from my original profile folder into the new one? I should also mention that I did not update my video driver yet either, but I think I'll still do that because the latest driver is 64-bit, which is what my OS is.

Question owner

Something else I forgot to mention. The bookmarks sidebar is not appearing anymore every time I restart FF like it was before. So, that problem was solved as well by creating a new profile. Regarding the Prevent Accessibility Services, I do have Norton Anti-virus installed on my computer, which has asked to install an add-on or something like that so that it can monitor my browsing activities to warn me about dangerous websites, etc. If I approve Norton's request the next time it asks to do this, will it turn the Prevent Accessibility Services back on?

Something else I forgot to mention. The bookmarks sidebar is not appearing anymore every time I restart FF like it was before. So, that problem was solved as well by creating a new profile. Regarding the Prevent Accessibility Services, I do have Norton Anti-virus installed on my computer, which has asked to install an add-on or something like that so that it can monitor my browsing activities to warn me about dangerous websites, etc. If I approve Norton's request the next time it asks to do this, will it turn the Prevent Accessibility Services back on?
Pkshadow
  • Top 10 Contributor
831 solutions 10392 answers

No sounds good. The 2nd part some where as this is getting long is if still bad usage of ram : Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

I did this my self and went down for a few days then went back up and is now settled into under 2 gigs of ram and performing just fine.

If you need more ram will have to look for savings else where and turn off things that do not need to start at boot.

Increase Virtual Ram : You may want to try this: Open the System Folder then Click on left side Advanced System Settings which opens System Properties click the Advanced Tab then click Performance button Settings then the Advanced Tab then Click the Change under Virtual Memory click Custom Size and Change Size to where it says Recommended Size then Click Set and then Click Apply then please Re-boot.

System - -> Advanced System Settings --> System Properties - -> Advanced Tab - -> Change Virtual Memory - -> Custom Size - -> ENTER Recommended Size - -> Set - -> Apply-- > Reboot

NOTE : the recommended settings are greyed out. You enter this number in both the Min and Max boxes.

Please let us know if this solved your issue or if need further assistance

No sounds good. The 2nd part some where as this is getting long is if still bad usage of ram : Go the 3 Bar Menu then Options --> General --> Performance and untick everything. change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. I did this my self and went down for a few days then went back up and is now settled into under 2 gigs of ram and performing just fine. If you need more ram will have to look for savings else where and turn off things that do not need to start at boot. Increase Virtual Ram : You may want to try this: Open the System Folder then Click on left side Advanced System Settings which opens System Properties click the Advanced Tab then click Performance button Settings then the Advanced Tab then Click the Change under Virtual Memory click Custom Size and Change Size to where it says Recommended Size then Click Set and then Click Apply then please Re-boot. System - -> Advanced System Settings --> System Properties - -> Advanced Tab - -> Change Virtual Memory - -> Custom Size - -> ENTER Recommended Size - -> Set - -> Apply-- > Reboot NOTE : the recommended settings are greyed out. You enter this number in both the Min and Max boxes. Please let us know if this solved your issue or if need further assistance

Question owner

I have both FF and Chrome running at the same time---three windows for each, but FF has 100+ tabs and Chrome has about 50 tabs---and my total RAM usage is 5.13 GB out of 6 GB total. Without either one running, I was a little over 3 GB. So, RAM usage doesn't appear to be a problem, but I'll still try what you suggested with the performance change, etc. I should also tell you that I noticed that my original profile folder has 9999 prefs.js files in it, and most of them (from #191 onward) are dated 11/30/17, which is around the time that I upgraded FF to the new version. Prior to that, the dates keep decreasing (sometimes one older date for each lower-numbered prefs.js file) back to 8/7/17. I wonder what caused this and if this is how my profile folder got corrupted.

I have both FF and Chrome running at the same time---three windows for each, but FF has 100+ tabs and Chrome has about 50 tabs---and my total RAM usage is 5.13 GB out of 6 GB total. Without either one running, I was a little over 3 GB. So, RAM usage doesn't appear to be a problem, but I'll still try what you suggested with the performance change, etc. I should also tell you that I noticed that my original profile folder has 9999 prefs.js files in it, and most of them (from #191 onward) are dated 11/30/17, which is around the time that I upgraded FF to the new version. Prior to that, the dates keep decreasing (sometimes one older date for each lower-numbered prefs.js file) back to 8/7/17. I wonder what caused this and if this is how my profile folder got corrupted.
cor-el
  • Top 10 Contributor
  • Moderator
16321 solutions 147278 answers

You can delete all numbered prefs-##.js files and only leave the main prefs.js file. When the are numbered files like that present then this means that Firefox wasn't able to rename this numbered temp file to the main file. Normally there shouldn't be any such numbered temp files left.

Do you have more such numbered files?


Maybe time to try a new profile folder like I wrote above if you haven't tried this already if the have been such issues in the past.

You can delete all numbered prefs-##.js files and only leave the main prefs.js file. When the are numbered files like that present then this means that Firefox wasn't able to rename this numbered temp file to the main file. Normally there shouldn't be any such numbered temp files left. Do you have more such numbered files? ---- Maybe time to try a new profile folder like I wrote above if you haven't tried this already if the have been such issues in the past.