Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox wont play Youtube Live Streams

  • 15 replies
  • 75 have this problem
  • 677 views
  • Last reply by Moriz

more options

Firefox wont play Youtube Live Streams

Youtube videos work ok, but any live stream wont play. I have tried Firefox 56 and 57, both same problem. Even without extensions the problem continues. Nothing changed on browser, just stoped working.

https://imgur.com/LwXbIvr

All Replies (15)

more options

It's happening with this channel. And no others.

https://www.youtube.com/watch?v=0tek2aa8hAQ

more options

A2020 said

It's happening with this channel. And no others. https://www.youtube.com/watch?v=0tek2aa8hAQ

I get a error message. So it is that URL/That Video is down.

Please let us know if this solved your issue or if need further assistance.

more options

Pkshadow said

A2020 said
It's happening with this channel. And no others. https://www.youtube.com/watch?v=0tek2aa8hAQ

I get a error message. So it is that URL/That Video is down.

Please let us know if this solved your issue or if need further assistance.

I can watch that channel video on other browsers like Opera and Chrome. It's just Firefox doing it.

If you search "tn en vivo" that's the channel. Also I get the error on their official website.

https://tn.com.ar/envivo/24hs

Never happened before, it always worked perfectly. That's why I'm not sure what's going on. On other PC where I tried the error said something about the browser not supporting HTML5 player.

more options

After removing old Firefox and all the leftover folders, installed Firefox 57 and now he video works.

more options

And... The error is back. I guess it's Youtube messing something?

more options

I keep getting the error myself, Reported the error and they give this :

https://support.google.com/youtube/topic/3014746

Please let us know if this solved your issue or if need further assistance.

more options

Same issue for me. Only some live streams break...some of the time. Reason I say that is because Sky News recently started working for me again. Due to the wide sporadic nature of reports so far (I'm assuming most people aren't updating to 57 because it breaks their extensions)...I'm assuming this is hw-related.

more options

Same Issue, started after I installed Firefox 57.0. Unable to watch live streams most of the time, on rare occasions it does work. Tried with many live streams, the problem is persistent. Chrome is working on all videos.

Modified by tshachaf

more options

A2020 said

Firefox wont play Youtube Live Streams Youtube videos work ok, but any live stream wont play. I have tried Firefox 56 and 57, both same problem. Even without extensions the problem continues. Nothing changed on browser, just stoped working. https://imgur.com/LwXbIvr

when i play sky news' stream with mpv via command line i get this throughout:

[ffmpeg] tls: The TLS connection was non-properly terminated. (Buffering) AV: 00:00:04 / 00:00:00 A-V: 0.000 Cache: 0s+2MB [ffmpeg] tls: The TLS connection was non-properly terminated. [ffmpeg] tls: The specified session has been invalidated for some reason.

has youtube made changes where it works in chrome/webkit/blink but not in others?

more options

magicsocks said

A2020 said
Firefox wont play Youtube Live Streams Youtube videos work ok, but any live stream wont play. I have tried Firefox 56 and 57, both same problem. Even without extensions the problem continues. Nothing changed on browser, just stoped working. https://imgur.com/LwXbIvr

when i play sky news' stream with mpv via command line i get this throughout:

[ffmpeg] tls: The TLS connection was non-properly terminated. (Buffering) AV: 00:00:04 / 00:00:00 A-V: 0.000 Cache: 0s+2MB [ffmpeg] tls: The TLS connection was non-properly terminated. [ffmpeg] tls: The specified session has been invalidated for some reason.

has youtube made changes where it works in chrome/webkit/blink but not in others?

Maybe. Right click and copy the debugging info on Sky and see if the related error is webm-based.

more options

hey-bud said

magicsocks said
A2020 said
Firefox wont play Youtube Live Streams Youtube videos work ok, but any live stream wont play. I have tried Firefox 56 and 57, both same problem. Even without extensions the problem continues. Nothing changed on browser, just stoped working. https://imgur.com/LwXbIvr

when i play sky news' stream with mpv via command line i get this throughout:

[ffmpeg] tls: The TLS connection was non-properly terminated. (Buffering) AV: 00:00:04 / 00:00:00 A-V: 0.000 Cache: 0s+2MB [ffmpeg] tls: The TLS connection was non-properly terminated. [ffmpeg] tls: The specified session has been invalidated for some reason.

has youtube made changes where it works in chrome/webkit/blink but not in others?

Maybe. Right click and copy the debugging info on Sky and see if the related error is webm-based.

i'm getting this:

"debug_error": {

   "errorCode": "fmt.unplayable",
   "errorDetail": "mediaElem.1;msg.NS_ERROR_FAILURE (0x80004005) - virtual mozilla::MediaResult mozilla::WebMContainerParser::IsInitSegmentPresent(mozilla::MediaByteBuffer*): Invalid webm content",
   "message": "An error has occurred. Please try again later.",
   "messageKey": "YTP_ERROR_GENERIC_WITHOUT_LINK"
 },

what's the easiest and quickest way to change my user agent without using an addon?

more options

Hi! On my PC, with FF 57 and webm & vp9 enabled, the others live stream videos works fine, for instance this one : https://www.youtube.com/watch?v=AQBh9soLSkI

But it may have a small FF bug with your live video... you can report it on bugzilla.mozilla.org ;)

more options
more options

Setting media.webm.enabled to false in about:config makes streams play for now. Though you might want to wait until the bug is fixed, instead of disabling webm completely...

more options

The Firefox browser still has an error message:

  • Does H.264 playback depend on your hardware and operating system compatibility? What does that mean? What should I do or change on my computer?